
Lesson 7 Date a nd T ime F unctions

and I nsert F unction

Les s on Topics
Date and Time Functions and Formats

The Insert Function Dialog Box

Les s on Objectives
At the end of the lesson, you will be able to:

Explain the importance of the serial date;

Use the NOW function to display the current date and
time;

Use the Date and Time formats to format cells;

Use the DATE and TIME functions to enter fixed dates and
times;

Use date and time values in calculations;

Use the Insert Function dialog box to enter functions and
their arguments in a workbook.

Student Files Used
You will use the following files from your student folder:

Invoices 1

Invoices 2
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Date and
Time
Functions
and
Formats

There are several functions that let you display dates. Excel thinks
of a date as the number of days from January 1, 1900 to the nearest
second. This is called a serial date. Since this is not the way humans
think of dates, the number can be formatted to look like a standard
date.

The NOW
Function

The NOW function displays the current date and time, which is
updated each time the workbook is opened or when Excel
calculates the other formulas in the document.

1. Open a new workbook.

2. Change the Standard Width to 15. (On the Format
menu, point to Column, choose Standard Width,
change the Standard Width to 15 and click OK.)

3. In A1, type =NOW() and then tap the ENTER key.

The current date and time appear in the cell. For the
time, Excel is using the 24-hour clock. For example,
9:35 AM is displayed as 9:35. After 12:00 noon, the
numbers keep increasing — 1:00 PM, for example, is
13:00 and 4:55 PM is 16.55.

4. The date and time are appearing in readable format,
because Excel has automatically formatted the cell with
a Date format. If you remove the formats from this cell,
the General format will be applied.

Go to A1.

5. On the Edit menu, point to Clear.

6. On the submenu, choose Formats.

A relatively large number appears in the cell. This is
the serial date. The numbers to the left of the decimal
point are the number of days since January 1, 1900.
The numbers to the right of the decimal point
represent the fraction of a day that has passed since
midnight. The Serial date is what Excel uses to
perform date and time calculations.

Tip: You can use CTRL/; (semicolon) to enter the
current date in a cell. Unlike the NOW() function,
this date will not be updated.
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Date Formats The Number tab contains predefined date formats, which you can
apply to cells. You are going to apply different Date formats to A1.

1. A1 should be the active cell.

2. On the Format menu, choose Cells.

3. If necessary, click the Number tab.

4. In the Category list box, choose Date.

In the Type list box, notice the different date formats.

5. In the Type list box, choose the 3/14/01 option.

At the top of the dialog box, notice the sample date.
It will be the date you are taking this lesson.

6. Click OK.

Notice that the serial date has been formatted to
something more recognizable.

7. You are going to see samples of the other Date
formats.

On the Format menu, choose Cells.

8. Verify that the Number tab is displayed, and that
Date is selected in the Category list box.

9. In the Type list box, scroll down and choose the
March 14, 2001 format.

In the Sample box, notice today’s date.

10. Choose three other formats and see how the
sample changes.

11. Click Cancel.
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Once you choose a format for a particular cell, you can enter the
date in any recognizable format " Excel will then convert it to the
format of the cell. You are going to format B1 with a particular date 
format and then enter a date with a different date format.

1. Go to B1.

2. On the Format menu, choose Cells.

3. In the Category list box of the Number tab, choose
Date.

4. In the Type list box, choose the March 14, 2001
format.

5. Click OK.

6. In B1, type 8/12 and then tap the ENTER key.

Notice the contents of the cell. Since the cell has been 
formatted with a long date format, Excel converted
8/12 into August 12, 2007 (or whatever the current
year is).

Remember, Excel treats the date as a number. If you enter a
number into a cell that has been formatted with the Date category,
Excel will assume that you are entering a serial date and will then
convert it to a more recognizable format. You are going to enter
some numbers into B1.

1. Go to B1.

2. Type 2 and then tap the ENTER key.

Notice the results. Since the cell has the Date format
applied to it, Excel assumed that the number you
entered was a serial date. Therefore, it converted the 
serial date into a more recognizable format. Since
the serial date is the number of days from January 1,
1900, a serial date of 2 translates to January 2, 1900.

3. Type different numbers (i.e., serial dates) into B1
and notice the date change. (Include decimal
points and notice that Excel includes the time on
the Formula bar.)

Note: It is not necessary to use the Format Cells
dialog box to apply a date format to a cell. You can
enter a date directly into a cell and the cell will
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automatically have a date format. The resulting
format may not always be as expected, however, so
it is usually easiest to use the Format Cells dialog
box when choosing date formats.

Time Formats Excel has predefined time formats. You are going to apply different 
Time formats to A2.

1. Go to A2.

2. If you enter a value in one of Excel’s time formats, the
cell will be formatted automatically using the Time
category.

Type 4:35 AM and use CTRL/ENTER to stay in the
cell.

Excel has formatted the cell. It assumes that you
want a time format and it applies one to the cell.

3. The Formula bar not only displays the time, but
seconds also.

In A2, notice the time on the Formula bar (4:35:00
AM). The last two zeros are for seconds, if there are 
any.

4. You are going to change the time format.

A2 should be the active cell.

5. On the Format menu, choose Cells.

6. On the Number tab, choose Time in the Category list 
box.

In the Type list box, notice the different time formats.

7. In the Type list box, choose the 13:30 time format.
This format uses the 24-hour clock.

In the Sample box, notice the sample time.

8. Click OK.

Notice how the current time is displayed. AM has
been removed from the format although the
Formula bar displays AM.

9. In A2, type: 7:30 PM and click the check box.
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Notice that 19:30 is displayed. The Formula bar,
however, uses the standard time convention
(7:30:00 PM).

10. On the Format menu, choose Cells.

11. Verify that Time is selected in the Category list box.

12. In the Type list box, choose some of the other time
formats and notice how the time is displayed in
the Sample box.

13. Click Cancel.

Note: Always keep in mind that Date and Time
formats are like all other formats. They can be
copied and cleared.

Fixed Dates
and Times

The DATE and TIME functions let you enter fixed dates and times
that will not change and can then be used in calculations. You enter 
them this way:

=DATE(year,month,day)

=TIME(hour,minute,second)

1. Go to A3.

2. Type =DATE(05,7,22)and use CTRL/ENTER.

The following information is enclosed within the
parentheses: 

      (2005,7,22)

Notice that the cell is automatically formatted with a 
format in the Date format category that uses a year" 7/22/2005 appears in the cell.

Note: Using the DATE function, you must type four
digits for years after 1999 — otherwise, Excel will
assume 05 means 1905. (This is not true when you
simply type a date into a cell, such as 5/5/09. In this
case, Excel interprets and formats the year as 2009.)

3. You are going to type a fixed time.

Go to A5.

4. Type =TIME(13,9,0) and use CTRL/ENTER.
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The following information is enclosed within the
parentheses:  
      (13,9,0)

Notice that the cell is automatically formatted with a 
Time format — 1:09 PM appears in the cell.

5. Go to A6 and type another fixed time. Remember
to add 12 to any time after 1 PM. Format the cell
with the Time format of your choice.

6. Close the workbook. It will not be used again.

Tip: You can use CTRL/SHIFT/: (colon) to enter the 
current time in a cell.

Date
Calculations

Since Excel treats dates as numbers, you can use them in
calculations. You are going to do this with the workbook Invoices 1.

1. Open Invoices 1.

2. Notice that the dates have not been formatted. You are
going to format the cells containing dates.

Select B6:D11.

3. On the Format menu, choose Cells.

4. If necessary, click the Number tab.

5. In the Category list box, choose Date.

6. In the Type list box, choose the 14-Mar-01 format.

7. Click OK.
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Notice the formatted dates. Although 07 appears in
the cell as the date because that is the format chosen, 
2007 appears on the Formula bar since the year is
greater than 1999.

8. You are going to calculate the Due Date, which is 30
days from the Invoice Date.

Go to C6.

9. Type =B6+30 and tap the ENTER key.

11-Nov-07 appears in the cell. It displays as a date,
because you set this cell to a date format a moment
ago.

10. Copy this formula to C7:C11.

11. You are going to find out how long it took to get paid.

Go to cell E6.

12. Type =D6-B6 and tap the ENTER key.

The result of the formula is a number (23), because
this cell is not formatted as a date.

13. Copy the formula in cell E6 to the range E7:E11.

Your screen should look like the following:

The Insert
Function
Command

Rather than type a function manually, you can use the Insert
Function to enter a function. It is often easier. You are going to use
the Insert Function command to create a formula that determines if 
the payment was late.

1. Open Invoices 2. It should be the same as your
Invoices 1 after you made changes to it in the last
section.
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2. Go to F6.

3. On the Insert menu, choose Function.

The Insert Function dialog box appears. 

The Or select a category drop-down list box lists the
broad categories of functions. When Most Recently
Used is chosen in the Or select a category box, the last
ten functions used will be displayed in the Select a
function list box below. When All is chosen in the Or
select a category box, every function in every category 
is displayed in the function box.

4. The Search for a function box is useful if you don't
know what category to look in.

In the Search for a function box, highlight the text,
type date and tap the ENTER key.

Notice the Date and
Time functions listed
in the Select a function
list box. Three of these
functions you already
know — DATE, NOW,
and TIME. Underneath 
the list box, notice the
description of the
selected function. In the lower left corner of the
dialog box, the Help on this function  hyperlink will
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show you the Microsoft Excel Help window with a
topic on the selected function.

5. You are going to write the following IF test:
=IF(E6<=30,”On time”,”Overdue”)

In the Or select a category list box, choose Logical.

Notice the list of Logical
functions.

6. In the Function name list box, 
select IF.

Below the list boxes, notice
the description and the
syntax of the IF function.

7. Click OK.

The second dialog box appears. This is the Function
Arguments dialog box. You can move this box
around if you need to see items on the worksheet
underneath it. You can also click a Collapse dialog
button at the right of each text box to temporarily
replace the dialog box with the text box. Clicking the 
same button on the text box restores the dialog box. 

Notice that Excel has already begun to enter the
formula on the Formula bar and in F6.

8. In the Logical_test text box, type: E6<=30
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Notice that the actual result of the logical test,
TRUE, appears to the right of the text box.

9. Tap the TAB key.

10. You are going to write the true result. You do not need
to type text in quotes. Excel inserts them for you.

Type On Time and then tap the TAB key.

Notice that Excel added the quotation marks.

11. For the false result, type Overdue and tap the TAB
key.

The three text boxes should look like this:

Also notice, near the bottom of the dialog box,
Formula Result = On Time.

12. Click OK.

Notice On Time in F6 and the function on the
Formula bar.

13. Copy the function to F7:F11.

Notice the results.

Note: When you choose the
Insert Function command, the
Insert Function dialog box
appears unless the active cell contains a function, in
which case the Function Arguments dialog box
appears.

There is an Insert Function button on the Formula bar, which is an
alternative to the Insert Function command. As with the Insert
Function command, the button displays the Function Arguments
dialog box if the active cell already contains a function.

1. Click in an empty cell.

2. Click the Insert Function button on the
Standard toolbar.
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Notice the Insert Function dialog box.

3. Click Cancel.

4. Go to F6.

5. Click the Insert Function button.

Notice the Function Arguments dialog box.

6. Click Cancel.

End of Lesson 7
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