
Lesson 3 P otpourri

Les s on Topics
The Fill Command

Wrapping Text

View Options

Edit Options

Other Fill Handle Uses

Les s on Objectives
At the end of the lesson, you will be able to:

Use the Fill command to repeat a character in a cell;

Wrap text within a cell;

Place overflow text of the active cell into cells below;

Display formulas in the cells and use the Formula
Auditing toolbar to help correct problems with formulas;

Understand and modify options on the View tab;

Use the Fill handle to create sequences in a range of cells;

Create custom lists of sequences to be used in a range of
cells.

Student Files Used
You will use the following file from your student folder:

Dairy 4
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The Fill
Command

The Fill command on the Alignment tab of the Format Cell dialog
box lets you repeat a character until it fills the width of the cell. You 
are going to repeat X’s, which you might want to do for a cell that
will be filled in later.

1. Open a new workbook.

2. In A1, type X and click the check box 
on the Formula bar.

3. With A1 the active cell, choose Cells
on the Format menu.

4. Click the Alignment tab.

The Alignment tab appears. 

5. Click the Horizontal box and choose the Fill option.

6. Click OK.

Notice the X’s that fill the cell.

7. If you change the width of the column, 
the X’s will automatically fill the cell.

Drag the column separator between columns A and 
B until the width of column A is 25.

Notice that A1 is still completely filled with X’s.

8. On the Format menu, choose Cells.

9. On the Alignment tab, click the Horizontal box and
choose the General option to turn off Fill.

10. Click OK.

Only a single X appears in A1.

11. Delete the contents of A1.

Wrapping
Text

Three commands allow you to wrap text — Justify and Wrap Text
on the Alignment tab, and Justify on the Fill submenu of the Edit
menu. We will begin with the two on the Alignment tab.

1. The Justify option on the Alignment tab expands text
within a cell. Excel ends all lines at the same place and
increases the row height so that there is enough room
to hold the text as it wraps around.

You can use the same empty workbook as before.
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2. Column A should have a width of 25. If it does not,
change the width.

3. In A1, type: This text is going to be wrapped by
choosing different options on the Alignment tab.

4. Click the check box.

At the moment, the text spills into adjacent columns
because they are empty. 

5. Verify that A1 is the active cell.

6. On the Format menu, choose Cells.

7. The Alignment tab should be displayed.

8. In the Horizontal box, choose Justify.

9. Click OK.

Notice that the text 
has wrapped
within the cell and 
is aligned between 
the left and right
edges of the cell.
Excel has changed the row height so that there is
enough room to hold the text.

The Wrap text option on the Alignment tab wraps text within a cell
but does not end each line at the same position.

1. Verify that A1 is still the active cell.

2. On the Format menu, choose Cells.

3. Verify that the Alignment tab is displayed.

4. In the Horizontal box, choose the General option to
turn off Justify.

Note: The Wrap text option will have no effect if the
horizontal alignment is set at Justify.

5. Choose the Wrap text option 
at the bottom of the dialog box 
and click OK.
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Notice that the text is wrapped, but the lines do not
end at the same place.

The Justify command (on the Fill submenu of the Edit menu) works 
differently than the Justify option on the Alignment tab. This
command wraps text to the rows below or to a selected range of
cells. The row height will not change, and any information in cells
to which the text is being wrapped will be overwritten.

1. A1 should be the active cell.

2. On the Edit menu, point to
Fill.

Notice the submenu.

3. On the submenu, choose
Justify.

The following alert box
appears indicating that 
text will extend below the
selected range.

4. Click OK.

5. Click to remove the highlight.

Notice that only one line of text remains in A1. The
other lines of text have been distributed to the cells
below.

6. Go to each cell in column A that has text and
notice that the text is actually in that cell — Excel is 

34 Microsoft Excel 2003 - Intermediate



not temporarily using the cells to display text, as it 
does with empty cells to the right.

7. Close the workbook without saving changes.

View
Options

By using options on the View tab of the Options dialog box, you
can change the way individual worksheets look on the screen —
the options do not affect the way worksheets look when printed.
By using the Edit tab, you can change the way you use Excel. You
are going to look at the options on both of these tabs.

1. Open Dairy 4.

2. On the Tools menu, choose Options.

3. If necessary, click the View tab.

Notice the Window options group on the View tab.

4. When the Formulas option is chosen in the Window
options box, the formulas are displayed, rather than the 
result of the formulas. This can help you find errors.

Select Formulas and then click OK.

Notice that the formulas (such as those in row 14)
are displayed. Also notice that the width of the
columns adjusts to accommodate the formulas.

The Formula Auditing toolbar also appears.

The Formula Auditing toolbar helps you to correct problems with
the formulas in your worksheet. You are going to use some of its
features.

1. Scroll through the worksheet and notice the
formulas.
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If your worksheet has many formulas, this view
helps you to edit them.

2. Click in B31.

Notice the blue outline around the range that is
designated in the SUM formula.

3. On the Formula Auditing toolbar, click the 
Trace Precedents button. 

An arrow is drawn, starting
from the beginning 
of the range and ending at
your formula.

4. Click the Remove 
Precedent Arrows 
button.

5. Click the Trace 
Dependents 
button.

Notice the arrow pointing down to B33. This means
that a formula in B33 depends on the result of B31
(the active cell). 

6. There is also an arrow pointing right, but its end is
hidden.

Scroll right until you see columns H through L. 

Notice the arrowheads. These four cells depend on
the result of the formula in B31.

7. Click the Remove Dependent Arrows button.

Other buttons on the Formula Auditing toolbar
include Trace Error, Edit Comment, Error Checking,
and Circle Invalid Data. Unless you have very
complex formulas, the buttons you have just used
are the most helpful.

You are going to see some of the other options on the View tab.

1. On the Tools menu, choose Options.

Following is a discussion of some of the other items
in the Window options group:
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! Page breaks. Displays the page breaks that have
been automatically set.

! Gridlines. Displays the gridlines on the screen.
You can use the Color drop-down list box to
choose the color of the gridlines on the display.
Be aware that neither of these options affect the
printing of the gridlines. To do this, you must
use the Sheet tab of the Page Setup dialog box.

! Row & column headers. De-selecting these options 
can give you more room on the screen.

! Outline symbols. If you use Excel to create an
outline, this option can be used to hide or
display the outline symbols that are used.

! Zero values. When this is turned off, cells that
contain a zero value will be blank (even if the
zero is the result of a formula). The formula
remains, however, and if in the future the result
of it is something other than zero, the result will
be displayed.

! Horizontal scroll bar, Vertical scroll bar, Sheet tabs.
You can use these options to decide which of
these items are displayed on your screen.

2. De-select the Formulas option.

3. Click OK.

Notice that the formulas are no longer displayed
and the worksheet returns to its original column
widths.

Tip: You can toggle formulas on and off by holding
down the CTRL key and tapping the key with the
tilde (~) on it. On most keyboards, this key is above
the TAB key. For convenience, we are going to
notate this keystroke as CTRL/~, even though the
tilde is typed with the SHIFT key, which you do not
use in this case. (As you may know, CTRL/SHIFT/~ 
applies the General format to the selected cells.)
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Edit Options The Edit tab on the Options dialog box provides options for
entering and editing text.

1. On the Tools menu, choose Options.

2. Click the Edit tab.

Notice the options on the Edit tab.

! Edit directly in cell. This option allows you to edit 
directly in the cell, instead of only on the
Formula bar.

! Allow cell drag and drop. This option allows you
to move and copy cells by dragging the
selection. Since this can produce undesired
results at times, it is often a good idea to select
the Alert before overwriting cells option as well.

! Move selection after Enter. This option tells Excel
to make another (adjacent) cell active when the
ENTER key is tapped in a cell. You can use the
Direction drop-down list box to specify how
Excel should move to make the next cell active.

! Fixed decimal. This option tells Excel where it
should place a decimal point as you enter a
number. For example, if the fixed decimal is 2
and you type 1245, the number will be entered,
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12.45. If you type 8, it will be entered, 0.08. You
can override this setting by typing a decimal
manually.

Note: The remaining options on the Edit tab are
advanced features.

3. Click Cancel.

4. Close Dairy 4 without saving the changes.

Other Fill
Handle Uses

Up to now, you have used the Fill handle to copy formulas. It can
also be used to create sequences in a range of cells.

1. Open a new workbook.

2. In A1, type 5 and use CTRL/ENTER.

3. You are going to copy this down to A10 by using the
Fill handle.

Point to the Fill handle.

4. Drag down to A10.

As expected, the 5 was copied to each cell.

5. You are now going to copy a sequence of numbers that 
increase by five.

In B1, type: 5

6. In B2, type: 10

7. Select B1:B2.

8. Point to the Fill handle and drag
down to B10.

Notice that a sequence was created.
Each cell was increased by 5, 
because that is what occurs 
between B1 and B2.

As you dragged, a ToolTip indicated 
the last number in the series.

9. If you want to copy the contents of the
cells but not the sequence, hold down
the CTRL key as you drag.

In C1, type: 5
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10. In C2, type: 10

11. Select C1:C2.

12. Point to the Fill handle until the pointer turns into
a crosshair.

13. Hold down the CTRL key.

Notice the little + mark next to the pointer. This
indicates that the range is going to be
copied.

14. While holding the CTRL key, drag the
Fill handle to C10.

You have copied the range.

The sequences that you create with the Fill handle do
not have to be numeric. You are going to create a
sequence of months.

1. Go to D1 and type: Jan

2. Use the Fill handle to fill the months Jan through
Dec. Watch the ToolTip and re lease when it says
Dec.

Notice the sequence. Excel assumes that you want to 
create the sequence of months and fills
in the cells accordingly. Notice that the
month format that Excel used for the
sequence (i.e., abbreviations) matches
what you initially used in the cell.

In general, you have to type at least
two consecutive cells to establish a
sequence. For example, you would
have to type 8 in one cell and 16 in
another to increase each cell by 8.
However, with months, you only have
to type one month. This is also true of days of the
week, which you will learn about shortly.
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The AutoFill
Options
SmartTag

When you use the Fill handle, Excel provides a way of changing its
behavior with a SmartTag — the small button (icon) that appears
below the filled range.

1. In E1, type 1 and use CTRL/ENTER.

2. Drag the Fill handle down to E10.

All ten cells contain 1. Notice the AutoFill 
Options SmartTag.

3. Click the AutoFill Options SmartTag.

Notice the options.
Copy Cells is the default
and the option you just used.

4. Click the Fill Se ries op tion.

Excel changes the range to the
numbers 1 through 10. You did not have to type a
sequence as you did when you entered 5 and 10,
respectively, in B1 and B2.

5. Click to remove the highlight.

Custom Lists The reason you can copy a sequence of months with the Fill handle
is that this sequence (or series) has been defined as a Custom List.
There are four Custom Lists that come with Excel — Jan, Feb, Mar,
etc. (which you have just used); January, February, March, etc.; Sun,
Mon, Tue, etc.; and Sunday, Monday, Tuesday, etc. With all of these,
you have only to type one entry into a cell and then use the Fill
handle to complete the sequence. In addition to these lists, you can
create your own Custom Lists.

1. On the Tools menu, choose Options.

2. Click the Custom Lists tab.

In the Custom Lists list box, notice the four defined
lists. The NEW LIST option lets you define your 
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own list. If there are any other lists, they have been
created by another user.

3. In the Custom Lists list box, click the Sun, Mon, Tue,
Wed list.

Notice the list that appears in the 
List entries box.

4. Click the other entries and notice 
the lists that appear in the List 
entries box.

5. You are going to create a custom list 
that might be used in an order form.

In the Custom lists list box, click NEW LIST.

The insertion point appears in the List entries text box.

6. Type the following list. At the end of each line, tap
the ENTER key. Each entry has to be on a separate
line.

Subtotal
Shipping
C.O.D. Orders
Rush Delivery
Sales Tax
Total

7. When you are finished, click the Add button.

Your list is added to the Custom lists list box.

8. Click OK.

9. You are going to use your new list.

Go to F1.

10. Remember, if you are copying a Custom List, only the
first entry needs to be typed.

Type Subtotal and use CTRL/ENTER.

11. Use the Fill handle to drag to F6.

Notice the list.

12. You are going to delete your custom list.

On the Tools menu, choose Options.

42 Microsoft Excel 2003 - Intermediate



13. Verify that the Custom Lists tab is displayed.

14. In the Custom lists list box, select your list.

15. Click the Delete button.

Excel displays an
alert box.

16. Click OK.

The list is removed.

17. Click OK to return to the workbook.

Notes Rather than type a custom list in the List entries text box, as
you did, you can type it into a worksheet. Merely highlight
the range and choose the Custom Lists tab on the Options
dialog box. Click the Import button, and the list will be
added to the Custom lists list box.

You can also use the Fill handle to copy dates, such as 1/5/04.
Excel assumes an increment of 1 (day) and will display
1/6/04, 1/7/04, etc. You can also type a sequence such as
1/7/05, 1/14/05, etc., if you want to skip every seventh day.
These dates do not have to be a Custom List. This is because
a number format is assigned to the date when you enter it
into a cell. The date then becomes a value, and all values can
be copied as a sequence.

If you use the right mouse button to drag the Fill handle, a
Shortcut menu will appear when you release. On the menu
will be choices to fill the selected range with Series, Days,
Weekdays, etc.

Once a list has been entered in the cells, it will repeat itself if
you keep dragging. For example, if a list contains 10 items
and you drag through 15 cells, the list will start over after the 
first 10 cells.

End of Lesson 3
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