
Lesson 9 M odifying a  W ork book

Les s on Topics
Inserting Rows and Columns

Deleting Rows and Columns

Inserting and Deleting Cells

Les s on Objectives
At the end of the lesson, you will be able to:

Insert and delete rows and columns using the menu
commands, the Insert dialog box, and the Delete dialog
box;

Explain the need for caution when inserting and deleting
rows above or below a selection;

Use the Insert dialog box or the Delete dialog box to
insert and delete cells.

Student Files Used
You will use the following files from your student folder:

Miller’s Shoes 4

Student Report

Student Files Crea ted
You will not save any new files to your student folder.
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Inserting
Rows and
Columns

Rows and columns can be inserted with the Insert command and
deleted with the Delete command.

Inserting
Rows

When inserting rows, select the rows that will follow the new ones.
You are going to use the Miller’s Shoes 4 workbook for this lesson.

1. Open Miller’s Shoes 4.

2. Click the row 7 heading  
to select all of row 7.

This row will follow the new row.

3. On the Insert menu, choose Rows.

One blank row is inserted above the Men row. Your
screen should look like the following:

Note: You can ig nore for now the Smart Tag that
ap pears. It will be ex plained shortly.

4. Excel automatically makes adjustments to a range when 
you add or delete rows and columns.

Go to B11, C11, and D11 and notice on the Formula 
bar that the range of these formulas now includes
rows 6 - 10. Previously it consisted of rows 6 - 9.

Note: The blank row above the to tal has been
in cluded in the for mu las be cause the AutoSum
but ton was used to en ter the for mu las.

5. Go to some cells in rows 17 - 20 and notice that the 
range has expanded to rows 6 - 9. Previously it
was rows 6 - 8.

Notice that the blank row is not included in these
formulas. This is because the AutoSum button was
not used to enter them.

6. Go to A7.

7. Type: In fant
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8. Tap the TAB key or the RIGHT ARROW key to go to
B7.

Notice that Infant is right-aligned because that is the
format of the cell above it.

9. In B7, type 600 and tap the TAB key.

Notice the results change in the respective cells with
formulas.

10. In C7, type 650 and tap the TAB key.

11. In D7, type 700 and tap the ENTER key.

Notice the changed values.

You are going to insert two rows above row 9. 

1. Use the row headings to select rows 9 and 10.

Two rows are selected, which tells Excel to insert
two rows above this range.

2. On the Insert menu, choose Rows.

Two rows are inserted. Notice that the active cell is
A9. This is helpful, because you often want to enter
information into the new row immediately after
inserting it.

3. Type the following text and values into the new
cells (there is no need to type the commas):

Notice that the text in A9 and A10 is right-aligned
because that is the format of the highlighted cells
above. Similarly, the values have the same format as
those in the cells below.

4. Go to a few cells containing formulas and notice
that the range has been extended.
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You do not have to select entire rows before inserting. You need
only select one cell in each row. You are going to insert three rows
above Infant.

1. Select C7:C9.

One cell in three rows are highlighted, which tells
Excel to insert three rows above this range.

2. On the Insert menu, choose Rows.

Notice the three new rows.

3. Type the following text and values into the new
cells and watch the totals and profits change
accordingly. 

4. Go to a few cells containing formulas and notice
that the range has been extended.

5. Go to E6 and, using the Fill handle, copy the
formula to E7:E13.

Smart Tags The small icon that appears when you insert new rows into the
worksheet is called a smart tag. Smart tags let you choose options
related to procedures. When you click a
smart tag, a menu of options appears. The
moment you continue working, the smart tag 
disappears.

When you are inserting rows, the options on the smart tag let you
decide whether you want to apply the formats to the new cells
from the row above, or below. Most of the time you will probably
want the default — the format of the row above.

A Word of
Caution

Be careful when inserting a row above or below a range indicated
in a formula, because the row will not be included in the formula.
Excel, however, will let you correct this. You are going to insert a
row above the Children row and notice that the values are not
included in the calculations.

1. Click in any cell of row 6.

110 Microsoft Excel 2003 - Beginning and Beyond



2. On the Insert menu, choose Rows to in sert a row
above.

3. Go to several cells with formulas and notice that
the first row in the range is now row 7 — not row 6.

Since the range begins with row 7, none of the
values typed into row 6 will be included in the
calculations.

4. Go to B6.

5. Type: 1000

6. Look at the value on the Total row. It is not going to
change.

Tap the ENTER key.

Notice that the value on the Total row did not change. 
Green triangles appeared next to some cells, however. 
You will learn more about these shortly.

You are going to insert a row above the Total row.

1. Click the To tal row head ing (row 17) to se lect the
row or any cell in row 17.

2. On the Insert menu, choose Rows.

3. Go to several cells with formulas and notice that
the last row in the range is still row 16 — not row
17.

Since the range ends with row 16, values  entered in
row 17 would not be included in the calculations.

4. Go to B17.

5. Type: 1000

6. Look at the value in the Total row. It is not going to
change.

Tap the ENTER key.

Notice that the value in the Total row did not change.

The green triangles that appeared next to the results in B18 and
B24:B27 indicate that the cells contain formulas that Excel thinks
may have an error. 
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1. Click in B18.

Notice the small box with an exclamation point. This 
indicates that Excel detects an
error in the formula.

2. Point, but do not click, to the
box with an exclamation point.

Notice the message: The formula in this cell refers to a
range that has additional numbers adjacent to it.

3. Click the small box.

In the menu that appears, Excel tells you the
problem: Formula Omits Adjacent Cells.

4. In the menu, choose Up date For mu la to In clude Cells.

The formula is updated, and its range, as shown on
the Formula bar, is now B6:B17. Only this formula
was updated, however.

Note: To up date the rest of the for mu las, you would 
have to re peat these steps for each one. The
procedure can be inconsistent, however, especially
in non-adjacent cells. For adjacent cells you could
copy it to the right with the Fill handle. In cases like
this, it may be faster to in sert a new row be low the
first one, cut the information in the top row (see
Cutting and Pasting in the next lesson), and then
paste it in the new blank row. The new top row will
then be blank, but still included in the formulas. You 
can then type information into this new blank row.

Inserting
Columns

The same procedures that apply when inserting rows apply when
inserting columns. When inserting a column, select the column that 
will follow the new column and then choose Insert/Columns.

1. You are going to insert a column before column B.

Click the column B heading  
to select the entire column.

The new column will come before this column (it
will be inserted to the left of the selected column).

2. On the Insert menu, choose Col umns.
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One empty column is inserted. It takes the width
and the formats of the column before it. Notice that
the title, MILLER’S SHOE DEPARTMENT, is
centered between columns A and F, rather than A
and E as before. 

3. You are going to insert two columns. As with inserting
rows, you can merely select a cell in each column to
follow the insert. You do not have to select entire
columns. 

Select A31:B31 or any two cells in columns A and B.

4. On the Insert menu, choose Col umns.

Two columns have been inserted before column A.
Because there was no column before these columns,
they have each taken on the Standard Width (8.43).
If you click the Smart tag, however, you can choose
Format Same as Right and the width of the new
columns will be the same as that to the right of them.

Deleting
Rows and
Columns

The Delete command lets you delete rows and columns. Do not
confuse the command with the Clear command (whose keyboard
equivalent is the DELETE key), which lets you delete the contents
of cells.

When inserting rows and columns, avoid merely selecting cells in
the rows or columns to be deleted. If you do, the Delete dialog box
(covered shortly) will appear to help you and it requires an extra
step. Therefore, it is usually easiest to delete rows and columns by
selecting their headings.

1. You are going to delete one row.

Click the row 6 heading to select row 6. 

2. On the Edit menu, choose De lete.

The row is deleted and those beneath it move up.

3. You are going to delete two adjacent rows.
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Select the row 17 and 18 headers.

4. On the Edit menu, choose De lete.

The two adjacent rows are deleted and those
beneath them move up.

Note: As with inserting rows, be care ful about
de let ing col umns that are ref er enced in for mu las.
For ex am ple, if C4 con tained the for mula
=SUM(B6:B8)/A20 and you were to de lete A20, the
mes sage #DIV/0! would ap pear in C4. This in di cates
that the for mula can't be solved be cause A20 is
empty.

You are going to delete the new A and B columns.

1. Drag through the column A and B headings to
select the entire columns.

2. Choose De lete on the Edit menu.

Both columns are deleted.

3. You are going to delete the new column B.

Click the column B heading.

4. On the Edit menu or shortcut menu, choose De lete.

The column is deleted.

Note: You may have noticed that when cells are
selected, the Delete command on the Edit menu has
an ellipsis (...) following it, indicating that a dialog
box will appear — in this case, the Delete dialog box
— which requires you to select an option to finish
the procedure. When a row or column heading is
selected, there is no ellipsis, and you save yourself a
step.

Summary These are the major points to keep in mind when inserting
rows and columns:

! Rows and columns are inserted either by clicking a row
or column heading or by selecting at least one cell and
then choosing Rows or Columns on the Insert menu.
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! Rows and columns are deleted by selecting a row or
column heading and then choosing Delete on the Edit
menu.

! Avoid deleting rows and columns by selecting one or
more cells and choosing Delete on the Edit menu. If you
do, the Delete dialog box will appear, and you have
created an extra step for yourself.

! Be careful about inserting and deleting rows and
columns at the extreme edges of a range that is
referenced in a formula. The new rows and columns
might not be included in the formula.

Inserting
and
Deleting
Cells

Sometimes it is necessary to insert and delete specific cells, not
entire rows or columns. The Insert and Delete dialog boxes let you
do this. You are going to do this with a workbook named Student
Report.

1. Open Stu dent Re port.

Notice that the workbook contains two alphabetical
lists of students. The one on the left contains
Undergrads and the one the right, Grads.

2. Imagine that Edgar has dropped out and has to be
removed from the list. If you delete all of row 7, Joan
will also be deleted. If you use the Clear command to
remove the contents of A7 and B7, there will be two
empty cells in the middle of the list. You want to delete 
only cells A7 and B7 and have the cells below them
move up to fill the gap.

Select A7:B7.

3. On the Edit menu, choose De lete.

The Delete dialog box appears. Notice that you can
shift cells left or shift cells up.

4. Verify that Shift cells up is se lected.

5. Click OK.
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Notice that the two cells were deleted and the cells
below them moved up to fill in the gap.

You are now going to insert two cells. A student named Nancy is to
be added to the undergrad list above Margaret.

1. Select A8:B8.

2. On the Insert menu, choose Cells.

The Insert dialog box appears. Notice that you can
shift cells right and down.

3. Verify that Shift cells down is cho sen.

4. Click OK.

Notice the two empty cells that were inserted. Cells
below it were moved down.

Note: The Smart tag is the same one that ap pears
when you in sert rows — its op tions are For mat Same
as Above (the de fault), For mat Same as Be low, or Clear
Formatting.

5. In A8, enter: Nancy

6. In B8, enter: 92
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Shortcut
Menus

Excel's Shortcut menus provide you with quick access to common
editing commands. You can display a Shortcut menu by
right-clicking. Always be aware that Shortcut menus are
context-sensitive, which means that they change depending on
where you click, and depending on what action you are
performing.

You are going to see the Insert, Delete, and Clear Contents
commands on the Shortcut menu.

1. Select a small range of cells.

2. Point to the highlighted range and right-click.

Notice the Insert, Delete, and Clear Contents
commands on the Shortcut menu. From now on, feel 
free to right-click and use Shortcut menus — you
will find them a big time saver.

3. Close the workbook. If you wish, save the changes.

End of Lesson 9
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