


Formatting
Values

In the last lesson, you changed the way in which text was
displayed by formatting cells with attributes such as bold and
italics. In addition to these attributes, Excel provides you with an
even greater control over how values are displayed. For example,
you can have Excel display values with commas, dollar signs, and
decimal places. You can also display negative values within
parentheses or with a minus sign.

You are going to apply different formats to values.

1. A new workbook should be open and maximized.

2. So that you can better see how the different formats
will work, you will enter a sample value in A1.

In A1, type 123456 and then click the check box on
the For mula bar so that A1 re mains ac tive.

3. On the Format menu, choose Cells.

4. Click the Number tab to display the tab.

The Number tab appears. 

The Category list box displays the various types of
formats available. As you will see, when you select
one of the categories, Excel displays the different
number formats available for that category. By
default, the General category is selected. Notice that
in the Sample box, Excel displays the contents of the
active cell. Because General is selected, the contents
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in the Sample box have no specific number format.
For example, there is no common separator or dollar 
signs.

5. In the Cat e gory list box, choose Num ber.

Notice the items that appear to the right of the
Categories list box. These are different ways to
display numbers. In the Sample box, notice that Excel 
formats the numbers in the active cell according to
the options that are currently selected. For example,
it may be displaying them with two decimal places.

6. In the Cat e gory list box, choose Cur rency.

To the right of the 
list box, notice that 
the options for the 
Currency category 
are only slightly 
different from the 
options for the 
Number category. 
For example, you 
have the option of 
including a symbol 
such as a dollar sign.

7. In the Category list box, choose Date.
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To the right of the
list box, Excel
displays the
different date
formats. 

8. You are going to take a
closer look at the
General format.

In the Cat e gory list box, choose Gen eral and then
click OK.

The General
Format

As stated, the General format is the default format for values and
the one that you have been using up to now. It has the following
characteristics: 

! No commas;

! No dollar signs;

! Negative values are displayed with a minus sign rather
than within parentheses;

! Decimal places appear only if you type them;

! Trailing zeros will not be displayed (for example, 25.40
will be displayed as 25.4).

You are going to see values displayed using the General format.

1. You are going to set the widths of all the columns to
15, so there will be plenty of room to display the values 
for this lesson.

Click the Select All button or use CTRL/A.

2. On the Format menu, point to Col umn and then
choose Width.

3. Change the contents of the Col umn width box to: 15

4. Click OK.

Tip: Re mem ber that you can also change the widths
of all col umns that have not been set in di vid u ally by 
chang ing the Stan dard Width.

5. In A1, type 5000.35 and tap the DOWN ARROW key.
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Tapping the DOWN ARROW key entered the value
into the cell, removed the highlight, and moved you
to A2.

6. In A2, type 3.777 and tap the DOWN ARROW key.

7. In A3, type -40 and tap the DOWN ARROW key.

8. In A4, type 1250350 and tap the DOWN ARROW
key.

A1:A4 should look like this:  
Notice that the values are 
difficult to read. This is because 
the number of decimal places 
differ — the first value has two 
decimal places, the second value has three decimal
places, and the last two values do not have any. As a 
result, the values are not aligned under each other at 
their decimal places. This is one of the characteristics 
of the General format. Also notice the other
characteristics of the General format — the values
are displayed without commas or dollar signs, and
the negative value is displayed with a minus sign.

Tip: You can also ap ply the Gen eral for mat by us ing
the key board com mand CTRL/SHIFT/~. (That is
the TILDE key, usu ally in the up per left cor ner of
the key board.)

The Number
Format

You are going to use the formats of the Number category to display
the values. You will begin by displaying the values with different
decimal places.

1. Select A1:A4.

2. On the Format menu, choose Cells.

3. Verify that the Number tab is displayed.

4. In the Cat e gory list box, choose Num ber.

Once again, notice the options for the Number
format. In the Sample box, notice the display of the
first value in the range. 

5. The Decimal places box determines the number of
decimal places to be displayed. By default, this is set to
2. You are going to change this.
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Change the contents of the Dec i mal places box to 0
(you can en ter it di rectly in the box or you can click 
on the in cre ment but tons). 

When this option is set to 0, no decimal places will
be displayed. Numbers with decimal places will be
rounded off.

6. Click OK.

7. Click in any cell to remove the highlight so the
details of the values are easier to see.

Notice that the values are 
displayed without 
decimal places.

8. Click A1.

Notice 5000.35 on the Formula bar. Excel has not
forgotten the complete value and will use it in
calculations. The decimal places are simply not
being displayed in the cell.

9. Click A2.

Notice 3.777 on the Formula bar. In the cell, it has
been rounded off to 4.

10. You are going to display the values with two decimal
places.

Select A1:A4.

11. On the Format menu, choose Cells.

12. Verify that the Number tab is displayed.

Notice that Number is chosen in the Category list box
and 0 is displayed in the Decimal places box. These
are the formats of the selected cells.

13. Change the contents of the Dec i mal places box to: 2

Notice the sample value.

14. Click OK.

15. Click in any cell to remove the highlight.

A1:A4 should look like this:
Notice that the values are 
displayed with two decimal 
places. Trailing zeros have been 
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added to values that did not originally have 2
decimal places, such as -40.00.

16. Click A2.

Notice 3.777 on the Formula bar. It has been
rounded off to 3.78 in the cell.

You are going to use other options for the Number category.

1. Select A1:A4. 

2. On the Format menu, choose Cells.

3. The Use 1000 Separator (,) option displays values with
commas.

Select the Use 1000 Sep a ra tor (,) op tion.

Notice the sample value.

4. Click OK.

5. Click in any cell to remove the highlight.

Notice that the large values in 
A1 and A4 
are displayed  
with commas. Since you did 
not change the Decimal places 
option, two decimal places are still displayed.

6. You are going to look at the formatting options for
negative numbers.

Select A1:A4. 

7. On the Format menu, choose Cells.

Notice the Negative 
numbers list box.  
This list box allows 
you to choose how 
negative values are 
displayed. You can display them with a minus sign,
in red, enclosed in parentheses and in parentheses
and red.

8. You are going to display negative numbers in
parentheses. 
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In the Neg a tive num bers list box, choose the third
op tion, (1,234.10), and then click OK.

9. Click in any cell to remove the highlight.

Notice that the negative 
number is enclosed in 
parentheses.  
The two decimal places are still 
displayed and the thousands 
separator is used as well. You can combine all of
these options to produce your desired format.

The Currency
Format

You are going to use the different Currency format options.

1. Select A1:A4.

2. On the Format menu, choose Cells.

3. Verify that the Number tab is displayed.

4. In the Cat e gory list box, choose Cur rency.

The options for the Currency category are identical
to those of the Number category except that the Use
1000 Separator (,) option has been replaced by the
Symbol option.

Note: Cur rency for mats for US cur rency are al ways
dis played with a thou sands sep a ra tor.

5. You are going to change the number of decimal places
displayed.

Change the contents of the Dec i mal places box to: 0

6. In the Sym bol box, ver ify that $ is dis played.

7. You are not going to change the way negative numbers 
are displayed.

In the Neg a tive num bers box, ver ify that the third
op tion is still se lected so that neg a tive num bers
will ap pear within pa ren the ses.

8. Click OK.

9. Click in any cell to remove the 
highlight.

Notice how the values 
are displayed.
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10. You are going to use the Currency format with two
decimal places.

Select A1:A4.

11. On the Format menu, choose Cells.

12. In the Cat e gory list box, ver ify that Cur rency is
cho sen.

13. Change the contents of the Dec i mal places box to: 2

14. Click OK.

15. Click in any cell to remove the highlight.

Notice how the values are 
displayed.

Notes The dollar sign option 
is usually applied only to the 
first number in a column of figures, or to totals. Using dollar
signs for all values can create a cluttered, unattractive look.
One solution is to use the Accounting format that Excel
provides. This format keeps the dollar sign at the left of the
cell, negative values in parentheses, and zero values are
represented with hyphens.

You can also apply the currency format with the keyboard
command CTRL/SHIFT/$.

Currency formats depend on the Regional and Language
Options in Windows' Control Panel. These options affect
default settings such as thousands separator, currency
symbol, negative number display, and others. 

Custom
Formats

If you need a format not found on the Number tab of the Format
Cells dialog box, Excel lets you design your own. You are going to
create a custom format that displays the letter x following each
value.

1. Select A1:A4.

2. On the Format menu, choose Cells.

3. In the Cat e gory list box, choose Cus tom.
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Notice the Type list box, which displays some of the
common formats. There is an example below. The
format of the selected cells is selected in the list box
and displayed above it in the Type text box.

4. You are going to choose the format that comes closest
to the one you want and then you will alter it.

Scroll to the top of the Type list box and click the
for mat near the top of the list that looks like this:
#,##0_);(#,##0)

The characters after the semicolon (;) tell Excel how
negative numbers are displayed. The _) represents
the space after a positive number that is reserved for 
the right parenthesis of negative numbers.

5. In the Type text box, click an in ser tion point to the
left of the semi co lon (;).

6. Type a space and type: x

Your text box 
should look 
like this:

7. So that negative numbers will also have the x, you must 
insert it in the area after the semicolon (;).

Position the insertion point at the very end of the
format.
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8. Type a space and type: x

Your text box 
should look like 
this:

9. Click OK.

10. Click in any cell to remove the highlight.

Notice that the values are 
displayed with an x 
after them.

Note: This cus tom for mat 
will be saved with the 
work book and is avail able for all cells of this
work book. You are go ing to use it again in the next
sec tion.

Formatting
Empty Cells

As you know, formats are applied to cells, not to values or text.
Therefore, you can format empty cells as you did in the last lesson.
Values entered into them will then take on those formats. You are
going to format B1:B4 with the custom format that you created.

1. Select B1:B4.

2. On the Format menu, choose Cells.

In the Category list box, notice that the General
category is chosen. This is the current format of the
selected empty cells.

3. In the Cat e gory list box, choose Cus tom.

4. Scroll to the bottom of the Type list box.

Notice that your custom format is listed.

5. Choose the format you created and then click OK.

The cells in B1:B4 have the custom format.

6. In B1, type 444 and tap the ENTER key.

Notice that the value is displayed with the custom
format.
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You can, of course, select the entire worksheet and choose a format
that will be applied to every cell. You are going to change the entire 
worksheet to a Number format.

1. Click the Select All button to select the entire
worksheet.

Note: If you used CTRL/A, Ex cel may have se lected 
only a "re gion" of cells containing information. If
only cells A1:B4 were se lected, use CTRL/A again.

2. On the Format menu, choose Cells.

3. Verify that the Number tab is displayed.

4. In the Cat e gory list box, choose Num ber.

5. Verify that the Dec i mal places box dis plays: 2

6. Click the Use 1000 Sep a ra tor (,) op tion to turn it on.

7. In the Neg a tive num bers list box, choose the third
item to dis play neg a tive num bers in pa ren the ses.

8. Click OK.

9. Click in any cell to remove the highlight.

Notice that all values have changed to that format.

Note: You can still change in di vid ual ranges to
other for mats.

10. If you enter a value into any cell, it will have that
format.

In B2, type 2222 and tap the ENTER key.

Notice the value has a comma and is displayed with
two decimal places, like this: 2,222.00

11. You are going to change back to the General format.

Select the entire worksheet.

12. On the Format menu, choose Cells.

13. In the Cat e gory list box, choose Gen eral and then
click OK.

14. Click in any cell to remove the highlight.

All cells have been 
returned to the 
General format.
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Clearing
Formats

You can clear the format of a cell without clearing its contents. You
can also clear both the format and the contents of the cell.

1. You are going to format A1 with a Currency format.

Go to A1.

2. On the Format menu, choose Cells.

3. Verify that the Number tab is displayed.

4. In the Cat e gory list box, choose Cur rency. It does
not mat ter how many dec i mal places will be
dis played.

5. Click OK.

Notice that the value in A1 has changed to the
Currency format.

6. On the Edit menu, point to Clear and then choose
Con tents on the submenu.

The contents of A1 have been deleted. The
formatting that you applied to the cell remains,
however.

7. With A1 selected, type 1234 and tap the ENTER key.

Notice that the value has the Currency format.

8. You are going to remove the Currency format in A1, but 
not the value.

Go to A1.

9. On the Edit menu, point to Clear and then choose
For mats on the submenu.

Notice that the format has been removed. The value
has the General format and looks like this: 1234

10. You are going to once again assign a Currency format
to A1 and then remove both the contents and format.

With A1 as the active cell, choose Cells on the
For mat menu.

11. In the Cat e gory list box, choose Cur rency and click
OK.

The value once again has a Currency format.

12. On the Edit menu, point to Clear and then choose
All.
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The value has been erased, and so has the format.

13. With A1 selected, type 1234 and tap the ENTER key.

Notice that the value has the General format and not
the Currency format.

14. Close the workbook without saving the changes.

Notes The DELETE key is the keyboard equivalent of the Clear
Contents command. It does not erase the cell format.

The Special category of the Number tab has preset formats for 
ZIP codes, phone numbers, and social security numbers.

The Number
Format
Buttons

The Formatting toolbar contains a number of buttons to help you
quickly apply various number formats without using the Format
Cells dialog box. They are alternatives to those commands. Keep in
mind that buttons can be taken off of toolbars and, as a result, are
not always available. Also, as you will see, they have limitations.

1. Open Weekly Pay roll.

2. All the values are currently formatted with the General
format, so they have no specific format. You are going
to use the buttons on the Formatting toolbar to apply
different formats to all the values except those in the
Hours Worked column.

Select C13:C20 and then hold down the CTRL key
and select E13:H20.

These are the ranges you will format.

3. On the Formatting toolbar, click the 
Currency Style button.

Notice that this button applies the Accounting format 
with two decimal places and a dollar sign. It does
not apply the Currency format where the dollar signs 
are placed next to the numbers.

4. Click the Percent Style button.

Notice that the numbers are all followed by a
percentage symbol (%). Each percentage value is the
equivalent of the numeric value that was entered
earlier.

80 Microsoft Excel 2003 - Beginning and Beyond



5. Click the Comma Style button.

Notice the format of the cells. Commas were
inserted where needed and two decimal places
added.

6. The Formatting toolbar has two buttons that allow you
to quickly adjust the number of decimal places
displayed.

With the range still selected, click the 
Increase Decimal button two times.

Notice that the numbers now have four 
decimal places.

7. Click the Decrease Decimal button  
four times.

Notice that the values now have no decimal places.
The numbers have been rounded off.

Automatic Cell
Formatting

When entering a value into one cell, Excel will let you include a
dollar sign and commas with the number. In other words, you can
bypass the Number tab and Number Format buttons, and directly
assign a format to one cell. The number of decimal places it will
accept, however, depends on the current format.

1. In Cell E13, type $1,250.00 and tap the ENTER key.

2. Click E13 and choose Cells on the For mat menu.

Notice that the chosen format is the Currency format
with two decimal places and a dollar sign. Also
notice, however, that the fourth style is chosen in the 
Negative numbers box. If you wanted a different
style, you would have to change it in this dialog box.

3. Click Cancel.

4. Close the workbook without saving changes.

Exercise:
Applying
Value
Formats

You are going to change the appearance of the values and text of
the Miller’s Shoes 2 workbook, which is similar to Miller’s Shoes 1.
You will be given general, rather than step-by-step, instructions.

1. Open and maximize Miller’s Shoes 2.
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An example of this worksheet is below. Notice that
the values are displayed with the General format.
They appear without commas or dollar signs, and
negative values are displayed with a minus sign.
None of the values have been typed with decimal
places. The text in row 3 is centered; that in column
A is left-aligned.

2. You are going to see what the values look like at
various settings.

Select the entire worksheet.

3. Choose the Num ber for mat with two dec i mal places 
and no thou sands sep a ra tor.

Notice the format. All the decimal places are zeros
because decimal places have not been typed. There
are no commas or dollar signs, and negative values
are displayed with minus signs.

4. Change the format of the entire worksheet so that
commas are used as thousands separators and
parentheses are used to display negative numbers.

Notice that commas have been inserted, negative
values are displayed within parentheses, and
positive values have been pushed a little way to the
left so there will be room for closed parentheses.

5. Choose the Cur rency for mat with dol lar signs and
two dec i mal places for the en tire worksheet.

Notice the Currency format. Values are displayed
with dollar signs, commas, and two decimal places.
Negative values are placed within parentheses.
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Notice that the values in some cells are too big to fit,
so # signs are displayed.

6. So that all values display, select the entire
worksheet, choose Col umn on the For mat menu,
then Width on the submenu, and change the
Col umn width to 11.

Notice that the # signs are no longer displayed.

7. There is no reason to display all values with dollar
signs. Also, there is no reason to have decimal places
because none have been typed.

Change the format for the entire worksheet so
there are no dollar signs and no decimal places.
There should be comma separators and negative
values should be surrounded with parentheses.

8. You are going to set the total values on row 10 to the
Currency format at 0 decimal places.

Select B10:E10 and choose the Cur rency for mat.

9. Do the same thing for the profit values in B14:E14.

10. Right-align the text in B3:E3.

11. In column A, right-align the Chil dren, Men, and
Women text.

12. Change the width of column A to: 15

13. Use the Save As com mand to save the worksheet as 
Value For mats.

Your worksheet should look like the following:

End of Lesson 6

Lesson 6 - Changing the Appearance of Values 83


