


Copying,
Cutting, and 
Pasting

In the last lesson, you used the Copy command to copy formulas to
other cells. In this lesson, you will use it to copy text and values.
You will also use the Cut command to move information. When
you copy information, the original is not removed from its location.
When you cut information, the original is removed from its location 
and placed elsewhere.

When you cut or copy information, it goes to a section of memory
called the Clipboard. When you choose the Paste command on the
Edit menu, the contents of the Clipboard are pasted in the
workbook.

The Clipboard is a Windows feature. This makes it easy to cut,
copy, and paste information between applications. You can, for
example, cut information in an Excel workbook and paste it into a
Word document. When you shut down Windows, the Clipboard is
emptied.

Note: If the Clip board Task Pane ap pears dur ing the fol low ing
in struc tions (it will prob a bly be on the right side of the worksheet),
ei ther close it by click ing its Close (x) but ton or ig nore it. It will be
ex plained shortly. 

Copying You are going to copy a range of cells in a column and paste it
somewhere else.

1. Open Miller’s shoes 5.

2. Select B6:B19.

3. On the Edit menu, choose Copy.

The flashing marquee indicates that the range is in
the Clipboard.

4. Go to F6.

5. On the Edit 
menu, choose Paste.

The copy is complete.

6. Click in any cell to remove 
the highlight.
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Notice that the formats were also copied. The
marquee is still flashing, indicating that the
information can be pasted again with the Paste
command. You can ignore it.

You are going to copy a range of six cells.

1. In the following step, do not worry that the marquee
will continue flashing around the old range. The
marquee will go to the next range when you choose
the Copy command.

Select B6:C8.

2. On the Edit menu, choose Copy.

The information in B6:C8 is copied to the Clipboard,
and the marquee is flashing around the new range.

3. Go to B21.

4. This time you are going to tap the ENTER key to finish
the procedure. When you tap the ENTER key, the
marquee disappears and the item cannot be pasted
again.

Tap the ENTER key.

The copy is complete and the marquee is no longer
flashing.

5. Click in any cell to remove the highlight.

Re mem ber: If you choose Paste to fin ish the
pro ce dure, the mar quee re mains and the
in for ma tion can be pasted again. If you tap the
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ENTER key, the mar quee is re moved and the
in for ma tion cannot be pasted again.

Notes If there is information in the range to which you are pasting,
it will be overwritten by the new information.

As with most Microsoft Office applications, the following
buttons are on the Standard toolbar, which are alternatives to 
the menu commands:

The Cut, Copy and Paste commands are on a Shortcut menu
when you right-click.

Probably the easiest method to cut, copy and paste are with
the keyboard commands CTRL/X (cut), CTRL/C (copy), and 
CTRL/V (paste). 

The Insert
Paste
Command

Until now, you have been pasting the clipboard contents to empty
cells. As stated, if you paste to cells with information, the
information will be overwritten. If you do not want to overwrite
text, choose Insert Paste on the Insert menu, rather than choose the
Paste command. Rather than overwrite text, cells with information
are pushed to the right or down.

1. Open a fresh copy of Miller’s shoes 5.

2. You are going to copy the Jan numbers and put them
before the Total numbers. You might want to do this if
you were starting an April column with numbers similar 
to those of January.

Select B3:B19.

3. Click the Copy button.

4. Go to E3.

122 Microsoft Excel 2003 - Beginning and Beyond



5. On the Insert menu, choose Cop ied Cells.

The Insert Paste dialog box
appears. Notice that you
can shift the highlighted
cells to the right or down.
Also notice in the workbook 
that Excel highlights the
E3:E19 range.

6. Verify that Shift cells right is cho sen, and click OK.

Notice that the Total column was shifted to the right. 
The marquee is still flashing around B3:B19,
indicating that it can continue to be pasted. It will be 
removed when you copy something else.

Notice the Smart tag triangles in cells with formulas. 
As with inserting rows and columns, always be
aware of the effects the procedure will have on
formulas. Check the results carefully because in
some situations there can be unexpected
consequences. In this case, Excel is alerting you to
the fact that the new column E is not included in
formulas in column F.

You are going to see what happens when cells are shifted down.

1. Select B6:B8.

2. Click the Copy button.

3. Go to C6.
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4. On the Insert menu, choose Cop ied Cells.

5. Choose Shift cells down and click OK.

6. Tap the ESC key to remove the flashing marquee.

Notice that the existing cells 
were pushed down. 

 

Cutting The procedures to cut and paste 
information are almost identical to those 
used to copy and paste information.

1. Open a fresh copy of Miller’s shoes 5.

2. You are going to move information in column B.

Select B3:B19.

3. On the Edit menu, choose Cut.

4. Go to F3.

5. On the Edit menu, choose Paste.

An empty column remains where the information
used to be. The newly located range is highlighted.
The numbers in the Total column (column E) have
changed because column B is now empty.

Note: Un like copy ing, you can paste only once af ter
cut ting, be cause no flash ing mar quee re mains. If you 
want to paste more than once, you can use the Copy
com mand and then de lete the orig i nal ver sion when 
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fin ished or you can use the col lect and paste fea ture
de scribed later.

6. You are going to move another range of cells. This time 
you will use the shortcut menus.

Select C6:C8.

7. Point anywhere in the selected cells and
right-click.

8. Choose Cut.

9. Go to G6 and right-click.

10. On the Shortcut menu, choose Paste.

The move is complete.

You are going to move a row. This time you will use the Cut button 
on the Standard toolbar.

1. Select A16:F16.

2. On the Standard toolbar, click the Cut button.

3. Go to A20.

4. This time, you will tap the ENTER key to complete the
procedure. Because the marquee does not remain
when cutting information, there is no difference
between using the Paste command and tapping the
ENTER key.

Tap the ENTER key.

The move is complete and the flashing marquee has
disappeared.

If you do not want cells that have been cut to overwrite existing
data, do exactly what you did when copying — once you have
chosen the Cut command, click the Insert menu and choose Cut
Cells, which will have replaced Copied Cells. Then make the
appropriate choice on the Insert Paste dialog box. There is one
difference, however between this and the Copy procedure. When
you insert cells in the same rows or columns from which they are
cut, Excel will automatically move the remaining cells.

1. Open a fresh copy of Miller’s shoes 5.
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2. Select B3:B19.

3. This time, use CTRL/X to cut.

4. Go to E3.

5. Click the Insert menu.

Notice that Cut Cells has
replaced Copied Cells.
Notice, however, that an
ellipsis does not follow the
command, which indicates that
a dialog box will not appear.

6. Choose Cut Cells.

Notice that the Insert Paste dialog box did not
appear as it did when you chose Copied Cells. This is
because the pasted cells remained in the same rows
from which they were cut.

The move is complete. The cut cells have been
placed before E3 and the other cells have moved one 
column to the left to fill up the gap.

7. You are going to move A16:E19 before A5. It is in the
same column, so Excel will move the other cells out of
the way.

Select A16:E19.

8. Use CTRL/X.

9. Click A5.

10. On the Insert menu, choose Cut Cells.
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The move is complete.

Because you clicked in a cell vertically above the
selected cells, Excel moved cells vertically down.
Before, you clicked in a cell horizontally to the right
of the selected cells and Excel moved cells
horizontally to the left.

Note: If you are not inserting in the same rows or
columns, the Insert Paste dialog box will appear as it 
does when you are copying.

Remember: When you insert cut cells in the same
rows or columns from which they are cut, Excel will
automatically move the remaining cells.

Collecting
and Pasting
Multiple
Items

You have seen how Excel pastes the last item that you either cut or
copied. Excel can, however, collect the items that you cut or copy
(up to 24) so that they can be pasted all together or separately. 

1. Open a fresh copy of Miller’s shoes 5.

2. On the View menu, choose Task Pane. 

3. If the title of the Task Pane is not Clip board, click
the downward pointing triangle to the right of the
ti tle and choose
Clip board.

The Clipboard 
Task Pane appears.
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Notice that it has a little toolbar of its own with three 
buttons. 

4. If there are any items on the Clipboard, you are going
to clear them and then place new ones there by cutting 
and copying. Even if the Clipboard is empty, perform
the following step for practice.

Click the Clear All button to empty the Clipboard. 

Incidentally, since the Clipboard is empty, Paste is
dimmed on the Edit menu.

5. Select A3:E3.

6. Cut it by any method you wish.

Notice the icon that was placed on the Clipboard
Task Pane.

7. Click in A4 and tap the ENTER key to complete the
cut and paste.

Notice that its icon is still on the Clipboard Task
Pane for you to paste it again.

8. Point (do not click) to the icon and notice that a
down arrow appears next to it.

9. Click the down arrow.

Notice the options. Paste 
pastes the item at the active 
cell, and Delete removes the 
item from the Clipboard.  

10. Select A10:E10.

11. This time, you are going to copy it.

Copy it by any method you wish. You will paste it
later.

Notice the item in the Clipboard Task Pane. The first 
item in the list is the most recently cut or copied.

12. Select A14:E14.

13. Copy it by any method you wish.

Notice the third item in the Clipboard Task Pane.

14. Tap the ESC key to remove the marquee.

As you know, when the marquee is removed, you
cannot use the Paste command.
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15. You are going to paste the items.

Go to A21. You may have to scroll to get there.

16. In the Clipboard Task Pane, click the Jan, Feb, Mar
item.

Notice that it has been pasted.

17. Go to A23.

18. On the Clipboard Task Pane, click the To tal item.

19. Go to A25.

20. On the Clipboard toolbar, click the Profit item.

Notice that all three items have been pasted.

21. You are going to paste all the items in one operation.

Go to A27.

22. On the Clipboard toolbar, click the Paste All
button.

23. Click anywhere to remove the highlight.

Notice that all the items have been pasted.

24. Close the Clipboard Task Pane by clicking its Close
(X) button.

25. One thing to keep in mind is that formulas cannot be
pasted in this way, only values and formats.

Click in B25:E25 and notice that they contain
values, not formulas.

Remember: To copy for mu las, you must use the
Cut, Copy, and Paste commands (or the Fill handle
for adjacent cells), not the Clip board Task Pane.

Drag and
Drop Editing

Often, the easiest way to move and copy a range is to drag it to its
new location.

1. Open a fresh copy of Miller’s shoes 5.

2. Select B3:B19.

3. Point to any border of the 
selected range until the  
pointer turns into a 
four-headed arrow.
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Note: If the pointer does not turn into a four-headed 
arrow, you should choose Op tions on the Tools
menu, click the Edit tab and ver ify that the Al low cell 
drag and drop op tion is se lected.

4. With the tip of the arrow on any border (but not
the Fill handle), drag to the right but do not
release.

Notice that you are dragging an outline of the range. 
A ToolTip helps you locate the range.

5. When the ToolTip displays F3:F19, re lease the
out line.

The move is complete. Notice that the information in 
the cell moved into the outline when you released.

6. By using the CTRL key when you drag, you can copy
ranges.

Select C6:C8.

7. Point to one of the range’s borders and hold down
the CTRL key.

Notice the + sign to the right of the pointer. This
indicates that you are going to copy.

8. Drag the outline somewhere into column G.

9. Release the mouse and then release the CTRL key.
If you release the CTRL key first, the range will be
moved, not copied.

The copy is complete.

10. On your own, practice drag-and-drop editing. You
will probably want to open fresh copies of Miller’s
shoes 5 af ter you drag and drop a few times.

By using the SHIFT key, you can insert a range, either one that you
have copied or one that you have cut. Suppose you want to insert
an April column that is like the Jan column. Because you want to
leave the Jan column where it is, you will copy it by holding down
the CTRL key along with the SHIFT key.

1. Open a fresh copy of Miller's Shoes 5.

2. Select B3:B19.
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3. Holding the CTRL and SHIFT keys, drag to the right
until you see a shaded bar between the Mar and
To tal col umns like this:

4. Release the mouse button first, and then the CTRL
and SHIFT keys.

The range is copied, and at the same time, the Total
cells were shifted to the right. (Had you used only
the SHIFT key, the Jan column would have been cut,
and Feb and Mar would have shifted left to take its
place.)

5. You can also insert a range and shift cells down.

Select A6:A8.

6. Hold CTRL/SHIFT and drag the border down until
the ToolTip shows A16:A18 (the shaded bar should
be above Di vi sions).

7. Release the mouse button first, and then the CTRL
and SHIFT keys.

Notice that the cells below were shifted down.

Note: You can also do this with en tire rows or
col umns by clicking their head ings, and then
dragging their bor ders.

The Undo 
and Redo
Commands

Excel’s Undo command allows you to “undo” actions, and its Redo
command allows you to put back changes you have undone. The
wording of the commands changes to reflect your most recent
action. For example, if your last action was to delete the contents of 
a cell, the command might read Undo Clear. If it was typing a value
into a cell, the command might read Undo Typing.

Lesson 10 - Cutting, Copying, and Pasting 131



You are going to use the Undo and Redo features.

1. Open a fresh copy of Miller’s shoes 5.

2. Go to A5, which contains Foot wear.

3. Tap the DELETE key to clear the contents.

4. Click the Edit menu.

Notice that the first command reads Undo Clear,
because that was your most 
recent action.

5. Click Undo Clear.

Notice that Footwear was restored.

6. To undo what you just did, you can choose the Redo
command.

Click the Edit menu.

7. Choose Redo Clear.

Notice that the text is again removed from the
screen.

8. You are going to type some text and notice how the
Undo command name changes.

Go to B3, type good fea ture and tap the ENTER key.

9. Click the Edit menu.

Notice how the
Undo command
has changed.

10. Click Undo Typ ing “good fea ture” in B3.

All the typing done since your last action has been
removed. 

11. You are going to notice how the Redo command name
changed.

Click the Edit menu 
and notice the 
change.

12. On the Edit menu, choose the Redo com mand and
watch the typ ing come back.

13. The Undo command also works with format
commands.
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Go to A6, which has Chil dren.

14. On the Formatting toolbar, click the Bold button.

15. Click the Edit menu and choose Undo Bold.

Notice that the bold has been removed.

16. The Undo and Redo commands have toolbar
alternatives.

In A6, bold Children again.

17. On the Standard toolbar, click the Undo
button.

The text is no longer bolded.

18. On the Standard toolbar, click the Redo
button.

The text is bold again.

Notes Not all commands can be undone. For example, you cannot
undo File commands. If the Undo command cannot be used,
Can’t Undo is displayed dimmed on the Edit menu.

Be aware that typing, cutting, copying, and pasting text are
undone at their original locations regardless of the position
of the insertion point. This can be very convenient in
instances where you are not sure where text was originally
located.

The Undo and Redo buttons have drop-down list boxes that
list previous changes.

End of Lesson 10
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