


Using
Different
Control
Types

You can change the type of control used to display a field. For
example, you can change a Combo Box control to a List Box control 
or a simple Text Box control. You are going to open an existing
form and then change some of the controls on the form.

1. Open the More Controls database file.

2. On the Database window, select the Forms tab.

3. Open the StudentCourses form in Design view.

4. If necessary, resize the window so you can see all
controls.

This form is based on the Courses table. At this time,
notice that the bound controls are all text boxes.

Combo Box
Controls

As you have seen, if a field is formatted as a Combo Box in Table
Design view, it will be formatted in the same way in Form view. If
a field is not already formatted as a Combo Box, you can use Form
Design view to format it in this way.

You are going to format the Department Text Box control as a
Combo Box. The Combo Box will simply display a list of
appropriate department values. The list will come from a value list
that you create.

1. Rather than delete the existing control and use the
Combo Box button on the Toolbox toolbar to begin
creating a new control, you are simply going to
reformat the existing Text Box control.

Select the Department Text Box control.

2. On the Format menu, point to
Change To.

Notice that the submenu
contains all control types used
on forms. Since the Department
field is a Text data type, only
certain control types are
available.

3. On the submenu, choose Combo
Box.
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The field has the appearance of a Combo Box
control, because of the arrow 
indicating a drop-down list box.

If the Department field were
already formatted as a lookup field, Access would
use its lookup properties. Since this is not the case,
you must define the lookup properties on the form.

4. If necessary, click the Properties button to display
the Properties window.

5. Select the Format tab.

The Format options are not much different from
what you used in the previous lesson. Since you are
formatting a Combo Box, notice the Column Count,
Column Heads, Column Widths and List Rows options.
These are the same options that appeared when you
formatted a lookup field in Table Design view.

6. The Combo Box will contain a list of appropriate
departments, so you will need only one column.

Verify that the Column Count option is set to 1.
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7. Select the Data tab.

The control remains bound to the Department field.
This means that Access will store contents of the
Combo Box in the Department field.

8. The Combo Box will display values from a list that you
create.

Set the Row Source Type option to Value List.

9. The values are entered in the Row Source property. Be
sure to separate them by a semicolon.

In the Row Source property, type: Art; English;
History; Mathematics; Music; PhysEd; Science

10. Since there will be only one column in the Combo Box, 
you should verify that the Department field will be
bound to that column.

Verify that the Bound Column option is set to: 1

11. You are going to take a look at the Combo Box.

Save changes to the form design.

12. Switch to Form view.

Notice the example of the form.
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13. Use the Record Control buttons to scroll through
twenty to thirty records.

Notice that the contents of the Combo Box change as 
you reach courses in different departments.

14. Click the Department Combo Box.

Notice the items in the value list 
that you defined.

15. Tap the ESC key to close the
Combo Box without making
changes.

List Box
Controls

Whereas a Combo Box control allows you to either type in a value
manually or select it from a drop-down list box, a List Box control
allows you to select only from a list of items. List Box controls
cannot accept values that are typed manually.

You are going to change the Department field from a Combo Box
control to a List Box control.

1. Open the StudentCourses form in Design view.

2. Select the Department Combo Box control.

3. On the Format menu, point to Change To and then
choose List Box.

Notice that the
control has
expanded to
become a multiline
control.

Tip: To cre ate a List
Box con trol from scratch, you could use the List Box
but ton on the Tool box toolbar.

4. Resize the Department List Box control so that it
does not cover the Credits Text Box control.

5. Since you changed only the type of control used to
display the Department field, the properties that you
applied earlier remain.

If necessary, select the Data tab on the Properties
window.
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Notice that the Row Source Type is still set to Value
List and that the Row Source property contains the
items that you entered earlier.

6. You will not bother saving changes to the form design.

Switch to Form view.

Notice the List Box control.

7. Use the Record Control buttons to
scroll through twenty to thirty
records.

Notice that the highlighted item in the List Box
control indicates the Department of the selected
course.

Check Box
Controls

By default, Access displays Yes/No data types using a Check Box
control. A check mark inside of the control indicates a value of Yes
(or True); no check mark indicates a value of No (or False).

1. The StudentCourses form should be open in Form
view.

2. Scroll through the records.

Notice the check mark that appears
inside of the Required Check Box
control whenever a required course is
displayed.

Tip: To cre ate a Check Box con trol from 
scratch, you can use the Check Box but ton 
in Form De sign view.

3. Switch to Form Design view.

Notice the Check Box control in
design view.

Note: By de fault, drag ging a Yes/No field from the
Field List to the form de sign cre ates a Check Box
con trol.
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Option Button
Controls

You can also use an Option Button control to display Yes/No data
types. As you will learn Option Button controls can be used in
many other situations.

1. You are going to use a Shortcut menu to change the
type of control used to display the Required field.

Right-click the Required Check Box bound control.
(Be sure to point to the box itself, not its label.)

2. On the Shortcut menu, point to
Change To.

Notice that only two options 
are available. Yes/No data 
types can be displayed only with
Check Box, Toggle Button or
Option Button controls.

3. Choose Option Button.

Notice the Option Button control.

4. Switch to Form view.

Notice the Option Button control 
in Form view. When a course is
required, the Option Button will fill in 
to indicate this.

5. Scroll through the records of the table.

Notice that the Option Button control
fills in when a course is required.

Note: Usually, Op tion But ton con trols are used to
dis play a se lec tion from two or more mutually
exclusive choices related to a single field. For
ex am ple, you could have used an Op tion But ton
con trol to spec ify the Department control When used
in this fashion, Option Buttons are often included
within an Option Group, which you will learn about
shortly.

Toggle Button 
Controls

You can also display Yes/No data types using a Toggle Button
control. A Toggle Button control that appears “pushed in”
represents a value of Yes. A Toggle Button that does not appear
pushed in represents a value of No.
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You are going to use a Toggle Button control to represent the
values of the Required field.

1. Switch to Design View for the StudentCourses form.

2. Your Toggle Button control will contain the caption
Required. Therefore, before you create it, you are going
to delete the Required Label control.

If necessary, select the Required Label control.

3. Tap the DELETE key.

The label is removed from the form.

Note: If you ac ci den tally de leted the Op tion But ton
bound control, choose Undo on the Edit menu. Click
the La bel con trol to se lect it and then try again.

4. Right-click the Required Option Button control.

5. On the Shortcut menu, point to Change To and then 
choose Toggle Button.

Notice the Toggle Button control.

6. You are going to format the Toggle Button
control.

If necessary, display the Properties window.

7. On the Format tab, set the Caption property to:
Required

The Caption property will appear on the Toggle
Button control.

Tip: You can use the Pic ture property to place a
pic ture on the Tog gle But ton. You can choose one of
the pre set pic tures or you can spec ify your own
pic ture.

8. Instead of dragging the control's sizing handles, you are 
going to use the Properties window to resize the
control.

Change the contents of the Width property to: 0.67

9. Change the contents of the Height property to: 0.25

10. Switch to Form view.

Notice the format of the Toggle 
Button control.
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11. Scroll through the records of the table.

Notice that the Toggle Button 
control appears pushed in 
when a course is required.

12. Close the form window without saving changes.

Adding
Option
Groups

Option groups are designed to display related values — such as
grade levels or departments — as a collection of Check Box, Option 
Group, or Toggle Button controls. When related values are
displayed within an Option Group, selecting a value is as simple as 
clicking the appropriate control. You are going to add an Option
Group to the MathTeam form.

1. Double-click the MathTeam form object to open it
in Form view.

Notice the form.

2. Use the Record Control buttons to navigate through 
the records of the table.

Notice that the Level Text Box control contains one of 
three different values.

3. You are going to create an Option Group of three
Option Buttons for the Level field.

Switch to Form Design view.

4. If necessary, resize the window to see all of the
form design.

Notice that the Level field is bound to a Text Box
control. Normally, you would not have a Text Box
and an Option Group bound to the same field. To
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help you understand how the Option Group works,
however, you will leave the Text Box control.

5. You can create an Option Group manually or with a
wizard. You will start by creating one manually.

On the Toolbox toolbar, verify that the
Control Wizards button is not selected.

When selected, the Control Wizards button will
cause wizards to begin automatically when some of
the other buttons on the Toolbox toolbar are used.

6. On the Toolbox toolbar, select the 
Option Group button.

7. The easiest way to create an Option Group that is
bound to a field is to drag the field from the Field List
to the form.

Verify that the Field List is displayed.
It may be behind a window.

8. With the Option Group button
selected, drag the Level field from the
Field List to the form design, just
below the Level Text Box control.

Notice the Option Group frame.

The Option Group frame
organizes the related values for
the bound field. Inside of the
frame will be a series of check
boxes, option buttons, or toggle
buttons to represent the possible values — in this
case, the possible math team levels. Only one of the
values within the Option Group frame can be
selected at a time. 

9. You are going to take a look at the properties for the
Option Group.

With the Option Group frame selected, use
ALT/ENTER.

The Properties window appears, if it was not
already displayed. 

Tip: ALT/ENTER is a shortcut for displaying the
properties of any selected object.

10. On the Properties window, select the Data tab.
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Notice that the Control Source is set to Level. When
you create an Option Group, it is the frame — not
the individual controls within the frame — that is
bound to the field.

11. In addition to the Option Group frame, Access created a 
label. Normally, the label text would be the name of
the bound field. Since there is already a control named  
Level on the form, however, Access uses generic text.
You are going to change this.

Select the Label control that is on the
Option Group frame.

12. On the Properties window, select the
Format tab.

13. Change the Caption property to: Level

14. With the label still selected, on the Format menu,
point to Size and then choose To Fit.

The size of the label is adjusted.

15. There are three different math team levels — Beginning, 
Intermediate, and Advanced. To represent these levels,
the numbers 1, 2, and 3 are used, respectively. You will 
need three Option Button controls to represent the
possible values of the Level field.

On the Toolbox toolbar, select the Option
Button button.

The pointer appears as a
crosshair with an Option Button
symbol attached to it.

16. Point to the upper left corner of
the Level Option Group frame.

Once you place the pointer in the
group frame, notice that the entire frame is
highlighted. This indicates that the Option Button
control will be placed inside of the frame, becoming
part of the Option Group control.

17. Click.

An Option Button control is
created within the frame, 
along with a generic label.
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18. You are going to format the Option Button that you just 
added.

On the Properties window, select the Data tab.

Notice the Option Value property.

Each Option Button control within the frame is
assigned an option value. When an option is selected,
its Option Value is what is actually stored in the
bound field. The Option Value can only be a Long
Integer Number, meaning that it can range from
about negative two billion to positive two billion.

19. If the first Option Button control is selected, Access
should store 1 in the Level field.

Verify that the Option Value property contains: 1

20. So that the user will know that this Option Button
corresponds to a Beginning level, you are going to
change the label used for the control.

Click the label for the Option Button control to
select it.

21. On the Properties window, select the Format tab.

22. Change the contents of the Caption property to:
Beginning

23. On the Format menu, point to Size and then choose 
To Fit.

Notice the new label 
for the Option Button control.
Although it will appear that a value 
of Beginning is being stored in the
Level field, Access will actually store 
a value of 1 when this control is
selected.

24. You are going to add the second Option Button control
to the Level frame.
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On the Toolbox toolbar, select the Option Button
button.

25. On the Form Design window, point to the Level
frame.

The frame highlights, indicating that the control will 
become part of the Level Option Group.

26. With the cross hair positioned below the first
Option Button control, click.

A second Option Button control is created. This
button will correspond to a Level of 2 (or
Intermediate).

27. If necessary, position the control and the label so
that they line up with the first Option Button
control of the frame.s

28. On the Properties window, select the Data tab.

Notice that the Option Value is already set to 2.
Access changes this automatically as you add
controls to the Option Group. Keep in mind that you 
can change this value to any long integer.

29. You are going to change the label that is used with this
control.

Select the label for the Option Button control that
you just added.

30. On the Properties window, select the Format tab
and change the Caption property to: Intermediate

31. The Size to Fit command also appears on a shortcut
menu.

Right-click the caption. On the shortcut menu,
point to Size and then choose To Fit.

32. Using the same techniques as above, add a third
Option Control button to the frame. The button
should have an Option Value of 3 and a label of
Advanced. You may have to increase the size of the
form design window.

The Level Option Group 
should look like this:

33. Save changes to the form design.

34. Switch to Form view.
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35. Navigate through some of the records and compare 
the contents of the Level text box with the contents 
of the Level option group.

Notice how the option button corresponding to the
Level setting is selected.

Once again, if the Beginning option button is
selected, the value corresponding to this option
button is what is stored in the Level field. Since you
set this Option Value to be 1, this is what Access
stores in the Level field when the Beginning option
button is selected.

36. Close the Form View window.

The Option
Group Wizard

The Option Group Wizard walks you through the process of creating 
an Option Group control. You are going to use the wizard to create
an option group that is bound to the Grade field.

1. Double-click the StudentInformation form object to
open it in Form view.

Notice the form created from the Students table. The
only field that the form is missing is the Grade field.
You are going to put this field on the form using an
Option Group.

Note: The rect an gle around the DOE, Feeder, etc.
fields is not an Op tion Group frame. It is sim ply a
rect an gle cre ated with the Rect an gle but ton on the
Tool box toolbar.

Tip: Usually, you can tell the difference between an
Option Group and a rectangle because an Option
Group has a text label over the top of the frame.
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2. Switch to Form Design view.

3. To create an Option Group using the wizard, the
Control Wizards button on the Toolbox toolbar 
should be selected.

On the Toolbox toolbar, click the Control
Wizards button to activate it.

As you will see, the Control Wizards button works
in combination with some of the other buttons on
the Toolbox.

4. On the Toolbox, select the Option Group
button.

5. You will create the Option Group in the empty area at
the left of the form.

Position the pointer just below 
the FirstName label.

The pointer is in the shape of a crosshair
with an Option Group 
symbol attached to it. 
Normally, you would drag to create the option
group frame and then format the frame and its
contents accordingly. Since the Control Wizards
button is selected, however, all you need to do is
click the mouse and the Option Group wizard will
begin.

6. Click.

An empty Option Group frame is placed on the
form and the Option Group wizard begins. After a
few moments, the first dialog box appears.
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7. The first dialog box asks you to indicate the labels that
should appear next to each option. You will need four
labels — one for each grade.

Type: 9th

As you type, a new row appears. You can add,
delete, and modify the label names using the basic
editing techniques that you use with datasheets.

8. Each label should appear on a new row.

9. On each row below 9th, type the other three grades 
as follows:

You have entered the four labels.

10. Click the Next button.

The second dialog box appears.
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You are asked if you would like one of these options 
to be the default choice. By default, Access suggests
the first option that you entered as the default.

11. On the dialog box, choose No, I don’t want a default.

12. Click the Next button.

The third dialog box appears. Here, you to specify

the value that should be assigned to each option.
Once again, only one option within a frame can be
chosen. The value of the Option Group, then, is the
value that is associated with the selected option.

By default, Access assigned a value of 1 to the first
option, 2 to the second option, 3 to the third option,
and so on. You can change these values to any long
integer.

13. Change the first row of the Values column to: 9

If the option with the 9th label is chosen, Access will
place a value of 9 in the bound field.

14. On each row below 9, type the other three values
as fol lows:

Notice the label names and their corresponding
values.

Note: Each op tion must have a unique value
as signed to it.
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15. Click the Next button.

The next dialog box appears.

You are asked if the selected value should be saved
for later (which would create an unbound control)
or stored in a field (which would create a bound
control).

16. Select Store the value in this field.

The drop-down list box next to this option allows
you to specify the field (from the table or query on
which the form is based) in which the value should
be stored.

17. Click the drop-down list box and choose Grade.

The Option Group control will be bound to the
Grade field.

18. Click the Next button.

This dialog box allows you to select and format the
control used in the Option Group.
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Only Option Button controls, Check Box controls, or
Toggle Button controls can be placed in an Option
Group (you cannot mix control types). Based on
your choices, Access will display a sample Option
Group in the dialog box.

Tip: As a general standard in designing interfaces,
Option But tons are used to des ig nate that only one
op tion of many can be se lected, whereas Check Box
con trols nor mally in di cate that mul ti ple op tions can
be se lected. For this rea son, Op tion But ton con trols
are used most of ten with option groups.

19. Click the various options and see the sample
change.

20. Verify that Options buttons and Etched are selected
and then click the Next button.

The final dialog box appears.

You are asked to choose a caption for the Option
Group control. The caption is the text that appears
on the Option Group frame, in the upper left corner
of the control.

21. Enter a caption of: Grade

Note: The cap tion is man da tory — you can not leave
it blank. As mentioned earlier, the text on the frame
helps to indicate that the Option Group represents a
single field, rather than a grouping of separate
controls.

22. Click the Finish button.
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Notice the Option Group control.

Access has formatted and sized the
control according to your selections
using the wizard.

Tip: To re po si tion the Op tion Group
con trol, click the frame to se lect the
en tire con trol and then drag it to the ap pro pri ate
location, or use the ARROW keys to "nudge" the
control one grid unit at a time.

23. Save changes to the form design.

24. Switch to Form view.

Notice the Option Group control.

Instead of the grade appearing as a
number in a text box, it appears as a
selected option within the Grade
option group.

25. Use the Record Control buttons to navigate through 
several records.

Notice the Grade option change. Keep in mind that
when the 12th option button is selected, what is
actually being displayed is the value that you
associated with that label " namely 12.

26. Close the form.

Notes Once again, it is important to consider an Option Group
control as a single object. If an option group is bound to a
field, it is the group frame that is actually bound to the field,
not the individual check boxes or option buttons.

As mentioned, the values of an option group can be only a
Long Integer Number data type, not a Text data type.

To delete an Option Group control, simply select the option
group frame and then tap the DELETE key. Of course, you
can delete an individual control within the option group by
simply selecting it and tapping the DELETE key.
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The Control Wizards button also works in combination with
the Combo Box and List Box buttons. Using these tools when 
the Control Wizards button is turned on would begin the
Combo Box Wizard or the List Box Wizard, which you used
in Lesson 7.

Review
Exercise

In order to review the concepts presented in this lesson, you are
going to modify a form so that it includes some of the controls that
you just used.

1. Open the MoreStudentInformation form object in
Form Design view.

2. The Advisor field can contain only one of four values.
You are going to change the control to a Combo Box
control.

Use the Change To command to change the Advisor
Text Box control to a Combo Box control.

3. Use the Properties window to identify the Row
Source Type as a Value List.

4. Use the Properties window to identify the Row
Source as the following value list: Bennett; Duffy;
Normand; Stover

5. In the same way, change the Grade Text Box
control to a Combo Box control.

6. Format the Grade Combo Box control so that it
refers to the following value list: 9; 10; 11; 12

7. Finally, you are going to create an Option Group control 
that is bound to the HomeRoom field.

Delete the HomeRoom Text Box control and its
label.

8. Create the following
Option Group control
(bound to the HomeRoom
field). 
You can do this manually
or with the assistance of
the Option Group Wizard.

Tip: To for mat the op tion group con trol as in di cated
above, you may need to first move the Op tion
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But ton con trols and then resize the op tion group
frame.

9. As you create the Option Group control, make sure
that the labels are associated with the following
values:

Label Value
Gould 250
Finn 251
Filler 253
Haskes 254
Quintana 360
Sleet 361
Minnio 363
Sutphen 364

10. Save changes to the form design.

11. Switch to Form view.

The form should look like the following.

12. Navigate through several records and notice the
controls you modified.

13. Use your redesigned form to add a new record to
the table.

End of Lesson 9
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