


Customizing
Labels and
Text

In the Beginning Course, you created and modified forms that were
based on a single table and consisted mainly of Text Box controls.
In these next two lessons, you are going to work with forms that
are based on queries and that use more complex controls.

1. Open the Controls database file.

2. The form with which you will work is based on a query. 
Before customizing the form, you will look at the query.

Select the Queries tab.

3. Open the CourseGrades query in Design view.

Notice that the query is based on three tables and is
designed to list the grade for each course that a
student has taken. Also notice that the query uses all 
fields from the StudentGrades table.

Note: If you plan on add ing new re cords to a ta ble
us ing a form, make sure that all fields from the ta ble
are in cluded on the form. Otherwise, the new
records will have fields with missing data. 

4. Switch to Datasheet view.

Notice the results of the query. In particular, notice
that the StudentID field is formatted as a lookup
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field. By default, the fields used in a query form
inherit the format used in their related table. (This
StudentID field came from the StudentGrades table.)

5. Close the query results.

6. A simple form has been created from this query.

On the Database window, select the Forms tab.

7. Double-click the StudentGrades form to open it in
Form view.

Notice the form.

This form was created by dragging the fields from
the Field List to the form design window. When this
is done, Access creates a bound control (which is
linked to the field), and an unbound control (which is
simply a label). On this form, most of the bound
controls are formatted as text boxes. The StudentID
field appears as a Combo Box, however.

8. Switch to Form Design view.

Notice the form in design view.
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9. On the View menu, verify that Ruler, Grid, and
Toolbox are selected.

You are ready to modify the properties of the
controls on the form.

Modifying the 
Format

Every control object has a property sheet. In the Beginning Course,
you formatted some of the controls using the Formatting toolbar.
This time, you are going to use the property sheet to modify how
text appears in a control.

1. In the Form Header section, select the Student
Grades label.

When a control object is
selected, sizing handles
appear around the
control.

2. On the View menu, choose Properties.

3. Verify that the All tab is displayed.

The Properties window appears. 

The items on this window depend upon the object
that is selected. On the Title bar of the Properties
window, notice that Access indicates that it is
displaying the properties of a label control.

Tip: You can resize the Prop er ties win dow to see
fewer or more of the avail able op tions.

4. On the Properties window, click the Format tab.

Notice the properties that are available.
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You will be working with most of these options
throughout these next two lessons. For now, you are 
going to work with the options that change the text
appearance.

5. Click an insertion point in the Fore Color property.
(You may need to scroll the list.)

On the Status bar, notice the description of the
property. This option is used to set the font color.

Tip: Keep in mind that the Sta tus bar dis plays
con text-sen si tive de scrip tions of the se lected
for mat ting op tion. For more as sis tance, you can
al ways tap the HELP key (F1) to dis play de tailed
help on the se lected op tion.

6. To the right of the Fore Color property, click
the Build button.

The Color window appears. 
You can select one of the
Basic colors or you can
define Custom Colors.

7. In the second row of the
Basic Colors, click the box
with the red color and 
click OK.

The color window closes
and the Fore Color changes
to 255 — the numerical
equivalent that Access
uses for this shade of red.
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Tip: A change in a property will not oc cur un til you
move the in ser tion point out of the property’s text
box.

8. Use the Font Size option to set a label size of 14.

9. The Font Weight option affects the thickness of the text.

Click an insertion point in the
Font Weight box and then tap F4
to display the options. 
(If the Toolbox toolbar appeared,
keep it on the screen. You will
use it shortly.)

Notice that there are more
options here than are available on the Formatting
toolbar.

10. Choose Extra Bold.

11. You will work more with the Properties window
throughout this lesson. For now, you will leave it open
as you work on the label directly.

If necessary, move the Property window so that
you can see the label that you just formatted. Do
not worry if all of the label text is not visible — you 
will resize the control shortly.

Resizing
Controls

The formatting changes that you just made have caused the
selected text to expand beyond the size of the actual control. You
are going to resize the label control so that all of the text fits inside
of it. Although you can do this by entering the appropriate
dimensions in the Width and Height settings of the Properties
window, you will look at two other techniques.

1. Point to the black handle in the middle of the right 
border of the label control.

The pointer should be in the form of a
double-headed horizontal arrow.

2. Drag about 1/2 inch to the right.

The label control has been resized. The Width option
on the Properties window changes to reflect the new 
size. This same technique is used to resize any
control.
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3. There is a menu command that will resize the control
automatically so that it fits the text.

With the label control still selected, click the
Format menu and point to Size.

Notice the options on the
submenu.

Since only one control is selected,
only the first two options are
available. The To Fit option will
adjust the size of the control to best fit the text (or
picture) contained in the control. The To Grid option
will adjust the size of the control to the nearest grid
points on the form (these are indicated by the dots
that appear on the form background).

4. Choose To Fit.

Notice that the control has been resized so that it fits 
the text perfectly. In the
Properties window, notice
that the Width of the control
has been adjusted (you may
need to scroll the window to see this). As it resized
the Label control, Access also needed to resize the
Form Header section.

5. Close the Properties window.

Working
with Text
Box Controls

The most common type of control on a form is the Text Box control. 
In the Beginning Course, you created Text Box controls by
dragging the field name from the Field List window to the form
design window. You can also use the Toolbox toolbar.

There are three main types of Text Box controls: bound, multiline,
and calculated. You will work with each of these.

1. The StudentGrades form should be open in Design
view.

Lesson 8 - Customizing Forms 139



Adding a
Bound Text
Box Control

In the Beginning Course, you used the Label button on the Toolbox 
toolbar to add a Label control to a form. The Toolbox also contains
tools for adding other types of controls. You are going to use the
Toolbox to add a Text Box control that will display the CourseGrade
field.

1. On the Toolbox toolbar, select the Text Box
button.

2. On the form design, position the pointer just under 
the Semester bound control.

Notice that the cursor is in the shape of a
crosshair with the Text Box symbol
attached.

3. Without releasing the mouse button, drag the
crosshair so that a control similar to the Semester
one is created.

On the Status bar, notice that Access indicates how
many lines and characters of the current font can be
displayed in the Text Box
control.

Tip: The same text is displayed
on the Status bar whenever you drag a control's
sizing handles.

4. Release.

Access creates a Label and a Text Box control. Notice 
that the Text Box control indicates that it is Unbound" that is, not connected to any field "#and that the
Label control consists of generic text. 

Do not be concerned that the generic text (in the
example below, Text 11) is different on your screen.
This is merely a sequential number that Access
assigns to each item placed on the form design.

5. You are going to modify the Text Box control so that it
is bound to a field.

On the View menu, choose Properties.
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6. On the Properties window, select the Data tab.

The Control Source property identifies the field to
which the control is bound. The Filter Lookup
property indicates how the control should handle
filters. The Smart Tags property lets Microsoft Office
associate the data in the control with other features,
such as a popup calendar for Date fields, recognize
names and open their contact information, etc. The
remaining properties are similar to the Field
Properties that appear in Table Design view.

7. Click an insertion point in the Control Source box
and tap F4 to display the drop-down list box.

Notice the fields that are
available in the CourseGrades
query.

8. Choose CourseGrade.

On the form design, notice 
that the control contains
CourseGrade, indicating
that it is bound to this
field. On the Properties window Title bar, however,
notice that it still contains the generic name of the
control. The source of a control is different from its
name. You will change this in a moment.

There is no need to modify the other Data
properties. Notice, however, that you can set an
Input Mask, Default Value and Validation Rule for the
control.

Note: For more about these Data prop er ties, see
Les son 2.
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9. You are going to change the name of the control.

On the Properties window, select the Other tab.

10. Change the contents of the Name option to:
CourseGrade

11. The change will not take effect until you move the
insertion point out of the option.

Tap the TAB key.

Although nothing happened on the form, notice that 
the Title bar of the Properties window now refers to
the control as CourseGrade. This is the name that
Access will use to reference this control object
internally.

12. You are going to change the label that is attached to
the CourseGrade control.

With the Properties window still open, click the
label that is associated with the CourseGrade
control.

Notice that the Title bar of the Properties window
indicates that it is displaying the properties for the
label.

13. On the Properties window, select the Format tab.

14. Change the contents of the Caption option to:
CourseGrade:

142 Microsoft Access 2003 - Intermediate



15. Tap the TAB key to move out of the Caption box.

On the form, notice that 
the text in the Label
control has changed.

16. On the Format menu, point to Size and then choose 
To Fit.

The size of the Label control is adjusted to fit the
label text.

17. Close the Properties window.

When you select an object in the Form Design window, its name
appears in the Select Object box of the Formatting toolbar.

1. In the Form Design window, click the CourseGrade
Text Box control to select it.

In the Select Object box on the
Formatting toolbar, notice the
name of the Text Box control. 
This is the name that you entered in the Name
property of the Properties window.

2. Select the CourseGrade Label control.

In the Select Object box, 
notice the generic label name. 
You modified only the Caption
property for this Label control, not 
the Name property.

Tip: You can use the Se lect Ob ject
drop-down list box to se lect the
items on the form.

Multiline
Controls

As you have seen, Text Box controls are used typically to display a
single line of text. If you have a large amount of text " in either a
Memo field or a long Text field " you will probably need more
than one line of text displayed. There are a few special properties
available for multiline controls.

1. The StudentGrades form should be in Design view.

2. The Comments field is a Memo data type. By default,
Access formats it as a multiline control.
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Select the Comments bound control.

3. On the Form Design toolbar, click 
the Properties button.

4. If necessary, click the Format tab to select it.

Notice the example on the next page. There are three 
important format properties to consider when
working with multiline controls:

Scroll Bars. This option allows you to choose which
(if any) scroll bars should appear when the insertion
point is in the field.

Can Grow. This affects how multiline fields appear if
you print the form. If Yes is chosen, Access will
increase the vertical size of the control (if necessary)
so that all the data can be printed. If No is chosen,
data that cannot be seen without scrolling will not
be printed. These properties do not affect how the
form appears on the screen.

Can Shrink. This affects how multiline fields appear
if you print the form. If Yes is chosen, Access will
shrink the vertical size of the control so that vertical
space is not wasted on the printed page. If No is
chosen, the control will not shrink when printed.

5. Verify that the Scroll Bars property is set to Vertical.

Note: Text boxes are al lowed to dis play only a
ver ti cal scroll bar. Other con trols can dis play a
hor i zon tal or ver ti cal scroll bar (or both).

6. Change the Can Grow property to Yes.
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7. Verify that the Can Shrink property is set to No.

8. Close the Properties window.

9. Before continuing, you are going to take a look at your
form.

Save changes to the form design.

10. Switch to Form view.

Notice the form.

Notice that the CourseGrade is formatted with the
Fixed number format. It has inherited this format
from the Courses table.

11. Click an insertion point in the Comments box.

Notice the vertical scroll bar that appears.

12. Navigate through the form and notice the different
grades for each student.

Working with forms is usually much easier than
working with tables.

13. Switch back to Design view.
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Creating
Calculated
Controls

You can use a Text Box control to display the result of any valid
calculation, which would include any of the calculation fields that
you created earlier. You are going to add a calculated Text Box to
display the full name of the student and another to display the
current date.

1. If the calculation field were already created in the
query, you could simply drag it from the Field List to the 
form design. Otherwise, you must use the Text Box
button in order to create a control in which to place the 
calculation expression.

On the Toolbox toolbar, select the Text Box
button.

2. To the right of the StudentID control, create a single 
line Text Box control that is about 11

2 inches wide.

3. Change the label of the new control to: Full Name:

4. Resize and position the label so that it is to the left 
of the control that you added.

Note: Re mem ber, to move an in di vid ual con trol,
point to the up per left cor ner of the se lected con trol,
un til the pointer is in the shape of 
a fin ger-point ing hand.

5. Click an insertion point in the unbound 
Text Box control. (To do so, click once to select the
control, then click once again to get an insertion
point.)

6. To create the full name, use the concatenation operator 
(&) to combine the FirstName and LastName fields
(along with a space to separate them).
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Type: =[FirstName]&" "&[LastName]

7. Tap the ENTER key.

After tapping the ENTER key, the control is selected
automatically.

8. You are going to change some properties for both the
calculation control and the label that you just added.

Click the Properties button.

9. On the Properties window, select the Data tab.

Notice the contents of the Control Source option. You
can enter the calculation directly in the Text Box
control or in this option of the Properties window.

10. On the Properties window, select the Other tab and 
then use the Name option to change the name of
the calculated control to: FullName

11. Close the Properties window.

12. For both the label and the calculated control, use
the To Fit command to resize the controls.

Tip: You can do this at once by us ing SHIFT/click to
select both fields. On the For mat menu, point to Size
and then choose To Fit.

You are going to use a calculation control to include the current
date in the Form Header section.

1. On the Toolbox toolbar, select the Text Box
button.

2. In the Form Header section, create a Text Box
control as follows:

3. You will not need a label.
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Click the generic label to select it and then tap the
DELETE key to remove the label from the form.

4. Click an insertion point in the Text Box control and
then type: =Now()

The result of this function will be the current date
and time. Earlier in this course, you used the =Date()
function to display only the current date (not the
time as well).

5. Tap the ENTER key to accept the calculation text.

6. You are going to modify the Properties of the control.
You can display the Properties window using the
Shortcut menu.

Right-click the calculation control.

Notice the context-sensitive
Shortcut menu.

7. On the Shortcut menu, choose
Properties.

The Properties window appears.

8. If necessary, select the Format
tab.

9. Change the Format property to
General Date (at the top of the
drop-down list box).

This will display the date and
time, using the DD/MM/YY HH:MM:SS PM format.

Note: Tech ni cally, Gen eral Date is the de fault for mat. 
You did not need to se lect it.

10. There is no reason for the date to appear as if it is in a
text box. You are going to format the text box so that it
is not visible.

On the Format tab, change the Back Style to
Transparent.

The Back Style is the appearance of the control's
background. When the default setting of Normal is
chosen, the control will be displayed using the color
indicated in the Back Color property.
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Back Color is the color of the background — normally 
white. Choosing Transparent overrides the color that
is selected in the Back Color option. 

11. On the Format tab, change the Special Effect to Flat.

This removes the default setting of Sunken.

12. Change the Border Style property to Transparent.

13. To the right of the Fore Color property, click
the build button.

14. When the Color dialog box appears, choose a dark
blue color and then click OK.

15. Change the Font Weight property to Bold.

16. Change the Text Align property (at the bottom of the 
dialog box) to Right.

This will ensure that the date always ends at the
right margin of the form.

17. Close the Properties window.

Notice the
formatted control.

18. Save changes to the form design and then switch
to Form view.

Notice the two calculation controls that you added
to the form.

19. On the Window menu, choose Size to Fit Form.

If necessary, Access resizes your form to remove any 
excessive space.

20. Navigate through the form and notice that the
Name calculation control changes as the StudentID
changes.

21. You cannot modify the results of a calculation field.

Click an insertion point in the Name calculation
control and try to change the name of the student.

Access does not allow you to modify the field.
Notice the error message on the Status bar.
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Note: Al though it does not ap pear to be so, the date
and time are the re sult of an ex pres sion in a Text
Box con trol. Click ing an in ser tion point in the date
or time would dis play the out line of the Text Box
con trol (which can not be mod i fied).

You may have noticed that the time does not change automatically
on a record. There are two ways to update the time.

1. If necessary, wait a few moments and notice that
the time displayed on the current record does not
change.

2. Go to the next record.

Notice that the correct time was updated when the
record changed. As before, however, the time is
again fixed.

3. You can update the time without leaving the active
record.

On the Records menu, choose Refresh.

Access updates the current record to display any
changes. Only the results of the =Now() function
have changed.

As mentioned, the Formatting toolbar contains buttons that can be
used to change some of the settings on the Properties window. In
particular, there are five drop-down buttons that modify the
settings you just used.

1. Switch to Design View so the Formatting toolbar
will be displayed.

Notice the following buttons:

Fill/Back Color button. Modifies the Back Color
property. There is a Transparent option that changes
the Back Style property.

Font/Fore Color button. Modifies the Fore Color
property.

Line/Border Color button. Modifies the Border Color
property. There is a Transparent option that changes
the Border Style property.
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Line/Border Width button. Modifies the Border Width
property. The thinnest border you can have is
Hairline. If you do not want a border to appear,
choose Transparent as the Border Style with the
Line/Border Color button (described above).

Special Effect button. Modifies the Special Effect
property.

2. Switch back to Form View.

Changing
the Tab
Order

In Form view, tapping the TAB key moves you from field to field
within a record and also from record to record. You can customize
the order in which the insertion point moves from field to field.

1. The StudentGrades form should be open in Form
view.

2. Tap the TAB key several times.

Notice the insertion point move from field to field.
Depending on how you would like to enter
information, this tab order may not be convenient.

3. Switch to Design view.

4. On the View menu, choose Tab Order.

The Tab Order dialog box appears.

5. The Section grouping allows you to choose the section
for which you will change the tab order.

In the Section grouping, choose Detail (if
necessary).
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In the Custom Order list
box, Access displays the
fields that are used in the
Detail section. Notice that 
only bound controls —
not Labels or Calculation
controls — are listed.

6. Since one would normally enter all grade information
before entering comments, you are going to place the
Comments field at the end.

In the Custom Order list box, click the Row Selector
for the Comments field.

The entire row is highlighted, indicating that the
field is selected.

7. With the tip of the pointer on the row selector for
the Comments field, drag down to the bottom of the 
list.

The Comments field is at the end of the Tab order.

Note: The Auto Or der but ton 
will cre ate a left-to-right,
top-to-bot tom tab or der, based on the po si tion of the 
fields in Form De sign view.

8. Click OK.

To see the changes, you need to switch to Form view.

Note: In Form De sign view, the tab or der is al ways
the or der in which the con trols were cre ated.

9. Switch to Form view.

10. Tap the TAB key several times.

Notice the new tab order. Also notice that the form
displays the next record when you reach the end of
the tab order.

11. Save changes to the form and then close it.

Note: If a control's Enabled property on the Data tab
is set to No, the control will not be included in the
tab order. By setting the Tab Stop property on the
Other tab to No, you can exclude a control from the
tab order (the control will still be usable with the
mouse).
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Improving
the Form
Design

After you have added and formatted the different control objects,
you will most likely need to spend some time arranging the form
layout so that it is pleasing to the eye. You might also want to
customize the background colors used for the different sections.

Access has options that allow you to do all of these things and
more. You will work with many of these commands in Lesson 10:
Improved Report Design. When you learn these techniques, keep in
mind that they work the same whether you are modifying a form
or a report. Likewise, keep in mind that the customization options
that you use with forms also work with reports.

Review
Exercise

In order to review the concepts presented in this lesson, you are
going to create the form displayed near the end of this exercise. The 
form is based on the Courses table.

1. Open a new Form Design window. Be sure to base
the form on the Courses table.

Note: On the View menu, ver ify that Ruler, Grid,
Tool box, and Form Header/Footer are all se lected.

2. In the Form Header section, use the Label button to 
create the Student Courses Offered label.

3. Use the Properties window to format the label in
14 point, bold, blue text.

4. Use the Format menu to size the label to fit.

5. Use any technique to place the following bound
controls on the form. Be sure to position and resize 
the controls as indicated.

6. First, you will adjust some of the properties on the
Format tab of the Properties window.

Format the CourseID bound control with bold text.
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7. Format the Comments field so that vertical scroll
bars will be displayed.

8. Next, you are going to adjust some of the properties on 
the Data tab of the Properties window.

For the Credits control, set a Default Value of 1.

9. For the same control, set the Validation rule so that
only the values of 0.5 or 1 are accepted.

Note: For as sis tance with de fault val ues and
val i da tion rules, see Les son 2.

10. For the Weight bound control, set a Default Value of
1 and then set the Validation Rule so that only 1 or
1.1 are accepted.

11. In the Page Header section, add a calculation
control to display the current date and time.

12. Format the control with the General Date format.

13. Adjust the format options for the calculation
control so that the date is displayed in colored text 
and the text box is not visible.

14. Save the form design with the name StudentCourses.

15. Switch to Form view and verify that your form
resembles the one below.

16. To test the validation rules you set, try changing
the Weight of one of the courses to 2.

17. Similarly, try changing the Credits for one of the
courses to 5.

End of Lesson 8
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