


Establishing
Referential
Integrity

Relationships between tables are essential for the creation of more
sophisticated databases. When you do this, however, you must be
aware that the data in your tables are no longer independent. For
example, if you were to change the StudentID field of a record in
the Students table, it is important that the related field in the
Guardians table be changed as well — otherwise, you would lose
the link between a student and his guardian.

To make sure that related data are not deleted or modified, Access
uses a system of “rules” called referential integrity. You are going to
examine referential integrity for related tables.

1. Open the Integrity database file.

Notice that this database contains many of the same
tables that were in the Relationships database.

2. On the Tools menu, choose Relationships.

The Relationships window opens. Notice the
various relationships between the tables.

3. Click the join line between the Students Field List
and the StudentGrades Field List.

The join line appears darker, indicating that the
relationship is selected.

4. On the Relationships menu, choose Edit
Relationship.

The Edit Relationships dialog box appears.

Tip: Al ter na tively, you can sim ply dou ble-click the
join line.
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5. Select the Enforce Referential Integrity option.

A check mark appears 
in the box, indicating
that the option is
selected. Also notice that the Cascade Update Related
Fields and Cascade Delete Related Records options are
no longer dimmed. You will use these options later.

6. Click OK to close the dialog box.

Notice the change in the
join line between the
linked tables.

To indicate that referential
integrity is enforced between these tables, Access
indicates the type of relationship that exists between 
them. Since these tables use a one-to-many
relationship, Access places a 1 near the Students
Field List and the symbol for infinity (") near the
StudentGrades Field List.

In order to maintain the relationship between the Students and
Guardians tables, you are going to establish referential integrity.

1. You can edit a relationship through the Shortcut menu.

Right-click the join line between the Students 
and the Guardians tables.

2. On the Shortcut menu, 
choose Edit Relationship.

Note: If Edit Re la tion ship does
not ap pear on the Short cut menu, ver ify that the tip
of the pointer is di rectly on the join line and then try
again.
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3. On the Edit Relationships dialog box, click the
Enforce Referential Integrity option to select it, and
then click OK.

Notice the change in the join line between the Field
Lists. When referential integrity is enforced, it is
easy to see what type of
relationship exists between 
two tables.

4. Save the layout of the
Relationships window.

5. Close the Relationships window.

Note: If you try to es tab lish ref er en tial in teg rity
be tween two ta bles, make sure that the re lated ta ble
of the re la tion ship does not con tain a re cord whose
for eign key value does not oc cur in the pri mary
ta ble of the re la tion ship. As you will see, this would
vi o late the sec ond rule of ref er en tial integrity. In the
relationship you just cre ated, the pri mary ta ble was
the Stu dents ta ble and the for eign key was the
StudentID field in the Guard ians ta ble.  If there are
records in the Guard ians ta ble whose StudentID do
not ap pear in the Stu dents ta ble, those re cords have
no "point of ref er ence" — that is, you have a guard ian
with no stu dent. This unreferenced data is likely to
be lost or in ac ces si ble to the database's users.  

Testing
Referential
Integrity

Once again, referential integrity is used to preserve the
relationships between primary and related tables when you modify 
records. When referential integrity is enforced, you must observe
three rules. In no particular order, these rules are:

! Rule 1: You cannot delete a record in the primary table if
related records exist in the related table. This would
leave records in the related table with no relationship to
other data in the database — you would "lose" data and
there might be no way of accessing it, short of reading
through all the records.

! Rule 2: You cannot add a primary key field value in the
related table if the primary table does not already contain 
that value.

66 Microsoft Access 2003 - Intermediate



! Rule 3: You cannot change a value in the primary key
field of the primary table if a related record exists in the
related table.

You are going to test these rules on the relationships that you just
modified.

1. Open the Students table in Datasheet view.

Notice the records in the table.

2. You are going to try to delete the first record in the
table. Keep in mind that each of these students have
grades listed in the StudentGrades table.

Click an insertion point anywhere in the first
record.

3. On the Edit menu, choose Delete Record.

The following alert box appears.

Since the student with StudentID 1001 has related
records in the StudentGrades table, deleting this
record would violate the first rule of referential
integrity.

Note: If you do not see the alert box, make sure that
you chose De lete Re cord (not sim ply De lete) from the
Edit menu.

4. Click OK to close the alert box.

The selected record is not deleted.

You are going to test the third rule of referential integrity by trying
to modify the StudentID of the first record.

1. In the first record, change the contents of the
StudentID field to: 2001

Although it seems as if you are able to change the
field, Access will not allow you to save these
changes to disk.

2. Use SHIFT/ENTER to save changes to the record.
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The same alert box appears as before. Since Jamaal
Young has related records in the StudentGrades table, 
Access will not allow you to modify the StudentID
field. Doing so would violate the third rule of
referential integrity.

3. Click OK to clear the alert box.

4. Tap the ESC key to undo the changes.

Note: Keep in mind that Ac cess pre vents you from
mod i fy ing the StudentID field be cause it is the
pri mary key of the re la tion ship. If a field is not
re lated to another ta ble, you will not be pre vented
from mod i fy ing its con tents.

You are going to test the second rule of referential integrity by
trying to add a grade for a student that does not exist.

1. Close the Students table.

2. Open the StudentGrades table.

3. On the Table Datasheet toolbar, click the
New Record button.

4. Enter the following record. When you get to the
last field, do not tap the TAB key.

StudentID: 2001
CourseID: MAT151
Semester: 952
CourseGrade: 3.67

5. Use SHIFT/ENTER to try to save the new record.

The following alert box appears.

Access will not allow you to add the record. You
tried to add a record in a related table,
StudentGrades, having a one-to-many relationship
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with the primary table, Students. Since a record for a
student with StudentID of 2001 does not exist in the
primary table of this relationship, this record fails the 
second rule of referential integrity.

6. Click OK to clear the alert box.

7. On the Edit menu, choose Undo Current Field/Record.

The record is removed from the datasheet.

8. Close the StudentGrades table.

Overriding
Referential
Integrity

There are two options that allow you to modify and delete related
records while still maintaining referential integrity between related 
tables. When these options are selected, instead of getting an alert
box when you try to modify a primary key in a table, Access will
simply make the same modification to all records in related tables.
You are going to take a look at how these options work.

1. On the Database toolbar, click the
Relationships button.

2. Select the join line between the Students Field List
and the StudentGrades Field List.

3. On the Relationships menu, choose Edit
Relationship.

Notice the options available under the Enforce
Referential Integrity
option.

Cascade Update Related
Fields. When selected,
modifying the primary key in the primary table will
cause any matching foreign keys in the related table
to be updated as well — the change "cascades"
down from the primary table to the related tables.

Cascade Delete Related Records. When selected,
deleting a record in the primary table will cause any
matching records in the related table to be deleted 
as well.

4. Select both of the Cascade options.

5. Click OK to make the changes to the relationship
and close the dialog box.
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Although referential integrity will be maintained
between these two tables, you have told Access to
override two of the rules.

When overriding the rules of referential integrity, it is important to
be aware of all of the relationships involving a particular table.
Although you have selected the two cascade options for the
relationship between the Students table and the StudentGrades table, 
there is also a relationship between the Students and the Guardians
tables. Since referential integrity is being enforced for this
relationship, Access will not allow you to change the primary key
field of the Students table unless the cascade options are enabled on 
all relationships involving the Students table.

You are going to select the cascade options for the one-to-one
relationship between the Students and the Guardians tables.

1. Right-click the join line between the Students Field
List and the Guardians Field List.

2. On the Shortcut menu, choose Edit Relationship.

3. On the Edit Relationships dialog box, click the
Cascade Update Related Fields and the Cascade
Delete Related Records options to select them.

4. Click OK to close the dialog box.

Note: Keep in mind that al though there is a
re la tion ship be tween the Courses ta ble and the
StudentGrades ta ble, ref er en tial in teg rity is not be ing
en forced for the re la tion ship.

5. Close the Relationships window.

Testing
Cascading
Updates

In order to see how the cascading update option works, you are
going to open the two related tables and then update one of the
StudentID fields in the primary table.

1. Open the Students table.

2. You are going to open a related table as well.

On the Table Datasheet toolbar, click the
Database Window button.

The Database window is active again.
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3. Double-click the StudentGrades table to open it.

4. You are going to minimize the Database window and
then arrange the two datasheets.

On the Table Datasheet toolbar, click the
Database Window button.

5. On the Integrity: Database window, click the
Minimize button.

6. On the Window menu, choose Tile Vertically.

The windows should look like the following:

7. In the Students table, click an insertion point in the
first record.

8. Change the contents of the StudentID field to: 2001

9. Use SHIFT/ENTER to save the changes to disk.
(Alternatively, you can simply move the insertion
point away from the record.)

Since the Cascade Update Related Fields option is
enabled, Access allows you to make the modification.
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In order to maintain referential integrity between
the tables, however, Access makes the same changes 
to the corresponding StudentID in the related table.

If referential integrity were not being enforced,
Access would not have changed the StudentID field
in the related table (StudentGrades). This would have 
caused problems, for in the Students table, Jamaal
Young would have had a StudentID of 2001. In the
StudentGrades table, however, he would have still
had a StudentID of 1001.

10. You are going to update another StudentID in the
Students table.

Click an insertion point in the second record of the
Students table.

11. Change the StudentID field to: 2002

12. Use SHIFT/ENTER to save the changes to disk.

13. Scroll the StudentGrades datasheet.

In the StudentGrades table, notice that the
corresponding StudentID was updated.

If you have made a mistake and would like to go back to the
original StudentID, you can use the Undo command.

1. Select the Students table datasheet.

2. On the Edit menu, choose Undo Saved Record.

In both the primary table (Students) and the related
table (StudentGrades), Access reverts to the original
value of the field.

Note: Of course, in both of these cases, Ac cess also
makes the ap pro pri ate changes in the StudentID of
the Guard ians table, because you chose Cascade
Update for this relationship as well.
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Testing
Cascading
Deletes

You are going to use similar techniques to test the cascading
deletes option. Be aware, however, that you cannot undo the
deletion of a record.

1. You are going to delete a record from the Students
table.

Click an insertion point in the third record of the
Students table (the one with a StudentID of 1003).

2. On the Edit menu, choose Delete Record.

An alert box appears indicating that a cascading
delete is about to take place.

3. Click Yes to delete the record and all related
records.

The record is deleted from the Students table and all
related tables where referential integrity is being
enforced.

4. Scroll the StudentGrades datasheet.

Notice that Access indicates where the deleted
records were located in the table. This indication
will no longer appear after you close the table.

5. You are going to open the Guardians table.

Close the two open table datasheets.
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6. If necessary, restore the Database window.

7. Double-click the Guardians table object to open the
datasheet.

Notice that the record for the student with a
StudentID of 1003 does not appear. This record was
deleted when the corresponding record in the
primary table (Students) was deleted.

Also notice that the previous StudentID of 1001 has
been updated to reflect the new StudentID of 2001.

8. Close the datasheet.

Note: Keep in mind that the cas cad ing op tions are
“one way” re la tion ships. The cas cade up date op tion
works only when you mod ify the pri mary key field
in the pri mary ta ble of the re la tion ship. The cas cade
de lete op tions works only when you de lete a re cord
in the pri mary ta ble of the re la tion ship.

Printing a
Relationships
Report

As you create more sophisticated database systems, managing the
table relationships becomes very important. Although the
Relationships window provides an important graphical overview,
it can be convenient to have a more detailed report that can be
printed. Access allows you to create such a report.
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1. In order to create the report, the Relationships window
must be closed.

Verify that the Relationships window is closed.

2. On the Tools menu, point to Analyze.

Notice the submenu that appears.

3. Choose Documenter.

The Documenter dialog box appears. For now, you
will use it only to print a relationships report. The
tabs at the top represent the different Access objects
that can be analyzed.

4. Click the Current Database tab.

Notice the objects from the current database that can 
be analyzed.

5. Click the Relationships check box to select it and
then click OK.

Access analyzes the relationships in the database,
displaying messages on the Status bar as it does this.

After a few moments,
the Object Definition
window appears in
Print Preview view.
Access has produced
a report containing
detailed information
on the relationships 
in the database.
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6. Maximize the Object Definition window, and use
the Zoom Control drop-down list box and Page
buttons to view different parts 
of the report.

7. To print the report, choose Print
from the File menu. If you are not 
going to print the report, close
the Object Definition window.

Review
Exercise

To review the concepts presented in this lesson, you are going to
enforce referential integrity on some of the existing relationships
and then use the cascading options.

1. Open the Integrity 2 database.

2. Open the Relationships window.

3. Display the MathTeam Field List.

4. Create a one-to-one relationship between the
Students table and the MathTeam table (the related
fields should be StudentID). Enforce referential
integrity and enable the cascading options.

Note: Since there are more re cords in the Stu dents
ta ble than the MathTeam ta ble, the Stu dents ta ble
should be the pri mary ta ble in the re la tion ship
(oth er wise, you will not be able to en force ref er en tial 
in teg rity). When cre at ing this re la tion ship, then, be
sure to drag the StudentID field from the Stu dents
Field List to the MathTeam field list.

5. Enforce referential integrity for the relationship
between the Courses and the StudentGrades tables.
Do not enable the cascade options.

6. Save the layout and then close the Relationships
window.

7. Open the Courses table and try to modify one of the 
CourseID fields.

Access should prevent you from modifying this field.

8. In the same table, try to delete one of the records.

Access should prevent you from deleting the record.

9. Open the Students and MathTeam tables. Arrange
them so that they are side-by-side.

76 Microsoft Access 2003 - Intermediate



10. Change the StudentID for Sherrill Williams to: 2005

The corresponding field changes in the MathTeam
table.

11. In the Students table, delete the record for Marcus
Pierno (1008).

The corresponding record is deleted in the
MathTeam table.

12. Open the StudentGrades and Guardians tables and
notice that the cascading options made the
appropriate updates and deletes.

13. Use the Documenter to create a new relationships
report.

End of Lesson 4
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Lesson 5 Querying a Relational Database

Lesson Topics! Creating Multi-table Queries! Summarizing Data! Review Exercise

Lesson Objectives
At the end of the lesson, you will be able to:! Create queries based on multiple tables that are joined

through relationships;! Use the Total row of the query design grid to count,
summarize, or average fields;! Use the Top Values drop-down list box to display only the 
highest values for a particular field;! Use the Group By setting to group the query results by a
specified field or by several fields.

Student Files Used
You will use the following file from your student folder:! Queries
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Creating
Multi-Table
Queries

In the Beginning Course, all of the queries that you created were
based on a single table. Now that you have created relationships
between the different tables in your database, you can create
queries that involve more than one table. Multi-table queries are an 
important part of any relational database management system.

You are going to create some multi-table queries.

1. Open the Queries database file.

2. Before you create the queries, you are going to look at
the Relationships window.

On the Tools menu, choose Relationships.

Notice the relationships that have been created. Any 
of these linked tables can be used easily in a
multi-table query.

3. Close the Relationships window.

Queries with
One-to-One
Relationships

Just as one-to-one relationships are not as common as one-to-many
relationships, queries involving one-to-one relationships are not as
common as other types of queries. 

You are going to create a query that lists students with their
guardians. All of the queries that you will create in this lesson are
Select Queries. 

1. On the Database window, select the Queries tab.

2. Click the New button.

The New Query dialog box appears. You are going
to use Design view to create the query.

3. Verify that Design View is selected and then click OK.

The Show Table window appears, with the Query
Design window behind it.

80 Microsoft Access 2003 - Intermediate



4. To create this query, the Students and Guardians tables 
must both be displayed.

On the Show Table dialog box, use CTRL/click to
select both the Students and Guardians tables. If
another table is selected, such as Attendance,
deselect it.

5. On the Show Table dialog box, click the Add button 
and then click the Close button.

In the top pane of the Query Design window, the
Field Lists for the selected tables appear. Notice that
Access indicates that the tables are related with a
join line between the appropriate fields.

6. Your query will display information from both tables.

In the Students Field List, double-click the StudentID
field.

Access places the field in the
first column of the design
grid. Notice that the Table
row indicates the table in
which the field is located.

Note: If the Ta ble row is not
dis played on your grid, choose Ta ble Names on the
View menu.

7. In the same way, place the LastName and FirstName
fields from the Students Field List to the query
design grid.

8. Remember, you can also select the appropriate field
from the Field row. You are going to use this technique
to place the Contact1 field in the design grid.

Click an insertion point in the Field row of the
fourth column and then tap F4 to display the list
box.
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