


One-to-Many
Relationships

As mentioned, Access is a relational database system. This is what
allows you to “link” information from one table to another.
Whereas most of your work in the Beginning Course was done on
one table at a time, your work in the Intermediate Course will
involve multiple tables at the same time. In order to do this, you
must be able to create appropriate relationships between the
different tables in your database.

1. Open the Relationships database file. Remember, all 
database files are stored in the FLS Access2003
Student Files folder on the C drive. If you see a
Security Warning dialog box, click Open.

2. If necessary, click the Tables tab of the Database
window.

Notice the different tables in the database. Since
they have been set up using the guidelines in the
first lesson, you must create relationships between
the tables in order to use the related information.

The most common type of relationship between two tables is a
one-to-many relationship, in which a single record in one table can
be related to multiple records in another table. An example of this
would be the relationship between a Clients table and an Orders
table. A particular client would appear as only one record in the
Clients table, but would probably have multiple records in the
Orders table — one record for each order placed. 

You are going to create a one-to-many relationship between the
Students table and the StudentGrades table.

1. The Relationships window is the easiest way to create
relationships.

On the Tools menu, choose Relationships.

The Relationships window appears in the
background and the Show Table dialog box appears
in the foreground.
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As you will learn, an empty Relationships window
does not mean that there are no relationships
defined for this database.

Note: If the Re la tion ships win dow is not empty,
close the Show Table dialog box if necessary, choose
Clear Lay out on the Edit menu and then click Yes on
the alert box.

2. You need to display some tables. 

If the Show Table dialog box is not on the screen,
choose Show Table on the Relationships menu.

3. On the Show Table dialog box, verify that the
Tables tab is selected.

4. Choose Students and then click the Add button.

In the Relationships window, notice that the
Students Field List appears. (You may need to move
the Show Table dialog box in order to see this.)

5. On the Show Table dialog box, select StudentGrades
and then click the Add button.

Tip: Al ter na tively, you can sim ply dou ble-click the
ta ble to dis play it.

6. You do not need to display any more tables.

On the Show Table dialog box, click Close.

The Relationships window should look like the one
on the next page.
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The Field List displays all of the fields for the
selected table. Bold text is used to indicate the
primary key for the table.

Tip: You can scroll or resize a Field List to dis play all 
fields.

Relationships are formed by matching the information in fields.
Normally, these key fields will have the same name. What is most
important, however, is that they are the same data type and size.
Since the StudentID field is common to both tables, these are the
fields that will be matched.

1. Drag the StudentID field from the Students Field List
to the StudentID field in the StudentGrades Field
List.

When you release the mouse, the Edit Relationships
dialog box appears.
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At the top of the dialog box, Access lists the primary 
table (Students) on the left and the related table
(StudentGrades) on the right. Since you dragged the
StudentID field from the primary table to the
StudentID of the related table, this field appears in
both columns.

2. Verify that the StudentID field is displayed in both
columns. If it is not, click an insertion point in the
column and use the drop-down list box to change
the field.

At the bottom of the dialog box, notice that Access
indicates that the relationship type is One-To-Many.
Keep in mind that although the StudentID field is
unique in the Students table, it is not unique in the
StudentGrades table (each student has more than one
grade stored in the table). This is why the
relationship is one-to-many.

3. Click the Create button.

You have related the Students table to the
StudentGrades table.

In the Relationships window, notice the join line that
appears between the Field Lists, “linking” the
StudentID field in each table. This is simply a
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graphical representation of what Access has done
internally.

4. No matter where the Field Lists are placed in the
Relationships window, a join line will connect the
related fields.

Point to the Title bar of the StudentGrades Field List 
and drag down and to the right.

Notice that the join line adjusts as you move the
Field List.

5. The relationship itself is already saved. If you would like 
to keep this graphical representation of the relationship, 
however, you must save the Relationships window.

On the File menu, choose Save.

The current layout of the Relationships window is
saved.

6. You will create another relationship in a moment. For
now, you are going to return to the Database window.

Close the Relationships window.

Relating
Non-Primary
Key Fields

Two related fields do not both have to be primary key fields. You
are going to create a relationship between the Students table and
the HomeRooms table. The HomeRooms table contains only the
unique homeroom numbers and the corresponding teachers. The
Students table contains a HomeRoom field, but it does not list the
name of the teacher.

1. On the Tools menu, choose Relationships.

The Relationships window appears. Since there is a
layout already, the Show Table dialog box does not
appear.
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Tip: You can dis play the Re la tion ships win dow by
click ing the Re la tion ships but ton 
on the Da ta base toolbar.

2. On the Relationships menu, choose Show Table.

The Show Table dialog box appears.

Tip: You can also dis play this di a log box by click ing
the Show Ta ble but ton 
on the Re la tion ships toolbar.

3. With the Tables tab active, double-click
HomeRooms and then click the Close button to
close the dialog box.

In the Relationships window, notice the Field List
for the HomeRooms table. Notice that
the HomeRoom field is the primary
key field of the HomeRooms table.

4. You are going to display the HomeRoom
field in the Students Field List. This can be done by
scrolling or resizing the box.

Drag the bottom border of the Students Field List
until you can see all of the fields.

5. You are going to relate the HomeRoom fields in the two 
tables.

Drag the HomeRoom field from the Students Field
List to the HomeRoom field of the HomeRooms Field 
List.

The Edit Relationships dialog box appears.

At the top, notice that Access has listed the
HomeRooms table on the left side, indicating that it is
the primary table (i.e., the “one” table) in the
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relationship. The related table (i.e., the “many”
table) is the Students table.

6. Verify that the HomeRoom field is listed in both
columns. If not, use the drop-down list box to
choose it.

At the bottom of the dialog box, notice that Access
identifies this as a one-to-many relationship. Once
again, each record in the HomeRooms table
represents a unique homeroom. In the Students table, 
however, each homeroom is listed more than once.
This is why it is a one-to-many relationship.

7. On the dialog box, click the Create button.

In the Relationships window, Access represents the
relationship graphically by connecting the
appropriate fields with a join line.

Note: To dis tin guish the linked fields, the
HomeRoom field of the pri mary ta ble is referred 
to as the pri mary key. The HomeRoom field of the 
related ta ble is re ferred to as the for eign key.

8. Move the Field List boxes so that the Relationships
window looks similar to the one below.

9. On the File menu, choose Save to save the
Relationships layout.

10. Close the Relationships window.

52 Microsoft Access 2003 - Intermediate



One-to-One
Relationships

Another type of relationship between two tables is a one-to-one
relationship. In such a relationship, each record in the primary
table has at most one matching record in the related table. This
type of relationship is often used to break up large tables, or to put
confidential information (such as credit card numbers for a client or 
salary scale for an employee) in a separate table.

You are going to create a one-to-one relationship between the
records in the Students table and the records in the Guardians table.

1. The Database window should be active.

2. On the Database toolbar, click the
Relationships button.

3. On the Relationships toolbar, click the Show
Table button.

4. With the Tables tab of the Show Table dialog box
selected, double-click the Guardians table.

5. Click Close to close the dialog box.

6. The relationship will be between the StudentID fields of 
the two tables.

If necessary, scroll the Students Field List so that
the StudentID field is visible.

7. Drag the StudentID field from the Students Field List
to the StudentID field of the Guardians Field List.

The Edit Relationships dialog box appears.

8. Verify that the StudentID field is listed in both
columns.

At the bottom of the dialog box, notice that Access
determines that this is a one-to-one relationship.
Whenever the two related fields are unique primary
keys, Access will create a one-to-one relationship.

9. On the Edit Relationships dialog box, click the
Create button.

In the Relationships window, notice the graphic
representation of the link between the Students table
and the Guardians table.

10. Move the Field List boxes as you wish so that all of 
the join lines are clearly visible.
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11. On the File menu, choose Save to save the layout.

12. Close the Relationships window.

Many-to-
Many
Relationships

A many-to-many relationship occurs when one record in either
table has more than one matching record in the other table. An
example of a many-to-many relationship would be the relationship
between students and courses. Each student takes more than one
course, and each course contains more than one student.

Like most relational database systems, Access does not work
directly with many-to-many relationships. Instead, a junction table
is used as an intermediary between the two tables. A junction table
is simply a table that contains the primary keys of the tables with
the many-to-many relationship. In this way, a many-to-many
relationship is created by defining two one-to-many relationships
— one between each primary table (a table containing a primary key 
and having unique records) and the junction table. In each
one-to-many relationship, the primary table is on the "one" side of
the relationship and the junction table is on the "many" side.

With the help of a junction table, you are going to relate the
Students and the Courses tables.

1. First, you are going to look at the tables that will be
used. You already know what the Students table looks
like. You will look at the others.

On the Database window, double-click the Courses
table object to open it in Datasheet view.

Notice that the table contains a list of the courses
offered at the school. Since the CourseID field is
unique for each record, it has been set as the primary 
key field for the table.

Since every course contains more than one student,
each record in this table is related to multiple
records in the Students table. This does not make it a
one-to-many relationship, however, for at the same
time, each student takes more than one course. This
means that multiple records in the Courses table are
related to a single record in the Students table.
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2. You are going to look at the table that will be used as a 
junction between the Students and the Courses tables.

Close the Courses table.

3. Open the StudentGrades table.

The StudentID field relates the Students table to the
CourseID field in the Courses table.

This table contains the primary key of the Students
table (StudentID) as well as that of the Courses table
(CourseID). This makes it a good candidate for a
junction table between these two tables.

4. Close the StudentGrades table.

5. As with all relationships, many-to-many relationships
are created in the Relationships window.

On the Tools menu, choose Relationships.

Since you have already created a number of
relationships, the window is somewhat cluttered.
You are going to clear the window to make it easier
to work. Clearing the layout will not affect any of
the current relationships — it will simply remove
the graphical representation of the relationships.

6. On the Edit menu, choose Clear Layout.
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The following alert box appears.

7. On the alert box, click Yes.

The Relationships window is cleared. Once again,
only the representation of the relationships is
cleared. The actual relationships between the tables
remain. (You will delete relationships later.)

Tip: You can clear re la tion ships by click ing
the Clear Lay out but ton 
on the Re la tion ships toolbar.

8. On the Relationships menu, choose Show Table.

9. On the Show Table dialog box, double-click the
following tables: Courses, StudentGrades, and
Students.

Tip: By holding down the CTRL key, you can select
multiple tables from the Tables list. When you click
Add, all selected tables will be added at once.

10. On the dialog box, click the Close button.

Notice the Field Lists for the three tables.

There is already a join line between the StudentID
fields in the Students and StudentGrades tables. This
is from the one-to-many relationship that you
created earlier. This is half of what you need.

11. You are going to create the relationship between the
StudentGrades and the Courses tables.

Drag the CourseID field from the Courses Field List
to the CourseID field of the StudentGrades Field List.

The Edit Relationships dialog box appears. Notice
that this time you have created a one-to-many
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relationship from the Courses table to the
StudentGrades table.

12. Click the Create button.

The Relationships window should look like the
following:

Since the StudentGrades table is able to serve as a
junction table, you now have a relationship between
the Students table and the Courses table.

13. On the File menu, choose Save to save the layout.

14. Close the Relationships window.

Remember: A many-to-many relationship is a
combination of two one-to-many relationships (with 
the second one being looked at as a many-to-one
relationship).

Notes When a table has a relationship, plus marks (+) appear to the
left of its records indicating a subdatasheet
(i.e., the datasheet of the table with which it
has a relationship). Clicking a plus mark
displays the subdatsheet for that record.
The feature is used most commonly with
one-to-many relationships. 

Generally there will not be a preexisting table that will serve
as a junction table. If this is the case, you will create a
junction table by creating a new table, copying each primary
key fields from the two primary tables, and then
constructing the one-to-many relationships.

You can define only one type of relationship between two
tables.
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A relationship cannot be created if one of the tables is open.

Many-to-one relationships are simply the converse (or
reverse) of one-to-many relationships. To create a
many-to-one relationship, create the appropriate
one-to-many relationship.

As mentioned, related fields must be of the same data type.
In addition, for Number data types, the fields must have the
same Field Size property. The only exceptions to this are that
you can match an AutoNumber field with a Long Integer
Number field, and you can match a Replication ID Number
field with a Replication ID AutoNumber field.

Managing
Relationships

You have already used the Relationships window to create and
display relationships between tables. In the same manner, you can
use the Relationships window to manage the relationships in the
database.

1. On the Tools menu, choose Relationships.

The Relationships window appears with the most
recently saved layout.

2. As you have seen, the Clear Layout command removes
all Field Lists from the window.

On the Edit menu, choose Clear Layout.

3. On the alert box, click Yes to continue.

The Relationships window is cleared.

Displaying
Relationships

At times, it might be convenient to display only the relationships
for a particular table — not the entire database. You are going to
display the relationships that involve the Students table.

1. On the Relationships toolbar, click the Show
Table button.

2. Double-click the Students table to display its Field
List.

3. Click Close to close the Show Table dialog box.

Notice the Field List for the Students table.
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4. On the Relationships menu, choose Show Direct.

Notice the three other Field Lists that appear in the
Relationships window. (You may have to drag the
related Field Lists to see the join lines.) Access
displays the Field Lists for all tables that are directly
related to the Students table. In addition, the join
lines between the fields are displayed. This can
make it easier to see how changes in one table might 
affect other tables.

Tip: You can click the Show Di rect
Re la tion ships but ton 
to dis play re la tion ships for a spe cific ta ble.

You can hide an individual Field List so that it does not appear on
the layout. You are going to hide the HomeRooms Field List.

1. Click the Title bar of the HomeRooms Field List in
order to select it. (The Title bar will not be
highlighted " only the first item.)

2. On the Relationships menu, choose Hide Table.

The Field List and the relationship link for the
HomeRooms table disappear.

Tip: You can also hide a Field
List by right-click ing its Ti tle
bar and choos ing Hide Table
from the Short cut menu.

You can use the Show All command to display all database
relationships.

1. On the Relationships menu, choose Show All.

The HomeRooms Field List reappears. In addition, the 
Courses Field List appears. So far, the Courses table is
the only table that is not directly related to the
Students table.

Tip: You can also click the Show All
Re la tion ships but ton.

2. On the File menu, choose Save to save the changes
to the layout.
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Deleting
Relationships

You can use the Relationships window to delete existing
relationships. You are going to delete the relationship between the
Students table and the HomeRooms table.

1. On the Relationships window, click the join line
between the Students and HomeRooms tables.(If
necessary, first drag the HomeRooms Field List to
see the join line more clearly.)

Notice that the join line appears thicker.

2. On the Edit menu, choose Delete.

An alert box appears asking you to verify the action.

3. Click Yes to delete the relationship.

The relationship between the tables is deleted.
Notice that the Field Lists remain.

Note: This ac tion can not be un done. To re store the
re la tion ship, you would have to cre ate it again.

Tip: In stead of us ing the menu com mand, you can
sim ply tap the DELETE key to de lete a se lected
re la tion ship.

4. Save changes to the Relationships window.

Note: You can mod ify the de sign of any ta ble
dis played in the Re la tion ships win dow. To do this,
right-click the Ti tle bar of the ap pro pri ate Field List
and then choose Ta ble De sign on the Short cut menu.
Ac cess will open the ta ble in Design View.
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Review
Exercise

To review the concepts presented in this lesson, you are going to
establish more relationships between tables in the database, and
then modify the layout of the Relationships window.

1. The MathTeam table lists the students who belong to
the school’s mathematics team. This table should be
related to the Students table.

Open the Relationships window (if necessary).

2. Create a one-to-one relationship between the
Students table and the MathTeam table. The
common field is StudentID.

3. The Attendance table lists the attendance for each
student. This table should be linked to the Students
table as well.

Create a one-to-many relationship between the
Students table and the Attendance table.

4. By now, the Relationships window is rather cluttered.

Clear the layout of the Relationships window.

5. In the Relationships window, display only the tables
that are directly related to the Students table.

6. Arrange and resize the Field Lists so that the
Relationships window looks like the following:

7. Save changes and then close the Relationships
window.

End of Lesson 3
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