


Customizing
a Report
Layout

In the Beginning Course, you created and modified a number of
different reports, both manually and with the Report wizard. You
are going to work with a few techniques that will enable you to
improve the design of a report. As mentioned in Lesson 8, many of
these techniques can be used when designing forms as well.

1. Open the Reports 2 database file.

2. On the Database window, select the Reports tab.

3. Double-click the CreditsEarned report object to open 
it in Print Preview view.

Notice the report.

For each student, the report lists the courses taken
and summarizes the number of credits earned. At
the moment, the items on the report are not aligned
very well, making it somewhat difficult to read. You 
are going to fix their alignment and then format the
report.

Note: This re port is based on the CreditsEarned
query.

4. Use the View button on the Report Design toolbar
to switch to Design View.

Notice the report in Design view. 

5. If necessary, resize the report window to see the
whole report.
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The report design consists of a variety of sections
and controls. As a review, we will discuss the
sections that are being used in this report.

The Report Header is used to display information at
the very beginning of the report. Notice that it
contains a Label control and a calculated control that 
uses the Now() function.

The Page Header is used to display information at the 
top of each page of the report. (The calculated
control can be created using the Page Number
command on the Insert menu.)

The Grade Header section is a result of the Sorting and
Grouping option. Because the report was made to
group records by the Grade field, it inserted this
section in order to place the text that distinguishes
each Grade group. As a result, the records will be
grouped by the Grade field. The first control in this
section is bound to the Grade field.

The StudentID Header section is also the result of the
Sorting and Grouping option. Within each grade, the
records will be grouped by the StudentID field. This
way, each student's name appears only once,
grouping all courses by student.

The Detail section will display the three bound
controls for each record in the query results (each
course taken by each student).
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The StudentID Footer section is used to summarize
the information for each StudentID grouping. In this
case, a calculation control uses the Sum() function to
total the credits for each StudentID.

Note: For more help on re port sec tions, see the
Be gin ning Course.

Adjusting
Alignment
and Spacing

To create a professional-looking report, it is important for the
controls on the report to be aligned and spaced out properly.
Although you can position a control manually, it can be difficult
(and tedious) to align multiple controls this way. An easier
technique is to use the commands available on the Format menu.

1. You will begin by aligning the controls in the Report
Header section.

Select the Credits Earned label.

2. To select more than one control, hold down the SHIFT
key as you click the other controls.

While holding down the SHIFT key, click the
calculated control at the right side of the Report
Header.

Both of the controls in the Report Header are
selected.

Tip: You can also se lect mul ti ple con trols by
drag ging through them.

3. On the Format menu, point to Align.

Notice the alignment options 
on the submenu. With the exception of 
the To Grid option, the items on this
submenu are available only if two or
more controls have been selected. (The 
To Grid option is available even if only one item is
selected. It will cause Access to align the selection to
the nearest “gridpoint” on the form.) 

4. On the submenu, choose Bottom.

The bottom edges of the controls are aligned.

5. Click an empty area to deselect the controls.

6. You can align controls in different sections. You are
going to align the calculation control that displays the
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date (in the Report Header section) with the calculation 
control that displays the page number (in the Page
Header section).

Select the date and the page number controls.

7. On the Format menu, point to Align.

On the submenu, notice that the Top and Bottom
items are not available. You cannot align objects in
these ways if the objects are in different sections.

8. On the submenu, choose Right.

The controls are aligned to their right edges.

9. You are going to align the other controls.

In the Grade Header section, select the calculated
Text Box control and the Line object. (It may take
several tries to select the line.)

Note: No tice that the cal cu lated text box con trol
con cat e nates a Num ber data type (Grade) with text.

10. On the Format menu, point to Align and then
choose Left.

The controls are aligned at their left edges.

Note: Keep in mind that you are only align ing the
edges of the con trols. You are not, for ex am ple,
spec i fy ing where the text within the Text Box
con trol will align. 

Tip: There is an Align com mand on the Short cut
menu.
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11. Select the four controls in the StudentID Header
section and align them at their bottom edges.

12. Similarly, select the three controls in the Detail
section and align them at their bottom edges.

13. Finally, align the two controls in the StudentID
Footer section at their bottom edges.

Note: You may ignore the error checking icon for
now.

Access can adjust the spacing between controls in a variety of
ways.

1. In the StudentID Header section, select the Course,
Semester, and Credits bound controls.

2. On the Format menu, point to Horizontal Spacing.

Notice the items on the submenu.

You can equalize, increase, or
reduce the horizontal spacing
between the selected objects.
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3. On the submenu, choose Make Equal.

Notice that the selected controls are repositioned so
that the horizontal spacing between them is equal.

4. With the three controls still selected, choose the
Size/To Fit option on the Format menu.

5. In the Detail section, select the three bound
controls.

6. On the Format menu, point to Horizontal Spacing
and then choose Make Equal.

Access repositions the controls so that an equal
amount of space is between them.

Note: The Ver ti cal Spac ing op tion ad justs the ver ti cal
spac ing be tween se lected con trols. This op tion is
avail able only if the se lected con trols are all in the
same section.

7. You are going to look at the adjustments that you have
made to the report design.

Save the changes to the report design.

8. On the View menu, choose Print Preview.

9. If necessary, maximize the report window and click 
on the report to magnify it to full size.

Notice the report in Print Preview view. Notice that
the report is easier to read than before.
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10. Use the Page Control buttons to view different
pages of the report.

11. You are going to make some more changes to the
report design.

On the View menu, choose Design View and resize
the window, if necessary.

Formatting
Controls

You can format the controls on a report using the same techniques
that you used when formatting controls on a form. You are going
to format some of the controls on the report so that it is even easier
to read.

1. First, you are going to format the calculation control
that displays the date and time.

In the Report Header section, select the calculation
control.

2. If necessary, choose Properties on the View menu or 
use ALT/ENTER to display the Properties window.

3. Select the Format tab.

4. Since there is no Format option specified, Access uses
the General Date format, which consists of a Short
Date and a Long Time format. You are going to change
this so that a Long Date and Long Time format is used.

Since the Format drop-down list box does not contain a 
long date/long time format, you must enter it manually.

In the Format option, type: dddddd ttttt

5. You are going to use the Formatting toolbar to adjust
some other options.

With the date calculation control still
selected, click the Bold button.

6. In the Page Header section, select the calculated
control.
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7. On the Formatting toolbar, click the Italic
button.

The page numbers will appear in italic text at the top 
of each page.

8. You are going to format the line that appears in the
Grade Header section.

In the Grade Header section, select the line control.

9. On the Formatting toolbar, click the down 
arrow that appears next to the
Line/Border Width button.

10. Choose a 3-pt. Border Width.

Notice the thicker line.

Note: The thick ness changes only if the Spe cial Ef fect
property is Flat. Oth er wise, chang ing the thick ness
will have no vis i ble ef fect.

11. You are going to place a two-point thick box around the 
total credits for each student.

In the StudentID Footer section, select the control
that displays the total number of credits.

12. On the Formatting toolbar, click the down
arrow of the Line/Border Width button.

13. Choose the 2-pt. Border Width option.

Notice the border around the control.

14. Finally, you are going to change the number format of
the Credits bound control.
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In the Detail section, select the Credits bound
control.

15. The Properties window should be open.

If necessary, select the Format tab.

16. Change the Format option to Fixed.

17. Save changes to the report design.

18. A quick way to view changes to a report layout is to use 
Layout Preview view.

On the View menu, choose Layout Preview.

Notice the changes to the layout. 

Access does not bother including all of the data in
the report — it simply includes a sample for each
report section.

19. On the Print Preview toolbar, click Close.

You are returned to Design View.
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Report
Properties

You have already used the Properties window to modify format
and data properties for selected controls on forms or reports. You
can also use the Properties window to modify certain settings for
an entire report. You are going to look at some of these report
properties. As you do, keep in mind that similar options are
available when working with forms.

1. The CreditsEarned report should be open in Design
View.

2. To view the properties for a report, you must select the
report.

On the Edit menu, choose Select Report.

Although it may not appear to be so, the entire
report object is selected.

Tip: You can also se lect the en tire re port by choos ing 
Re port from the Ob ject drop-down
list box on the For mat ting toolbar.

3. If necessary, display the Properties
window and select the Format tab.

Notice the Format properties for the report.

4. You are going to look at some of the more common
Format properties.
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Click an insertion point in the Page Header
property and then tap F4 to display the options.

Normally, the Page Header
prints at the top of every page
in the report. This is the All
Pages option. By selecting the
Not with Rpt Hdr, Not with Rpt Ftr, or Not with Rpt
Hdr/Ftr options, you can choose to omit the Page
Header section when the Report Header, the Report
Footer, or both the Report Header and Footer
sections appear.

5. Tap the ESC key to close the drop-down list box
without making changes.

Note: The Page Footer op tion pro vides the same
properties as the Page Header sec tion.

6. The Grid properties control the placement and the
alignment of objects on the report. The default setting
is 24 grid divisions per inch.

Change the Grid X property to: 12

You have specified that there should be 12
subdivisions per inch (the default unit of
measurement).

7. Tap the TAB key to move to the Grid Y property.

On the report window, notice that the grid points
are spaced out more horizontally than vertically.
When the Snap to Grid option is selected on the
Format menu, the objects on the form will align with 
these dots.

Tip: If you can not see the grid points, ver ify that
Grid is se lected on the View menu.

8. Change the Grid Y property to 12 and tap the TAB
key to make the change.
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Notice the grid points on the report design.

Note: You can use the six dif fer ent Pic ture properties 
to choose and for mat a pic ture that will ap pear as a
back ground im age in the re port.

Section
Properties

In addition to the property settings for the entire report, each
section in a report or form has its own set of properties. You are
going to look at a few of the available properties.

1. With the Properties window still open, click on the
Report Header section band to select it.

Notice the Format properties.

Force New Page. You can use this option to make
Access start a new page before the selected section
prints, after it prints, or both before and after the
section.

New Row Or Col. When working with a
multiple-column report, this option specifies where
Access should begin printing a new row or column
— before, after, or both before and after the section.

Keep Together. When set to Yes, Access will make
sure that the entire contents of the section are
printed on the same page. This option is especially
useful when working with the Detail section, for it
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will ensure that all of the information about a record 
will appear on one page.

You have worked with the remaining options
throughout this course. Notice that you can adjust
the Back Color and the Special Effect used for the
section.

2. On the Form Design window, click the Page Header 
section band.

Notice that only four Format options are available
for a Page Header section.

3. On the Form design window, click the Grade
Header section band.

Notice the available Format properties.

Since the Grade Header section is a grouping
section, Access provides a Repeat Section. Normally,
the contents of the Grade Header section will appear 
only at the beginning of each new value for the
Grade field. When the Repeat Section property is set to 
Yes, however, Access will print the appropriate
Grade Header at the top of each page — even if the
Grade field has not changed in value.
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4. Close the Report Design window. It is not
necessary to save changes.

AutoFormat If you do not like the format of a report, you can change it rather
quickly using the AutoFormat command. You are going to create a
new report using the Report wizard and then change its format
using the AutoFormat feature.

1. The Reports tab of the Database window should be 
active.

2. Double-click the Courses report object.

Notice the report in Print Preview view.

This report was created using the Report wizard,
which you used in the Beginning Course. The
records are grouped by the Department field.

3. When the report was created, it was formatted using
the predefined Corporate style. You are going to
change this.

On the View menu, choose Design View.

Notice the report design.

4. On the Format menu, choose AutoFormat.
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The AutoFormat dialog box appears.

On the left, Access displays the six predefined
formats " along with any user-defined formats.

5. At the left of the dialog box, choose Formal.

Notice the format of the Formal AutoFormat.

6. Before applying a new format, you are going to look at
the options available.

On the dialog box, click the Options button.

At the bottom of the dialog box, notice the Attributes
to Apply grouping.

For any selected format, you can choose to apply or
not apply the Font, Color, and Border settings.

7. Click the Customize button.

The Customize AutoFormat dialog box appears.

The first option allows you to create a new
AutoFormat based on the current report format.
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This is convenient if you have spent a good amount
of time formatting a report and would like to save
those settings so that other reports can be formatted
in this manner. The AutoFormat that you create will
then become available when you use the AutoFormat
command or when you use the Report Wizard.

The second option allows you to update the selected 
AutoFormat with information in the current report
design.

The third option will allow you delete the selected
AutoFormat.

8. Click Cancel to close the dialog box without making 
changes.

9. You are going to apply the Formal AutoFormat to the
report.

Click OK.

Access applies the Formal AutoFormat to the report.
No controls are added or repositioned on the report
design — the AutoFormat command only alters the
Font, Color, or Border properties of the report.

10. On the View menu, choose Print Preview.

Notice the changes in the report.

11. Close the report design without saving changes.
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Note: There is an AutoFormat com mand avail able for 
form ob jects as well. There are ten pre de fined
AutoFormat set tings for forms.

Review
Exercise

In order to review the concepts presented in this lesson, you are
going to improve the appearance of an existing report using the
alignment and formatting options. The report on which you will
work is based on the StudentAverages query object.

1. Open the GPAReport report in Print Preview view.

Notice the current format of the report. 

2. You are going to modify this report so that it looks like
the one at the end of the exercise.

Switch to Design View.

3. In the Page Header section, add a calculated Text
Box control to display the current date in a long
date format. Right-align the control’s text.

4. Use the Line button on the Toolbox toolbar to draw 
a line in the Grade Header section. Format the line
as a 2-point flat line.

Tip: Hold ing down the SHIFT key as you cre ate the
line will cause it to come out per fectly hor i zon tal or
ver ti cal.

5. Align the Student Grade Point Averages label and the 
two controls in the Grade Header section to their
left edges.

6. Align the three controls in the Detail section at
their bottom edge.

7. For the same controls, make the horizontal spacing 
between them equal.

8. Align the calculated control in the Grade Footer
section with the right edge of the AvgOfCourseGrade
control in the Detail section.

9. Align the controls in the Grade Footer section to
their bottom edge.

10. Format the AvgOfCourseGrade control (in the Detail
section) and the calculated average control (in the
Grade Footer section) so that numbers appear in the 
Fixed number format.
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11. In the Grade Header section, format the calculated
control with bold, italic text.

12. In the Grade Footer section, format both controls
with bold text.

13. In the Grade Footer section, format the average
calculated control with a 2-point box around it.

14. Save changes to the report design.

15. Switch to Print Preview view and verify that your
report resembles the following:

End of Lesson 10
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