


Filter By
Selection

A filter is used to isolate records that fit specified conditions. For
example, if you are working with personnel records, you can use a
filter to display the records of everyone in a particular department.
Filters can be used with datasheets or forms. Access has different
types of filters. The first one you will use is the Filter By Selection.

1. Open the Filter database.

2. Open the StudentInfo table in Datasheet view.

3. You are going to display the records of students who
live in Brooklyn. To do this with the Filter By Selection
command, you must locate a record with this condition.

Tap the TAB key four times to make the City field of 
the first record active.

4. On the Records menu, point to Filter.

Notice the submenu
containing the different
types of filters.

5. On the submenu, choose
Filter By Selection.

Notice the records displayed in the datasheet.

Since the active field contained Brooklyn, only the
records of students living in Brooklyn are displayed. 
To the right of the Record Control buttons, notice
the message indicating that the records displayed
are filtered. Finally, at the right of the Status bar,
notice FLTR, indicating that a filter is active.

Note: Re mem ber, the last row of a datasheet (where
the as ter isk is lo cated) is re served for en ter ing new
re cords. It is not an ac tual re cord in the ta ble.
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6. The other records in the table are temporarily hidden.
To redisplay them, you must remove the filter.

On the Records menu, choose Remove Filter/Sort.

The filter is removed and all records are displayed
again.

Access stores the most recent filter.

1. On the Records menu, choose Apply Filter/Sort.

Access remembers the most recent filter and applies
it to the datasheet. Only the records of students
living in Brooklyn are displayed.

2. On the Records menu, choose Remove Filter/Sort.

All of the records are displayed again.

You can also filter by only part of a field. You are going to filter the
records of students who live on avenues.

1. In the Address field of record 2,
highlight Ave (at the 
beginning of Avenue).

The filter will look to match only what is
highlighted — not the entire contents of the field.

2. There are filter buttons on the Table Datasheet toolbar.

On the Table Datasheet toolbar, click the
Filter By Selection button.

Notice the filtered records. The all have ave
somewhere in the address field. On the toolbar,
notice that the Remove Filter button is highlighted,
indicating that a filter is being used on the
datasheet.

3. You can use the toolbar to remove the filter.

On the Table Datasheet toolbar, click the Remove
Filter button.

All records are displayed. Notice that the Remove
Filter button is no longer highlighted.

Tip: The Re move Fil ter but ton is a tog gle. When it is
high lighted, it is called the Re move Fil ter but ton.
Oth er wise, it is called the Ap ply Fil ter but ton.
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Successive
Filters

You can apply successive filters to a datasheet — that is, you can
filter records that are the result of a filter. This allows you to isolate
information in a table with more precision. You are going to use
successive filters in order to display the records of students in the
11th grade who live in the Bronx.

1. Locate the record of a student in the 11th grade
and then click an insertion point in its Grade field.

2. On the Table Datasheet toolbar, click the Filter By
Selection button.

Notice the records of 11th grade students. They are
in no particular order.

3. You have completed one filter. You must now specify
the selection for the second filter.

In the filtered datasheet, locate the record of any
student living in the Bronx and then click an
insertion point in its City field.

4. On the Table Datasheet toolbar, click the Filter By
Selection button.

Notice the records that are displayed. These are the
only 11th graders who live in the Bronx.

5. On the Table Datasheet toolbar, click the Remove
Filter button.

Note: The Fil ter Excluding Selection fea ture (avail able 
by click ing the Re cords menu and point ing to Fil ter)
dis plays all re cords ex cept those match ing the
se lec tion.

Filter By
Form

The Filter By Form feature allows you to filter records by choosing
the filter criteria from drop-down list boxes in a window that
duplicates the active datasheet or form. Unlike the Filter By
Selection feature, you can enter more than one criteria at the same
time — you do not have to apply successive filters.

You are going to use the Filter By Form feature to filter some of the
records in the StudentInfo table.
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1. The StudentInfo table should be open.

2. On the Records menu, point to Filter and then
choose Filter By Form.

The StudentInfo: Datasheet window becomes the
StudentInfo: Filter by Form window.

As mentioned, this window is a copy of the current
datasheet (or form). Notice, however, there is only
one row. This is where you enter the filter criteria.
Notice that the most recent criteria (11th graders
living in the Bronx) is listed in the window.

There are several elements of the Filter by Form
window that are different. Notice the Filter/Sort
toolbar. It has many of the same buttons as other
toolbars. Also notice that the Menu bar has changed.

At the bottom of the window, notice the two tabs.
The Look for tab is white, indicating that it is the
active tab. The Or tab is not being used.

3. Before entering the new filter, you are going to clear
the old one.

On the Edit menu, choose Clear grid.

The contents of the window are cleared.

Tip: You can also clear the fil ter by click ing
the Clear Grid but ton 
on the Fil ter/Sort toolbar.

4. The active field in the Filter by Form window has a
drop-down list button. This helps you define your filter
criteria. You are going to filter the records of students
from New York City who entered the school on 9/7/01.

Click the City drop-down list box.

Notice the values in the drop-down
list box. Access displays every unique value found
in the City field of the entire table. For this table,
there are only four different values in the City field.
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5. In the list box, choose New York.

Notice “New York” in the filter grid. Filter values
that are text must appear between quotation marks.
Access does this for you automatically.

Tip: To make it eas ier to see the fil ter val ues, ad just
the width of the col umns on the fil ter grid.

6. If you were to apply the filter at this point, only
students from New York (City) would be displayed. You 
are going to add a second criterion.

Click an insertion point in the DOE field and then
click the DOE drop-down list box.

Notice the values in the list box. These are the dates
on which students entered the school.

7. In the list box, choose 9/7/2001.

Notice the contents of the DOE field. Access
displays the date between pound signs (#) so that
the slashes (/) are not confused with the division
symbol (which is also a slash).

Notice the criteria on the filter form. Since the
criteria appear on the same tab sheet called Look for
(notice its name on the Status bar), Access will filter
records that match both of the criteria. 

8. On the Filter menu, choose Apply Filter/Sort.

Notice the records of students from New York City
who entered the school on 9/7/01. Access filtered the
records of students that satisfied both conditions.

When multiple criteria appear on the same tab sheet, 
Access combines them with the AND operator. This
means that only records matching all conditions will 
be filtered.

Note: In stead of the Fil ter menu com mand, you can
click the Ap ply Fil ter but ton on the toolbar.
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You are going to filter records of 11th graders in homeroom 250.
Since both of these conditions should be met, you will enter the
criteria on the same tab sheet. This is another example of the AND
operator.

1. On the Table Datasheet toolbar, click the
Filter By Form button.

The Filter by Form window appears with the 
previous filter criteria.

2. On the Filter/Sort toolbar, click the Clear
Grid button to remove the criteria.

3. In the filter grid, use the drop-down list box to
select a Grade of 11

4. In the filter grid, use the drop-down list box to
select a HomeRoom of 250

Note: You can have as many con di tions on a grid as
there are fields.

5. On the Filter menu, choose Apply Filter/Sort.

Notice the results of the filter. Since there are no 11th 
grade students in homeroom 250, no records are
displayed. (The zeros that appear in the StudentID
and Grade fields are default values; they are not part
of a record.)

6. On the Table Datasheet toolbar, click the
Remove Filter button.

The filter is removed. All records are displayed.

Using the OR
Operator

As you have seen, when two criteria are entered on the same tab
sheet on the Filter By Form window, Access filters records that
match both criteria. This is equivalent to using the AND operator.
You might also need to filter records that simply match at least one
of the criteria. You can do this with the OR operator.

When you tried to filter records of 11th graders in homeroom 250,
Access was unable to locate any records because no record in the
table matches both criteria. This time, you will filter records of
students who are in 11th grade or are in homeroom 250.

1. On the Records menu, point to Filter and then
choose Filter By Form.
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Notice the previous filter criteria in the filter grid.

2. On the Edit menu, choose Clear Grid.

3. In the filter grid, use the drop-down list box to
select a Grade of 11.

4. At the bottom of the Filter by Form window, click
the Or tab.

Notice the new filter grid. The Or tab is active and
the Look for tab is hidden. Notice that Access
prepares a third tab.

5. In the filter grid, use the drop-down list box to
select a HomeRoom of 250.

You have entered two conditions for your filter.
Since the conditions are on separate filter grids,
Access will filter records that match at least one of
the conditions.

6. On the Filter menu, choose Apply Filter/Sort.

Notice the results of the filter. Access found 17
records of students who are in the 11th grade or who 
are in homeroom 250. Using the OR operator
expands the criteria. By contrast, the AND operator
narrows the criteria.

7. Click the Remove Filter button.

You are going to filter records of students who are from Brooklyn
or from the Bronx.

1. On the Table Datasheet toolbar, click the
Filter by Form button.

2. On the Filter/Sort toolbar, click the Clear
Grid button.

Access clears every filter grid.

3. In the Look for filter grid, use the drop-down list
box to select a City of Brooklyn.

4. Since you want to filter records that match at least one
of the criteria, you must use the OR condition.

120 Microsoft Access 2003 - Beginning



Click the Or tab to display a second filter grid.

5. In the Or filter grid, use the drop-down list box to
select a City of Bronx.

6. Click the Apply Filter button.

Records of students from Brooklyn or from the
Bronx are filtered.

7. Remove the filter.

Note: The abil ity to use the OR op er a tor is an
im por tant ad van tage that the Fil ter By Form fea ture
has over the Fil ter By Se lec tion fea ture.

Combining
AND with OR
Operators

When criteria are on the same filter grid, they are linked with the
AND operator (all conditions must be met). When criteria are on
different filter grids, they are linked by the OR operator (only
conditions on one grid must be met). You can combine these
operators to produce more complex filters.

You are going to filter the records of students that meet at least one 
of the following criteria:

! Student is in 10th grade AND is from the Bronx

! Student is in 12th grade AND is from Brooklyn

! Student entered school on 2/1/95

1. On the Table Datasheet toolbar, click the Filter By
Form button.

2. On the Edit menu, choose Clear Grid.

3. Since only one of the three criteria needs to be met,
they should each go on a separate filter grid. Two of the 
grids, however, will have more than one criterion.

In the Look for filter grid, use the drop-down list
box to choose a Grade of 10.

4. In the same filter grid, use the drop-down list box
to choose a City of Bronx.

These are the criteria for the first condition. Since
they appear on the same grid, both conditions must
be met.

5. Click the Or tab to display a second filter grid.
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6. In the Or filter grid, use the drop-down list box to
choose a Grade of 12.

7. In the same filter grid, use the drop-down list box
to choose a City of Brooklyn.

These are the criteria for the second condition.

8. Click the second Or tab.

Notice the new filter grid.

9. In the second Or filter grid, use the drop-down list
box to choose a DOE of 2/1/03.

This is the only criterion for the third condition. You
are ready to apply the filter.

10. Click the Apply Filter button.

Notice the results of the filter.

Scroll the list and notice that there are records that
meet each of the conditions.

11. Remove the filter.

Advanced
Filter/Sort

The Advanced Filter/Sort feature provides even more control over
the filter process. You can use this feature to filter records based on
a wide range of criteria and then sort the results of the filter. As
with the other filter commands, you can use the Advanced
Filter/Sort feature on datasheets or forms. You are going to filter
records from the StudentInfo table.

1. On the Records menu, point to Filter and then
choose Advanced Filter/Sort.
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The StudentInfoFilter1 : Filter window appears.

Notice that the window is divided into two panes.
The top pane contains a Field List box with all of the 
fields in the StudentInfo table. To remind you of the
unique field for the table, Access formats the
primary key field with bold text.

The bottom pane contains a grid used to specify the
criteria and the sort order for the filter. Currently,
the grid contains information relating to the
previous filter.

Tip: You can ad just the rel a tive size of the
panes by drag ging the hor i zon tal bar
lo cated at the top of the bot tom pane. You
can also show more rows below the grid by
dragging the dialog box's bottom border.

2. You can clear the filter grid using the Shortcut
menu.

Point to an empty part of the top pane and
right-click.

Notice the shortcut menu.

3. On the Shortcut menu,
choose Clear Grid.

The grid is empty.

4. You are going to filter the records of students in the 9th 
grade who live in New York City. To set filter criteria,
you simply place the appropriate fields from the top
pane to the grid. There are several ways of doing this.
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In the Field List box (in the top pane), double-click
the City field (scroll the list, if necessary).

Notice that City is placed in the Field box of the first
column.

5. To specify the criterion for the selected field, simply
type it into the Criteria box of the appropriate column.

In the first column of the Filter grid, click an
insertion point in the Criteria box and type: New
York

6. You are going to enter the second criterion differently.

Click an insertion point in the Field box of the
second column.

A drop-down list button appears, allowing you to
select the field from a list box.

Before continuing, notice that quotation marks have
been placed around the New York criterion (in the
first column). Access does this automatically with
Text data types.

7. In the Field box of the second column, click the
drop-down list button and choose Grade.

Tip: Al ter nately, you can be gin typ ing the field
name.

8. In the Criteria box of the second column, type: 9

9. On the Filter menu, choose Apply Filter/Sort.

The datasheet appears with the filtered records.
Notice that all of the records are for 9th graders from 
New York (City). Notice, however, that the records
are in no particular order.
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You are going to sort the records by last name. Although you could 
do this by choosing Sort on the Records menu, you are going to do
it as you filter the records.

1. Although you might not be able to see it, the Filter
window is still open.

On the Window menu, choose StudentInfoFilter1 :
Filter.

The Filter window appears with the stored criteria.

2. To sort the records by last name, you must add the
LastName field to the filter grid.

In the Field List box, double-click the LastName
field.

Access inserts the field in the third column of the
filter grid.

Tip: To place a field in the fil ter grid, you can also
drag it from the Field List box to the grid.

3. You are not going to set any criteria for the LastName
field — you are simply going to specify a sort order.

In the third column, click an insertion point in the
Sort text box and then click the down arrow button.

Notice the options on the
list. You can sort in
Ascending or Descending
order. The (not sorted)
option simply clears the
Sort box.

4. Choose Ascending.

The records will be sorted in ascending order by the
last name.

5. On the Filter menu, choose Apply Filter/Sort.

Notice the same records as before. This time,
however, the records are sorted by last name.

Lesson 8 - Filtering Records 125



Multi-Level
Sorts

In the previous lesson, you learned to sort the contents of a table
according to a single field. The filter grid can be used to perform
multi-level sorts — that is, sorts based on more than one field. For
example, a common multi-level sort is one that sorts by last name
and then first name.

You are going to use the Advanced Filter/Sort feature to sort the
contents of the StudentInfo table in alphabetical order by grade.

1. On the Records menu, point to Filter and then
choose Advanced Filter/Sort.

2. Use any technique to clear the filter grid.

3. If more than one field has a sort order specified in the
filter grid, Access will sort the fields from left to right. To 
sort by grade first, then, that field should be at the very
left of the grid.

Click an insertion point in the Field box of the first
column.

4. Click the Field drop-down list box and choose
Grade.

5. In the Sort box of the first column, choose
Ascending.

You have entered the first sort level. Since you are
only sorting the records, not filtering them, you will
not enter any filter criteria.

6. Click an insertion point in the Field box of the
second column.

7. Click the Field drop-down list box and choose
LastName.

8. In the Sort box of the second column, choose
Ascending.

You have entered the second level sort criteria.

9. Click an insertion point in the Field box of the third
column.

10. Click the Field drop-down list box and choose
FirstName.

11. In the Sort box of the third column, choose
Ascending.
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You have entered the third level sort criteria. Your
filter grid should look like the following.

12. On the Filter/Sort toolbar, click the Apply Filter
button.

Notice the results of the filter. No records were
actually filtered — rather, they were sorted by
grade, last name, and then first name.

Using the OR
Operator

You are going to filter the records of students in the 9th grade,
students in the 10th grade, or students in homeroom 363. To do
this, you will need to combine these filter criteria with the OR
operator. In addition, you are going to sort the records within
grade by StudentID.

1. On the Records menu, point to Filter and then
choose Advanced Filter/Sort.

2. Use any technique to clear the filter grid.

3. In the Field List box, double-click Grade. (If
necessary, scroll the list box.)

4. In the first column of the filter grid, choose
Ascending for the Sort order.

5. In the Criteria text box, type: 9

6. To create OR conditions, enter the criteria on different
rows of the filter grid. Since the Grade field already
appears on the grid, you can use that same column.

Tap the DOWN ARROW key to move to the or box
just below the Criteria box.

7. Type: 10

Since the two Grade criteria are on different rows,
Access will combine them with the OR operator.

Note: Ac cess al lows up to nine dif fer ent cri te ria for
a field.

8. You are going to enter the HomeRoom criterion.
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In the Field List box, double-click HomeRoom.

9. You are not going to sort the records by homeroom.
When you specify the HomeRoom criterion, however,
you must enter it on a different row than either grade
criterion. Criteria that appear on the same row are
combined with the AND operator.

In the third Criteria row of the second column (the
fifth row of the grid), type: 363

Tip: To see more of the lower pane, resize or
max i mize the Ad vanced Fil ter/Sort win dow. 

10. You have already told Access to sort by Grade. Within
each grade, you can specify a sort order. You are going
to specify StudentID as the second sort level.

In the Field box of the third column, enter the
StudentID field.

11. Click an insertion point in the Sort row and specify
a Sort order of Ascending.

Your filter grid should look like the following:

12. On the Filter menu, choose Apply Filter/Sort.

Notice the results of the filter and the sort. Since you 
used the OR operator between each condition, the
criteria were expanded. (Had you used the AND
condition, no records would have been found
because no student is in both the 9th and 10th
grades.)

Creating
Complex
Filters and
Sorts

The Advanced Filter/Sort feature can make it easier to create
complex filters and sorts, because all of the criteria is displayed on
one grid. You have already used the OR and the AND conditions
with the Filter By Form feature. You are going to see how they are
used with the Advanced Filter/Sort feature.

You are going to filter the records of students who meet at least one 
of the following criteria:
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! Student is in 9th grade AND is from New York

! Student is in the 10th grade AND entered the
school on 2/1/96

! Student is from the Bronx

In addition, the records should be sorted (in ascending order) by
the StudentID field.

1. On the Records menu, point to Filter and then
choose Advanced Filter/Sort.

2. Clear the filter grid.

3. As mentioned, AND conditions must be entered on the
same row. OR conditions must be on different rows.
You are going to enter the first condition, which is
actually two criteria combined with AND.

In the Field text box of the first column, enter the
Grade field.

4. In the Criteria text box of the first column, type: 9

5. In the Field box of the second column, enter the City
field.

6. In the Criteria text box of the second column, type:
New York.

You have entered the first condition. Since the
criteria appear on the same row, Access will look for 
records that satisfy both criteria.

7. The criteria for the second condition will appear in the
first or row of the grid.

In the or row of the first column, enter: 10

Note: Al ter nately, you could have en tered this
con di tion in a new col umn headed by a sec ond
Grade field.

8. You must add the DOE field to the filter grid.

In the Field text box of the third column, enter: DOE

9. In the or row of the third column, type: 2/1/96

You have entered the second condition.

10. The next condition should go in a new row — the
second or row of the grid. Since this condition is for a
city, you can put it in the second column.
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In the second or row of the second column, type:
Bronx

11. Finally, you should sort the filtered records only by the
StudentID field. This will need to go in a new column.

In the fourth column of the filter grid, enter
StudentID.

12. Enter a Sort order of Ascending.

Your filter grid should look like the following. Once
again, criteria on the same row are joined by the
AND operator. Criteria on different rows are joined
by the OR operator.

13. Apply the filter.

Notice the filtered records (sorted by StudentID).
Each record in the filtered datasheet verifies at least
one of the conditions.

Saving a
Filter

As you have seen, filters can be saved with the datasheet or form.
Unfortunately, only one filter can be saved at a time. Once you save 
a new filter with a datasheet or form, the previous one is cleared.
Access allows you, however, to save a filter as a query object. A
query is designed to answer questions about the information in
your table, which is what filters can do as well. The advantage of
queries, however, is that they are more permanent.

You are going to save the most recent filter as a query. This must be 
done from the filter window.

1. On the Records menu, point to Filter and choose
Advanced Filter/Sort.

Notice the filter that you just created.

2. On the File menu, choose Save As Query.

The Save As Query dialog box appears.

3. Name the query MyAdvancedFilter and click OK.

Access saves the filter as a query.
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Note: The Load From Query op tion on the File menu
al lows you to copy the cri te ria of an ex ist ing query
into the fil ter grid.

4. You are going to take a look at the query you just
saved.

On the Filter/Sort toolbar, click the Database 
Window button.

The Database window appears.

5. Click the Queries tab.

Notice the query that you just saved. You will learn
more about queries in the next lesson.

6. Use the Window menu to switch back to the
StudentInfoFilter1 filter.

7. Close the filter.

8. Close the StudentInfo datasheet. Do not save
changes to the table design.

Review
Exercise

To review the concepts presented in this lesson, you are going to
apply different filters to the StudentInfo table in Datasheet view.

1. Open the StudentInfo table of the Filter database. Be 
sure to click the Tables tab.

2. Use the Filter By Selection feature to filter the
records of students who have Zip codes beginning
with: 100

3. Use the Filter By Form feature to filter the records of 
students in HomeRoom 360 from Brooklyn.

4. Use the Advanced Filter/Sort feature to sort all of the 
students in alphabetical order — first by the City
field and then by the LastName and FirstName
fields.

5. Use the Advanced Filter/Sort feature to filter the
records of students who meet at least one of the
following criteria (the records should be sorted by
last name and then first name):

! Student lives in Queens
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! Student is in the 12th grade and entered the
school on 2/1/94

! Student is in the 10th grade

6. The filtered records should be as follows:

End of Lesson 8
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