


Searching
for
Information

You have already learned how to navigate through a table. When
you need to locate a specific record, however, this can be a tedious
way of finding information (especially in a large table with many
records). You are going to look at easier ways of locating
information in your table.

1. Open the Search database file.

2. Open the StudentInfo table in Datasheet view.

This table is similar to the ones with which you have 
been working. Notice, however, that there are 50
records in the table. When there are many records in 
a table, it can be difficult to locate information.

3. You are going to look for a record that has Diaz in the
LastName field. The field in which you are searching
should be active.

Use CTRL/HOME to move to the beginning of the
datasheet.

Note: If you are in Edit mode (that is, if you can see
an in ser tion point blink ing in one of the datasheet
fields), CTRL/HOME will not take you to the first
re cord. In this case, tap F2 to get out of Edit mode
and then try again.

4. Tap the TAB key to move to the LastName column.

5. On the Edit menu, choose Find.

The Find and Replace dialog box appears.

Notice that the insertion point is blinking in the Find
What text box. This is where you specify the search
string to be located. Access suggests Young because
it was highlighted when you chose Find.
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6. In the Find What text box, type: Diaz

7. The Look In drop-down list box lets you choose
either the current field or the entire table.

In the Look In box, verify that LastName is selected.

8. The Match drop-down list box is used to specify where
the search string should be located in the selected field.

Click the Match drop-down list box.

Notice the three options:

Any Part of Field tells Access that the search string
can be located anywhere in the field (even as part of
another word).

Whole Field tells Access that the search string must
take up the entire field.

Start of Field tells Access that it should look for the
search string only at the beginning of the field.

The Search drop-down list box is used to specify
how Access should search for the information — by
looking Up through the table, by looking Down
through the table, or by looking through All the table.

9. Select Whole Field (the default).

You will use the other options later.

10. In the Search drop-down list box, verify that All is
selected.

11. Click the Find First button.

Access locates the first record with Diaz in the
LastName field. Notice that it is record 32. 

Tip: If nec es sary, move the Find and Re place di a log
box out of the way.

12. On the Find and Replace dialog box, click the Find
Next button.

Access finds the next occurrence of Diaz in the
LastName field (record 35).

13. Click the Find Next button.

Access locates a third occurrence of Diaz in the
LastName field (record 42).

14. Click the Find Next button.
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The following alert box appears, indicating that
there are no more instances of the search item.

15. Click OK to close the alert box.

Note: Ac cess must go through the en tire ta ble be fore 
dis play ing this alert box. If you do not start on the
first re cord, Ac cess will go to the first re cord, lo cate
each in stance until it reaches the starting point, and
then dis play the alert box.

16. Click Cancel to close the dialog box.

Note: With the Find and Re place di a log box closed,
use SHIFT/F4 to lo cate the next oc cur rence of the
search string. Ac cess will not dis play a di a log box
when you reach the end of the ta ble, how ever.

Find Options You are going to use some of the options on the dialog box as you
look for Brooklyn.

1. Use CTRL/HOME to go to the beginning of the
datasheet.

2. Tap the TAB key until the City field is active.

3. On the Edit menu, choose Find.

The Find and Replace dialog box appears. Notice
that City is indicated in the Look In box. Also notice
that the Find What text box contains Brooklyn.

Tip: You can also use CTRL/F to dis play the Find
and Re place di a log box.

4. The Match Case option allows you to specify if the
search string case should be matched. You are going to
see how this works.

Change the contents of the Find What text box to:
brooklyn

5. Verify that the Match Case option is not selected.

This means that Access will find any capitalization
variation of Brooklyn, such as brooklyn or BrooKLYN.
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6. Click the Find Next button.

Access stops at the first record. Notice Brooklyn
highlighted in the City field. Notice that the second
record also has Brooklyn in the City field.

Note: If the text does not appear highlighted, click
the Table window title bar to see the highlight.

7. You are going to change the Match Case option.

Click the Match Case check box to select the option.

Access will find only occurrences that exactly match
the capitalization of the search string.

8. Click the Find Next button.

Since every city name is capitalized, Access goes
through the table and does not locate any records
with City fields that match brooklyn.

9. Click OK to close the alert box.

10. Deselect the Match Case option so that
capitalization will not matter.

11. Click Cancel to close the Find and Replace dialog
box.

The Search Fields As Formatted option allows you to look for a
specific format of a field (such as a date format). You are going to
see how this works.

1. Use CTRL/HOME to go to the beginning of the
datasheet.

2. Click an insertion point in the DOE field of the
record.

In the DOE field, notice that the first three students
in the table have a date of entry of 9/7/2001 and that
there are others farther down.

3. Use CTRL/F to display the Find dialog box.

4. Verify that Search Fields As Formatted is not
selected. (If it is dimmed, deselect Match Case.
When Match Case is chosen, Search Fields As
Formatted is not available.)
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When Search Fields As Formatted is not selected,
Access will look to match only the value of the search 
string — not the format as well.

5. Change the contents of the Find What text box to: 7
sept 01

Although this date of entry has a different format
than 9/7/2001, it has the same value.

6. Click the Find Next button.

Notice that the DOE field of the second record is
highlighted. Although the dates have different
formats, they have the same value.

7. Click the Find Next button.

The DOE field of the second record is highlighted.
Once again, although the dates have different
formats, they have the same value.

8. Select the Search Fields As Formatted check box.

This time, Access will look to match both the value
and the format of the search string.

9. Click the Find Next button.

An alert box is displayed indicating that the search
string could not be found. Although the third record 
contains an equivalent date value, the date format
does not match. In fact, none of the date formats
match the format of the search string. 

10. Click OK to close the alert box.

On the Status bar, notice the
message indicating that the
search string was not found.

11. Deselect the Search Fields As Formatted option.

12. Click Cancel to close the Find and Replace dialog
box.

If you are trying to find some information but are not sure about
the field in which it is located, you can search through all fields.

1. Use CTRL/HOME to go to the beginning of the
datasheet.
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2. Since you are going to be searching through every field, 
it does not matter which field is active.

On the Edit menu, choose Find.

3. You are going to tell Access to look for the search string 
12 anywhere in table.

Change the contents of the Find What text box to: 12

4. Click the Look In drop-down list box and choose
StudentInfo: Table.

5. Click the Match drop-down list box and choose Any
Part of Field.

6. Click the Find First button.

Access finds the search string as part of the Zip code
of the first record. Since Any Part of Field was
selected, Access did not try to match the entire field.

7. This time, you are going to use the FIND NEXT keyboard 
combination to continue searching.

Close the Find dialog box.

8. Use SHIFT/F4.

Access finds the next occurrence of the search string
in the Grade field.

9. Use SHIFT/F4.

Access finds the next occurrence of the search string
in the Grade field of the next record.

10. Use SHIFT/F4 a number of times and notice the
different occurrences of the search string.

Notes You can use the Find button on the Table Datasheet 
toolbar to access the Find and Replace dialog box.

You can also use the wildcard characters * and ? in a search
string. The question mark (?) can replace any single character 
in a string and the asterisk (*) can replace an unspecified
number of characters in a string. For example, searching for
Bro* in the City field will find Brooklyn and Bronx. Searching
for 100? in the StudentID field will find records with the
following StudentID: 1001, 1002, 1003, ... 1009.
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Replacing
Information

The Replace command lets you replace a search string with another
string. You are going to replace occurrences of Ave with Avenue in
the Address field.

1. Use CTRL/HOME to go to the beginning of the
datasheet.

2. Tap the TAB key three times to make the Address
field active.

3. On the Edit menu, choose Replace.

The Find and Replace dialog box appears with the
Replace tab selected. Notice that it is similar to the
Find tab, with the addition of the Replace With text
box.

4. In the Find What text box, type: Ave

5. In the Replace With text box, type: Avenue

6. In the Look In box, verify that Address is displayed.

7. Since Ave will never take up the entire field, Whole
Field should not be selected in the Match drop-down
list box.

In the Match drop-down list box, verify that Any
Part of Field is selected.

8. The search string ave could appear in the middle of a
word such as Waverly St. To prevent Access from
replacing such instances, you are going to use the
Match Case option.

Select the Match Case option.

Since the capitalization must match, this will
prevent Access from replacing the ave in Waverly.
(However, it will not prevent Access from replacing
Ave in Avenue.)
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9. If you were to click the Replace All button, Access
would replace all occurrences. For now, you are going
to replace only some of the occurrences.

If necessary, move the Find and Replace dialog box 
so you can see as much of the Address column as
possible.

10. Click the Find Next button to start the replace.

Access stops at the first occurrence of Ave, which is
at the beginning of Avenue in the second record.

11. You are not going to replace this occurrence.

Click the Find Next button to locate the next
occurrence of Ave.

Access locates Ave in record 3.

12. Click the Replace button to replace Ave with
Avenue.

Ave is replaced and the next occurrence is found.

13. Click the Replace button.

Ave is replaced and the next occurrence is found.

14. Replace the next few instances of Ave.

Notice that you can always click the Replace All
button during the process.

Tip: If you click the Re place All but ton, Ac cess
dis plays an alert box ask ing you to ver ify that you
want to re place all oc cur rences. This can not be
un done, so be care ful when us ing the com mand.

15. Click Cancel to close the dialog box.

Sorting
Records

As you will learn, Access provides you with a number of ways in
which to sort the information in a table. In Datasheet view, one of
the quickest ways is to use the Sort command. You can sort in
ascending order (e.g., from A to Z or 1 to 100) or descending order
(e.g., from Z to A or 100 to 1).

You are going to sort (in ascending order) the information in the
StudentInfo table by LastName.

1. You must indicate the field by which to sort.
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Click an insertion point anywhere in the LastName
column.

2. On the Records menu, point to Sort.

Notice the two options on
the submenu.

3. On the submenu, choose Sort
Ascending.

Access sorts the records in ascending order
according to the LastName field.

4. Scroll through the datasheet and notice that the
records are sorted by LastName.

Some of the students have the same last name. In
these cases, notice that the records are not
necessarily sorted by the first name. This would be a 
multi-level sort. You will do this in the next lesson.

5. You are going to sort the records (in ascending order)
according to the contents of the City field.

Click an insertion point in the City column.

6. On the Records menu, point to Sort.

7. On the submenu, choose Sort Ascending.

The records are sorted by City.

8. You are going to sort the table (in descending order)
according to the contents of the DOE field.

Click an insertion point anywhere in the DOE
column.

9. On the Records menu, point to Sort and then
choose Sort Descending.
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The records are sorted according to the date of entry 
of the students. Since it was a descending sort,
students who entered most recently are listed first.

You can also use toolbar buttons to sort the records in a table. You
are going to sort the records in ascending order by HomeRoom.

1. Click an insertion point in any HomeRoom field.

2. On the Table Datasheet toolbar, click the
Sort Ascending button.

The records are sorted in ascending order according
to the contents of the HomeRoom field.

3. You are going to sort by LastName again — this time, in 
descending order.

Click an insertion point in the LastName column.

4. On the Table Datasheet toolbar, click the
Sort Descending button.

The records are sorted.

Saving a Sort
Order

If you always want the records in a table sorted a certain way, you
must save the sort with the table. Currently, the records are sorted
by LastName. You are going to save the datasheet like this.

1. On the File menu, choose Save.

2. Close the datasheet.

Note: If you had not first saved the lay out, Ac cess
would have dis played an alert box as you were
clos ing the datasheet ask ing you to save the change.

3. Open the StudentInfo table in Datasheet view again.

Notice that the records are still sorted (in
descending order) according to the LastName.

4. You are going to sort by the StudentID field and close
the datasheet without saving changes. This time, you
are going to use the Shortcut menu to do this.

Right-click any part of the StudentID field.
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Notice the (context-sensitive) Shortcut menu.

5. On the Shortcut menu, choose Sort Ascending.

The records are sorted by StudentID.

6. On the File menu, choose Close.

Since changing the sort order is a design change, an
alert box appears asking if you want to save changes 
to the table design.

7. On the alert box, click No.

8. Open the StudentInfo table in Datasheet view.

Since you did not save the most recent sort, the
records remain sorted by the LastName field.

Removing a
Sort Order

By default, Access stores records in a table in the order in which
they are entered. As you have seen, you can save a sort with a
datasheet. At times, however, you may need to restore the original
order of the records. You can do this with the Remove Filter/Sort
command.

1. Currently, the records are sorted by LastName. You are
going to remove this sort.

On the Records menu, choose Remove Filter/Sort.

The records are no longer sorted by LastName.
Although it appears that they are sorted by
StudentID, they are actually listed in the order in
which they were entered.
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2. On the File menu, choose Save.

The records will remain in this order when you close 
the datasheet.

Review
Exercise

To review the concepts presented in this lesson, you are going to
search for some records, replace the contents of fields, and sort the
records in Datasheet view.

1. The StudentInfo table of the Search database should 
be open.

2. Use the Find and Replace dialog box to locate the
student with a Zip of 11212.

3. Close the Find dialog box.

4. Change the Zip for this student to: 11213

5. The date of entry for the 2004-2005 school year was
incorrectly entered for all records. Instead of 9/7/2004
it should be 9/5/2004.

Use the Replace command to change all
occurrences of 9/7/2004 to 9/5/2004.

6. Two of the homerooms (250 and 251) are switching
classrooms. You can make this switch in three steps:

First, change the students currently in homeroom
250 to a “dummy” homeroom — use homeroom
999.

Second, change students currently in homeroom
251 to homeroom 250.

Finally, change students from the “dummy”
homeroom to homeroom 251.

7. Sort the records in ascending order according to
the contents of the HomeRoom field.
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The datasheet should look like the following:

8. Close the datasheet without saving the current sort 
order.

End of Lesson 7
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