


Navigation
Techniques

You have already used the TAB key to move from field to field
within a table in Datasheet view. Access provides a number of
other navigation techniques.

1. From now on, when we ask you to open a database
file, look for it in the FLS Access2003 Student Files
folder.

2. Open the Datasheet database.

3. Verify that the Tables tab is selected.

4. Select StudentInfo table and then click the 
Open button.

The table is opened in Datasheet view. By default,
the first field of the first record is selected.

Keyboard
Commands

Since most data is entered through the keyboard, it is convenient to 
use keyboard commands to move around tables. In the steps
below, it is assumed that your Access keyboard default options
have not been changed. If you find that your insertion point does
not move as described, choose the default options discussed in the
Keyboard Options section (on page 52) and then try again.

1. The ENTER key works much like the TAB key.

Tap the ENTER key a few times.

The insertion point moves from one field to the next. 
When it moves to a new field, the contents of the
field are highlighted. As you will see, this makes it
easier to edit the field.

2. The ARROW keys can also be used.

Tap the DOWN ARROW key a few times.

The insertion point moves down, from one record to 
the next. At the left of the datasheet, notice that the
Record Indicator moves to indicate the active record.

3. Tap the UP ARROW key a few times.

Notice that you move up to one of the earlier
records in the datasheet.

4. Tap the RIGHT ARROW key a few times.
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At this time, you are moved from field to field. As
you will see, however, the LEFT and RIGHT arrow
keys can be used to move character by character
when you are editing the contents of a field.

5. The HOME key moves you to the first field in a record.

Tap the HOME key.

The first field of the current record is active.

6. The END key moves you to the last field in a record.

7. Tap the END key to go to the last field of the
current record.

8. CTRL/HOME will move you to the first field of the first
record in the table.

Use CTRL/HOME and notice that the first field of
the first record is active.

9. Similarly, CTRL/END will move you to the last field of
the last record.

Use CTRL/END and notice that the last field of the
last record is active. 

Following is a summary of navigation techniques.

Key Command Where insertion point goes

TAB next field in record

ENTER next field in record

SHIFT/TAB previous field in record

UP ARROW (") same field in previous record

DOWN ARROW (#) same field in next record

RIGHT ARROW ($) next field in record

LEFT ARROW (%) previous field in record

CTRL/" same field in first record

CTRL/# same field in last record

HOME first field in the record

END last field in the record

CTRL/HOME first field of the first record

CTRL/END last field of the last record

PAGE UP up one screenful of records

Lesson 4 - Working in Datasheet View 51



PAGE DOWN
SHIFT/END

down one screenful of records
edit field contents

Keyboard
Options

You can change the behavior of the keyboard. You are going to
take a look at the options available.

1. On the Tools menu, choose Options.

The Options dialog box appears. Notice the different 
tabs on the dialog box. The Options dialog box is
used to control many aspects of Access.

2. Click the Keyboard tab.

Notice the options on the Keyboard tab.

Move after enter. These options tell Access what
should happen after the ENTER key is tapped. Don’t 
move leaves the insertion point in the current field;
Next field moves the insertion point to the next field
(this is the default); Next record moves the insertion
point to the first field of the next record.

Arrow key behavior. These options allow you to
control how the ARROW keys behave. Next field
causes the insertion point to move to the next field
(this is the default); Next character causes the
insertion point to move to the next character within
the current field.
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Behavior entering field. These options tell Access what 
should happen when you move into a new field.
Select entire field causes the contents of the field to be
highlighted (this is the default); Go to start of field
causes the insertion point to be placed at the
beginning of the field; Go to end of field causes the
insertion point to be placed at the end of the field.

Cursor stops at first/last field. If this option is selected,
Access will not allow the LEFT or RIGHT ARROW
keys to move the insertion point to the next (or
previous) record when you are at the last (or first)
field of a record.

3. Click Cancel to close the dialog box without making 
changes.

Record
Control
Buttons

At the bottom of the Datasheet window, Access provides a series of 
buttons to help you navigate through your records.

1. To help you locate the appropriate button, here are 
the names of each one.

2. Click the First Record button.

While staying in the same field, Access moves to the
first record. Since you are in the first record of the
table, the Previous Record button is dimmed.
Finally, to the right of the Record Control buttons,
notice that Access indicates the total number of
records in the table.

3. Click the Next Record button.

The same field in the next record is now active.

4. Click the Last Record button.

Access moves to the same field of the last record.
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5. No matter where you are in a table, clicking the Add
New Record button will prepare you to enter a new
record at the end of the table.

Click the Add New Record button.

Access moves the insertion point to the first field at
the end of the table. New records are always added
to the end of a table. To the right of the Record
Control buttons, notice that the number of records in 
the table has increased to 21.

6. If you move the insertion point without making
changes, the record will not be added.

Tap the UP ARROW key to move the insertion point 
out of the new record.

The number of records has returned to 20.

You can use the Record number text box to go directly to a specific
record.

1. Highlight the contents of the Record number box.

Tip: One way to quickly high light the con tents of a
text box is to dou ble-click some where in the text
box.

2. Type 5 and then tap the ENTER key.

The insertion point moves to the fifth record.

3. In the same manner, use the Record number box to
go to the tenth record.

Note: As you will learn, the Re cord Con trol but tons
are also avail able when you are work ing with forms.

The Edit
Menu

If you prefer using menu commands, the Edit menu contains some
of the more common navigation commands.

1. Click the Edit menu and point to Go To.

Notice the submenu 
that appears.

2. On the submenu, choose First.

Access moves the insertion
point to the first record.
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3. On the Edit menu, point to Go To.

4. On the submenu, choose Next.

The insertion point moves to the next record.

Note: You can also use the scroll bars to nav i gate
within a datasheet. The scroll bars do not change the 
ac tive re cord, how ever — they merely al low you to
see more of the datasheet.

Adding and
Deleting
Records

You can add and delete records while a table is in Datasheet view.
You should keep in mind that the same techniques that you use in
this lesson can be used when you are working with forms.

Adding
Records

As mentioned, new records are always added to the end of the
table. A quick way to do this is to click the Add New Record
button.

1. Click the Add New Record button.

Access moves to the first field at the end of the table.

2. Enter the following record:

StudentID: 1021
LastName: Nager 
FirstName: Heather 
Address: 300 East 10th Street
City: New York
State: NY
Zip: 10003
DOE: 2/1/02
Grade: 10
HomeRoom: 254

3. When you get to the last field, tap the TAB key.

Access saves the record you entered and prepares
for a new record.
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You are going to add a new record for Heather’s brother, Brian,
who has enrolled in the school as well. As you do this, you are
going to learn two keyboard shortcut commands.

1. In the StudentID field, type 1022 and then tap the
TAB key.

2. There is a shortcut that tells Access to copy the
information in the corresponding field of the previous
record and place it into the current record. You are
going to use this to enter Brian’s last name.

Use CTRL/’ (that is an apostrophe, which is on the
same key as the double quote mark). 

Notice that Nager is entered in the current field.
Access copied the value that is in the same field of
the previous record.

3. Tap the TAB key to move to the next field.

4. Type Brian and then tap the TAB key to move to the 
next field.

5. Use CTRL/’ to copy the Address from the previous
record.

6. In the same manner, use CTRL/’ to copy the City,
State, and Zip fields.

7. The DOE field should be active.

8. You are going to enter the current date as Brian’s date
of entry. There is a keyboard shortcut to do this.

Use CTRL/; (that is a semicolon).

Notice that the current date is entered in the field.

9. Tap the TAB key to move to the next field.

10. In the Grade field, type 9 and then tap the TAB key.

11. In the HomeRoom field, type 250 and then tap the
TAB key.

Access saves the record you entered and prepares
for a new record. The table now has 22 records.

Deleting
Records

You can delete a record from a table. To do this, the record to be
deleted must be selected. You are going to delete the record that
you just added.
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1. Make the Brian Nager record the active record by
clicking an insertion point somewhere in it.

2. On the Edit menu, choose Delete Record.

The record disappears from the Datasheet and the
following alert box appears.

3. On the alert box, click Yes.

The record is deleted.

Printing a
Datasheet

As you will learn, Access provides many different ways for you to
print the information in your database. The most common way is
as a report, which you will do in a later lesson. At times, however,
you may need to print a table as it appears in Datasheet view. You
are going to print the StudentInfo table as a datasheet.

Print Preview Before printing the datasheet, you are going to use the Print Preview
command to see what it will look like when printed.

1. On the File menu, choose Print Preview.

Notice the replica of an 8.5" x 11" page. At the top of
the page, Access puts the name of the table and the
current date. At the bottom of the page, Access puts
the page number.
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2. Position the pointer anywhere on the page.

The pointer turns into a Magnifier (with a
small plus sign inside of it), indicating that
clicking will cause the page to zoom to full
size with that section showing.

3. With the pointer somewhere on the page, click.

The page zooms to full size. Only a portion
of it can be seen on the screen. The Magnifier 
now has a small minus sign inside of it,
indicating that clicking will cause the page to 
zoom out.

4. With the pointer somewhere on the page, click.

The page returns to reduced size.

5. On the View menu, choose Datasheet View to return
to Datasheet view.

You will work more with Print Preview later.

You are going to learn to print the datasheet. Even if you are not
going to actually print, you can still follow these steps, however.

1. If you are going to print, check that the printer is
on and that it has paper.

2. On the File menu, choose Print.

The Print dialog box appears.

Following is a description of the various options:
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Printer. The options in this group provide you with
information about the current printer. If there are
other printers available, you can use the Name
drop-down list box to choose a different printer. The 
Properties button is used to modify the settings for
the current printer. If a printer is not available, you
can choose the Print to file option. This tells Access to 
store the printout in a file that can be printed later.

The Print Range group lets you print All the pages
(of a multi-page datasheet) or the range of pages
indicated in the From and To boxes. (For example,
From 3 To 5 would print pages 3, 4, and 5; From 7 To
7 would print only page 7; From 12 To 999 would
print page 12 to the end of the datasheet. The
Selected Record(s) option will print only the active
record (or the records that are highlighted).

Copies. This lets you print multiple copies. The
Collate box indicates how multiple copies of the
datasheet will be grouped.

Setup. Choosing this takes you to the Page Setup
dialog box, which you will use in a moment.

3. To print the datasheet, click OK. Otherwise, click
Cancel.

Note: If a datasheet is too wide to fit on the pa per,
Ac cess splits it ver ti cally and prints the other part on 
the next sheet of pa per.

Page Setup You can adjust certain settings before you print a datasheet.

1. On the File menu, choose Page Setup.

The Margins tab of the Page Setup dialog box
appears. (It is shown on the next page.)

There are only five options on this tab. Notice that
you can set the Top, Bottom, Left, and Right margins
independently of each other. In the Sample box,
notice the dashed line around the sample page. This
line approximates the relative margin settings.
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2. Set all four margins to: 0.5

3. If the Print Headings option is selected, Access will
print the field names for the table at the top of every
page, just as they appear normally in Datasheet view.

Verify that the Print Headings option is selected.

4. You are going to look at the options on the Page tab.

Click the Page tab.

Notice the three groups on the Page tab.

The Orientation group lets you choose Portrait or
Landscape orientation. For a datasheet with many
fields, it is often best to choose Landscape.
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The Paper group allows you to specify the Size and
Source of the paper. The options available depend
upon the printer that is selected.

The Printer for StudentInfo group allows you to
specify the printer for the datasheet. You can choose
the Default printer or you can choose the Use Specific
Printer to specify a printer for the datasheet only.

5. You are going to change the orientation of the page.

In the Orientation group, choose Landscape.

6. Click OK to close the dialog box.

7. You are going to preview the changes that you made.

On the File menu, choose Print Preview.

Notice the changes in the datasheet. The page now
appears in landscape orientation with smaller
margins, allowing more fields to fit on a page.

8. On the View menu, choose Datasheet View to return
to Datasheet view.
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Toolbars By default, Access places at least one toolbar just below the Menu
bar. Toolbars provide alternative ways to perform common
commands, such as switching to Design view, adding records to a
table, or opening a database. As you may have noticed, Access
changes the toolbar depending upon your current activity.

You are going to take a quick look at some of the toolbars available
and then use a few of the buttons on the Table Datasheet toolbar.

Displaying
Toolbars

You can display a toolbar using the Toolbars command on the View
menu.

1. On the View menu, point to Toolbars.

The Toolbars submenu
appears.

2. Choose Customize.

The Customize dialog box
appears.

3. Verify that the Toolbars tab is selected.

Notice on the Toolbars tab that Access has over
twenty different toolbars. A check mark next to a
toolbar indicates that the toolbar will be displayed.
You can also create your own toolbars and
customize any of the existing toolbars.

4. Scroll down and verify that the Table Datasheet
toolbar is selected.
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5. If you pause the mouse on a toolbar button for a
moment, Access can provide a ScreenTip indicating the
name of the button. You are going to check to see that
this feature is turned on.

Click the Options tab.

6. Toward the bottom of the dialog box, verify that
the Show ScreenTips on toolbars option is selected.

Note: If you prefer to use keyboard shortcuts, select
the Show shortcut keys in screentips option.

7. Click Close.

Notice the Table Datasheet toolbar (it has probably
been there all along.)

Note: If the toolbar ap pears as a pal ette some where
on the screen, you can move it to the top by
dou ble-click ing its Ti tle bar.

8. Near the left of the toolbar, point to the 
Save button.

Notice the ScreenTip that appears,
indicating the name of the button.

9. Click the Save button.

Any changes to the datasheet design are saved.

10. The Table Datasheet toolbar has a button for switching
to different views.

At the left of the toolbar, click the View button 
(do not click the down arrow on the
button).

Notice that the Design View window
appears. Also notice that the toolbar that is
displayed (the Table Design toolbar) is different
from the Table Datasheet toolbar. Access changes
toolbars automatically.
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Also notice that the View 
button changed.

The View button is a toggle that switches you
between Design and Datasheet views.

11. You are going to use the View button to switch 
back to Datasheet view in a different manner.

Click the down arrow of the View button.

A drop-down list appears
containing different views
for the active object. For a
table object, there are four
views. Other objects might
have more. (PivotTable and
PivotChart views are
covered in the Intermediate course.)

12. Choose Datasheet View.

You are returned to Datasheet view.

Common
Toolbar
Buttons

Before continuing, notice some of the other buttons on the Table
Datasheet toolbar for commands that you have already used.

Print button. Print current object. (If you use the
button, the Print dialog box does not appear.)

Print Preview button. Go into Print Preview 
mode.

New Record button. Add a new record at the 
end of the table.

Delete Record button. Delete the selected 
record.

Database Window button. Display the Database
window. (The active window is not closed.)

New Object button. Create a new Access object.

In this course, you will choose most commands from the menus.
We feel that this helps you become familiar with more of the
options available in Access. If you are prefer to use the toolbars,
however, feel free to substitute the appropriate toolbar button.

1. Close the table datasheet window.
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Review
Exercise

To review the concepts presented in this lesson, you are going to
add and delete some more records to the StudentInfo table.

1. If necessary, open the Datasheet database.

2. Open the StudentInfo table in Datasheet view.

3. Delete record 15 (the one for Shauna McCoy) and
then delete record 8 (the one for Marcus Pierno).

4. Add the following two records to the table. Use the 
shortcut keys (CTRL/’ and CTRL/;) when appropriate.

StudentID: 1064
LastName: Avvento 
FirstName: Richard
Address: 355 East 9th Street
City: Brooklyn
State: NY
Zip: 11250
DOE: 9/8/03
Grade: 11
HomeRoom: 363

StudentID: 1065
LastName: Avvento 
FirstName: Marie
Address: 355 East 9th Street
City: Brooklyn
State: NY
Zip: 11250
DOE: 9/8/03
Grade: 12
HomeRoom: 361

5. View the datasheet in Print Preview mode.

6. Set all margins to .75 inches and change to
landscape orientation. If possible, print the
datasheet.

End of Lesson 4
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