


Creating a
Database
File

As you will learn throughout this course, Access often provides
you with several ways of accomplishing the same task. For
example, Wizards are automated programs that can help you create
new database objects. Although you will use different techniques
throughout this course, we feel that you will understand Access
best if you accomplish most tasks at least once manually.

In the previous lesson, you used an existing database file. Now,
you are going to create a new database file, as well as a table in the
database.

Note: The da ta base you will cre ate will be sim i lar to the one you
used in Les son 1. In fact, this same ma te rial (con cern ing a high
school) is used through out this course. Rather than use the same
da ta base file for the en tire course, we have opted to use a new one,
with es sen tially the same data, for each les son. This way,
al ter ations made to a file in one les son will not af fect files opened
in sub se quent les sons. A file used in one les son is never used again.

1. Start Access. If necessary, refer to the instructions
at the beginning of Lesson 1.

Notice the bottom of the Getting Started task pane.
In the last lesson, you used the More option to open
a file.

2. At the bottom of the Getting Started task pane,
click Create a new file.

The New File task pane appears. 

3. Choose Blank Database.

The File New Database dialog box appears. This
dialog box is similar to the Open dialog box that you 
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used in the previous lesson. The top part concerns
where you are going to save the database. The
bottom part concerns what you will name the
database.

At the bottom of the dialog box, notice that the File
name box probably contains db1. Before you begin
working on a new database, you must name it. db1 is 
the name that Access proposes.

4. You are going to change the proposed name of the
database. Whenever text is highlighted, it will be
replaced automatically by what you type next.

Verify that the contents of the File name text box
are highlighted.

Type High School (do not tap the ENTER key).

Note: Da ta base files are saved au to mat i cally with
the ex ten sion mdb, which de fines it as a Microsoft
da ta base.

5. You are going to make sure that the file is saved to
your student folder.

Click the Save in drop-down list box.

A list of the drives (and folders on the Desktop)
available to you appears.

6. Your student files should be stored in the FLS
Access2003 Student Files folder on the C drive.
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In the list, click 
once on (C:).

A list of the 
files and folders on the 
C drive appears.

7. In the file and folder list
box, click once on the FLS
Access2003 Student Files
folder.

At the right of the dialog box, notice that the Create
button has turned in to an Open button, indicating
that the selected item can be opened.

8. Click the Open button.

The contents of the FLS Access2003 Student Files
folder appear. At the top of the dialog box, notice
that FLS Access2003 Student Files appears in the Save
in box.

9. Click the Create button.

The Database window for the new database file
appears. You have created a new database.
Currently, there are no objects in your database. As
mentioned in the last lesson, the three items in the
window, beginning with Create table in Design view,

are not objects but merely alternative methods of
performing functions that more traditionally are
started by clicking a button on the toolbar above
them. In this course, you will use the toolbar
buttons.
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Creating a
Table

Once you create a new database file, usually the next step is to
create a new table. You are going to create a new table to store
student information for the school.

1. On the Database window, verify that the Tables tab 
is selected.

2. On the Database window toolbar (the one directly
below High School: Database), click the
New button.

The New Table dialog box appears.

At the right of the dialog box, notice the different
options for creating a new table. In the Beginning
Course, you will work with the first two options.

3. In the list box, choose Design View and then click
OK.

The Table1: Table design window appears.

You can use the table design window to define the
fields for the table. It is divided into two areas, or
panes. The top pane lists the existing table fields. It is 
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divided into three columns with the headings Field
Name, Data Type, and Description. Each field that you 
create will appear in a separate row of this design
grid. The small triangle at the left indicates the
selected field.

The bottom pane (called the Field Properties pane) is 
where information about the selected field appears.
The left part of the pane contains two tabs — the
General tab and the Lookup tab. Since there are no
fields defined, these tabs are empty. The right side
of the pane contains context-sensitive help. As you
are defining the fields, it is a good idea to look at the 
messages that appear here.

Naming
Fields

Before defining the fields, it is a good time to discuss guidelines
that should be followed when naming fields and objects (such as a
table or a query) in Access.

! Names cannot be longer than 64 characters.

! Names cannot include the following five
characters:  .  !  ‘  [   ]

! Names cannot begin with a space.

Although allowed, most experts agree that you should avoid using
spaces when naming fields or objects. For example, a field that will
be used to store a student’s last name should be called LastName
instead of Last Name. As you will learn, field names are used in
many different instances. If you use spaces in your field names,
people might think that your are referring to two separate fields
(e.g., the Last field and the Name field) instead of a single field.

In the Intermediate Course, you will learn about the Leszynski
Naming Conventions (LNC), which is a common standard used to
name Access objects.

Defining
Fields

Your table will contain six different fields relating to student
information. The first field that you define will be for the last name
of the student.

1. The insertion point should be in the Field Name
column of the first field row.

2. Type: LastName
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3. After you have named the field, you must define the
type of data (i.e., information) that the field will hold.

Tap the TAB key to move to the Data Type column.

The insertion point moves to the Data Type column,
with Text highlighted. This is the default data type.
In the next lesson, you will use other data types.

In the Field Properties pane, notice the text boxes
that appear in the General tab. These are used to
help define the characteristics of the field.

4. The Description column is used to write a brief
description of the field. As you will see, these
descriptions appear on the Status bar as you use the
database. Although optional, it is a good habit to use
the column to help people who work with the
database.

Tap the TAB key to move to the Description column.

5. Type: Last name of student

You have entered the essential information that
Access needs to create the LastName field. Before
creating the next field, you are going to use the Field 
Properties pane to customize the LastName field.

6. In the Field Properties pane, click an insertion
point in the Field Size text box.

When a new text field is created, it is assigned the
default length, which is usually 50 characters.

7. You are going to change the Field Size to 20.

Delete the contents of the Field Size text box.

8. In the Field Size text box, type: 20

You will not use the other items in the Field
Properties pane at this time.

Note: A text field can be a max i mum of 255
char ac ters long.

9. You can use the F6 key to switch between panes.

Tap the F6 key.

The insertion point moves to where it was last
located in the top pane.
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10. To create a new field, simply move the insertion point
to the next row.

Tap the TAB key.

The insertion point moves to the Field Name column
of the next row.

11. You are going to create the second field.

Type FirstName and then tap the TAB key.

12. With Text selected in the Data Type column, tap the
TAB key to move to the Description.

13. Type: First name of student

14. You are going to change this field size to 15.

Tap the F6 key to switch panes.

The contents of the Field Size text box should be
highlighted.

15. Change the contents of the Field Size box to: 15

16. Tap the F6 key to switch back to the top pane.

17. Tap the TAB key to move to the Field Name column
of the next row. 

18. In the same manner, define the following fields:

Field Name Data Type Description Size

Address Text Include Apt # 40

City Text Use city borough 20

State Text State of student 2

Zip Text Zip code 5

When finished, the top pane should look like the
following:
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Saving the
Table Design

The table that you have designed exists only in memory. To keep it
as an object in the High School database, you must save the design.

1. On the File menu, choose Save.

The Save As dialog box appears.

A similar dialog box appears whenever you save a
database object for the first time. Notice that Access
indicates that you are working on a table and it
proposes the generic name of Table1.

2. With Table1 highlighted in the Save As dialog box,
type: StudentInfo

StudentInfo replaces the contents of the Table Name
text box.

3. Click OK.

An alert box appears indicating that there is no
primary key defined for the table. You will learn
more about primary key fields in the next lesson. For 
now, you are not going to define one.

4. Click the No button.

The table design is saved.

5. You are going to view the table in a moment. For now,
you are going to close the table design window and
return to the Database window.

On the File menu, choose Close.

You are returned to the Database window. Notice
the StudentInfo table that you just created.
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Tip: You can al ways close a win dow by click ing the
win dow’s Close box. Al ter nately, you can use the
key board com bi na tion CTRL/W.

Adding
Records to a 
Table

So far, you have only designed the table structure — you have yet
to enter any information in the table. You are going to view the
table you just created and then add some records to it.

1. The Tables tab of the High School Database window 
should be selected.

2. Click the StudentInfo table object to select it.

3. Click the Open button.

The StudentInfo table window opens.

There are no records in the table at this time. At the
top of the table, however, notice the names of the
fields that you created in the table design window.

 The table design window allows you to view the structure of the
table. This is referred to as Design View. The current window allows 
you to view the contents of the table. This is called Datasheet View.
Many Access objects have a Design View and a Datasheet View.

1. You can use the View menu to switch between
Datasheet View and Design View.

On the View menu, choose Design View.

The Design View window appears.

2. You are going to switch back to Datasheet View and
then enter some records into the table.

On the View menu, choose Datasheet View.

Once again, the StudentInfo table appears in
Datasheet View.
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You are ready to add some records to the table.

1. Verify that the insertion point is in the LastName
field.

On the Status bar, notice the message Last name of
student. This is the description of the field that you
entered when you designed the table.

2. Type: Young

Notice that a new row is added to the end of the
table. This new row indicates the end of the table
(notice the asterisk symbol to the left of the row). In
addition, notice that the Record Indicator is replaced 
by a pencil symbol. The pencil symbol appears
whenever the current record is being modified.

3. Tap the TAB key to move to the FirstName field.

On the Status bar, notice the description of the
current field.

Tip: If you pre fer, you can tap the ENTER key
in stead of the TAB key to move to a new field.

4. In the FirstName field, type Jamaal and then tap the
TAB key.

5. In the Address field, type: 700 East 82 Street

As you typed the address, notice that the text in the
field scrolled. Remember, although all of the field
columns in Datasheet View are the same width, the
fields themselves have different sizes. When you
designed this table, you created the Address field
with a size of 40 characters.

6. Tap the TAB key to move to the next field.

7. In the City field, type Brooklyn and tap the TAB key.

8. In the State field, type NY.

9. Since this field was defined with a length of two
characters, Access will not let you type more text into
the field.

With the insertion point still in the State field, try
to type a few letters.
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Your computer makes a sound, indicating an error.

10. Tap the TAB key to move to the next field.

11. In the Zip field, type 11244 and then tap the TAB
key.

Since you were in the last field of the record, tapping 
the TAB key moved you to the first field of the next
record. When the Record Indicator moves out of a
record that is being modified, any changes are saved 
automatically — you do not have to worry about
saving the record manually.

12. In the same manner, enter the remaining records
(indicated below) into the table. You have already
typed the first record. When finished, you should
have a total of ten records.

13. On the File menu, choose Close in order to close the 
Datasheet view window.

You are returned to the Database window.

Closing and
Opening
Databases

Only one database file can be open at a time. This means that in
order to work with a different database, the active one must be
closed. You are going to close the High School database and then
look at the different options available for opening a different
database.

1. On the File menu, choose Close.

Only the Microsoft Access application window
appears on your screen.

2. Click the File menu.

Notice the options on the menu.
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3. Choose New.

The New File task pane appears. 

4. On the New File task pane, under Templates, click
On my computer.

The Templates dialog box appears.

Once again, the contents depend upon how your
computer is set up. Most likely, the Blank Database
icon appears somewhere. By selecting this icon and
then clicking the OK button, Access will open a new
(empty) database. This works just like the Blank
Access Database option on the New File task pane.

5. Click the Databases tab.

Notice the different items on the tab. (You may need 
to scroll the list box to view all of the items.) These
are the Database Wizards that can be used to create
databases. You are not going to use any of these at
this moment.

6. Click the Cancel button to close the New dialog box 
without opening a new database.

7. The Open Database command allows you to open an
existing database.

On the File menu, choose Open.

The Open dialog box appears. You used this in the
previous lesson to open an existing database. You
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will learn more about this dialog box in the
Intermediate course.

8. Click the Cancel button to close the Open dialog
box without opening a database.

9. Finally, the File menu provides you with a quick way of
opening recently used databases.

Click the File menu.

At the bottom of the File
menu, notice the recently 
used file list. 
(Your list is probably
different than this example.) 
By default, Access displays
the four most recently used
databases. This provides you with a quick way of
opening a database.

10. On the File menu, choose High School.

The database is opened.

Note: If a da ta base is al ready open and you try to
open an other, Ac cess will first close the ac tive
da ta base. If there are changes that might need to be
saved, you will be prompted with an alert box.

11. On the File menu, choose Close to close the High
School database.

Review
Exercise

To review the concepts presented in this lesson, you are going to
create a new database for personal contacts, create a table, and then 
add 10 records to the table. If you are unsure of how to accomplish
one of the steps, refer to the lesson.

1. Open a blank database.

Note: You can use the New com mand on the File
menu to open the New File task pane. Blank da ta base
is the first option on the task pane.

2. When the File New Database dialog box appears,
verify that the database will be saved in the FLS
Access2003 Student Files folder.

3. Name your database Contacts and then click the
Create button.
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4. With the Tables tab selected, click the New button
and then choose to create your table in Design
View. 

5. Use the table design window to create the
following fields. (You should indicate your own
description of the fields.)

Field Name Data Type Field Size
FirstName Text 15
LastName Text 25
Company Text 30
Street Text 40
City Text 25
State Text 2
Zip Text 5

6. Before continuing, you should save the table design.

On the File menu, choose Save.

7. Use the Save As dialog box to name your table
BusinessContacts.

8. When the alert box appears indicating that there is 
no primary key defined, click No.

9. Once the table design is saved, you are prepared to
enter some records.

Use the View menu to switch to Datasheet View.

10. Add the following five records to the table:

11. Close the Datasheet view of the table.

12. Close the database and exit Access.

End of Lesson 2
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