


The
AutoForm

You have already learned two techniques by which to create a form 
— either through the Form Design window or through the Form
Wizard. In addition to these methods, Access provides a third
technique — the AutoForm feature.

You are going to use the AutoForm to create a form from the
StudentInfo table.

1. Open the Form Design database.

2. In order to use the AutoForm, a table must be selected.

On the Database window, select the Tables tab.

3. Click on the StudentInfo table to select it.

4. On the Insert menu, choose AutoForm.

Notice the form. Unlike the Form Wizard, you are
not given the opportunity to choose the layout or
style of the form.

5. You are going to save the form.

On the File menu, choose Save.

6. Verify that the Form Name is StudentInfo and click
OK.

7. Close the form.

8. Select the Forms tab and notice the new form
object.

You can also create an AutoForm from the New Form dialog box.
You are going to create a different AutoForm for the Electives table.
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1. When you use the New Form dialog box, a table does
not have to be selected.

On the Insert menu, choose Form.

2. In the list box, choose AutoForm: Tabular.

3. Click the drop-down list box at the bottom of the
dialog box and choose Electives.

4. Click OK.

Notice the tabular AutoForm.

Instead of appearing in a column, the fields of the
records appear in a row, creating a table effect.
Notice that the format of the form is whatever was
last applied (in this case, what you applied when
using the Form Wizard in the last lesson).

5. You are not going to save this form.

On the File menu, choose Close.

6. When the alert box appears click No.

The form is not saved.

Note: You can use the New Ob ject but ton 
on the Form View toolbar to cre ate an
AutoForm. To do this, se lect a ta ble or query, click
the but ton’s down ar row, and then choose
AutoForm. (Since AutoForm is the de fault, you can
also just click the but ton.)
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Working in
Form Design
View

Although the wizards do a fine job of creating basic forms, you
may need to modify the form — either by changing the layout of
fields, adding fields, or deleting fields. In order to do this, you
must be comfortable with some basic elements of Form Design
view.

You already used Form Design view to create your own form. You
are going to learn more about working in Form Design view.

1. On the Database window, select the StudentInfo
form.

2. Click the Design button.

Notice the form in Form Design View.

You have already used the View menu to display certain items on
the Form Design window. You can also use buttons on the Form
Design toolbar. 

1. Click the Field List button (if necessary) 
to display the window.

The button should appear
highlighted. Notice the Field List
window. As you already learned,
you can use this at any time to add
fields to your form.

2. Close the Field List by clicking the
Close button on its Title bar or by clicking the Field 
List button again.
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3. Click the Toolbox button (if necessary) 
to display the toolbox.

The button should appear highlighted. 
Notice the Toolbox toolbar. In this
example, it is floating. 
You will be using this to select control
objects.

4. Click the Properties button 
(if necessary) to display the 
window.

Notice the Properties window.

This window displays the properties of whatever is
selected in the Form Design window. It can be used
to change many options for the selected object. It is
similar to the Properties pane on the Table Design
window.

5. Close the Properties window by clicking its Close
button or by clicking the Properties button again.

Selecting
Control
Objects

You already know that the items on the form are called control
objects. Control objects are divided into three categories: bound
controls, unbound controls and calculated controls. You will work with 
the first two types at this time. 

A bound control is directly “tied” to a field in a table or query. This 
is why you are able to use a form to modify the contents of a table.
Bound controls can take many different forms, but the most
common type is a text box.

An unbound control is used primarily for informational purposes.
Unbound controls are not “tied” to a field in a table or query. They
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are usually used to label bound controls (so you know what
information goes where) or to organize the form (by adding lines to 
separate parts of the form, or give general instructions about the
form). The most common type of unbound control is a field label.

Control objects can be formatted and rearranged on the form. In
order to do these things, the objects must first be selected. You are
going to use different techniques to select bound and unbound
controls.

1. The quickest way to select a control is with the mouse.
Before doing this, you should verify that the Select
Objects button of the Toolbox toolbar is selected.

On the Toolbox toolbar, click the Select
Objects button.

2. Point to the StudentID bound control (i.e.,
the text box) and click.

Notice that the control is selected. You can see the
selection handles around the text box. In addition,
notice the selection handle near the StudentID label,
indicating the associated unbound control.

3. Point to the LastName bound control and click.

The bound control is selected.

4. Click the FirstName label (the unbound control) to
select it.

The label is selected.

You can also use the Formatting (Form/Report) toolbar to select
controls. This is convenient if there are many controls on the form
design. (If the Formatting toolbar is not displayed, right-click any
toolbar and choose it from the Shortcut menu.)

1. At the left of the Formatting toolbar, click the
Object drop-down list box.
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Notice the different items in the
list box.

2. In the list box, select Label11.

On the form, notice that the State
label is selected. By default, labels
are given generic names. This is
the 11th item on the form.

3. On the Formatting toolbar, click the 
Object drop-down list box and
choose City.

Notice that the City bound control is selected.

Modifying
the Form

You are going to modify the StudentInfo form by rearranging the
controls and adding some graphic elements.

Moving and
Deleting
Controls

The easiest way to move controls is to simply drag them with the
mouse. You are going to rearrange the City, State, and Zip controls
so that they appear on the same line.

1. Select the State bound control.

2. You are going to move only the bound control — not its 
associated label. To do this, you must position the
pointer so that a hand with an extended finger appears.

Point to the upper left corner of the State
bound control, until the 
pointer looks like this:

(If an opened hand appears, 
the label will move with the text box.)

3. Drag the State bound control so that it
appears to the right of the City bound control. The
grid will expand when you release.

If the State label moved with the bound control,
choose Undo from the Edit menu and try again.

4. Select the Zip bound control.

5. In the same way as above, move only the Zip
bound control so that it appears to the right of the
State bound control. Again, do not worry if there is
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not enough room on the grid — it will be resized
automatically.

6. You are going to delete the State and Zip labels at the
same time. To select multiple controls, you must hold
down the SHIFT key (not the CTRL key).

Select the State label (the unbound control).

7. Hold down the SHIFT key.

8. Select the Zip label (the unbound control).

9. Tap the DELETE key to remove both labels from the 
form.

The labels are deleted. The bound controls remain,
however.

Note: Re mem ber, a form is sim ply an other way of
man ag ing the in for ma tion in a ta ble. If you de lete a
con trol on a form, the data is not af fected. How ever,
if you de lete a bound con trol, you will not be able to
use the form to view, mod ify, or en ter in for ma tion
for the field to which the con trol is bound.

10. If necessary, resize the Form Design window to see 
more of it.

You can change what a label says. You are going to modify the City
label so that it reads City, State, Zip.

1. Select the City label.

2. On the label, point near the right of City, until the
pointer turns into an I-beam.

3. Click.

Notice that the City label is more 
prominent and there is an insertion point
at the end of City.

4. Type: , State, Zip

5. Tap the ENTER key.

Notice the changes to the label.
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You are going to eliminate the open space in the form by moving
the DOE, Grade and HomeRoom controls.

1. Select the DOE bound control.

2. While holding down the SHIFT key, select the Grade
and the HomeRoom bound controls.

The three bound controls should be selected.

3. Point to one of the selected bound controls until
the pointer turns into an open hand.

When the pointer is in the shape of an open hand,
the controls and their associated labels can be
moved at the same time. When the pointer is in the
shape of a hand with an index finger pointing, only
a single control can be moved.

4. Later, you are going to add a box around the selected
objects. Therefore, when you move them, be sure to
leave a little space for the box.

Drag the selected objects up and to the right a bit
(as in the example below).

5. Click anywhere outside of the selected objects.

The form should look like the following:
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Changing the
Size of
Controls

When you create a form using the Form Wizard or the AutoForm
feature, the size of the control depends upon the Field Size setting in 
the Field Properties pane of the Table Design window. At times,
this may not fit the needs of your form. You can adjust the size of
any of the controls on the form.

You are going to make the Grade and HomeRoom bound controls
smaller.

1. Select the Grade bound control.

2. Carefully point to the black handle in the middle of 
the right border of the control object, until the
pointer turns into a double-headed horizontal
arrow.

3. Drag about 1/2 inch to the
left.

The control object has been
resized so that it takes up less room on the form.
You may have noticed that the rulers show black
areas, indicating the control's position, to help you
move or size the control. In re-sizing the control
object, you have not altered the information that it
displays, however.

4. Select the HomeRoom bound control.

5. In the same way, adjust the size of the control to
match that of the Grade control object.

6. Adjust the width of the State bound control so two
characters only can fit into it, approximately.

7. Move the Zip bound control so it is directly to the
right of the State bound control. Resize it so it can
hold approximately nine numbers.

The two bound controls should look similar to the
following:

8. You can also change the size of the form by dragging its 
edges.
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Point to the right edge of the form until the pointer 
turns into a double-headed horizontal arrow.

9. Drag to the left until the right border is
near the end of the Zip bound control.

10. Do the same for the bottom edge of the
form.

Adding a Box You can easily add boxes and lines to your forms. These can help
organize related controls so the form is easier to view. You are
going to add a box around the controls that you just moved.

1. On the Toolbox toolbar, click the 
Rectangle button.

The Rectangle tool allows you to draw boxes
on your form. The boxes are unbound controls.

2. On the form, point above and to the left of the DOE
label. Be sure that it is the label and not the bound 
control.

Notice that the pointer has turned into a 
cross with a rectangle attached to it.
This reminds you that you are about to
create a box.

Tip: If you no lon ger want to cre ate a rect an gle, you
can click the Rect an gle but ton or the Select Objects
button on the Tool box toolbar to turn it off.

3. Drag down and to the right until the outline of the
box surrounds the group of controls.

4. Click in a blank part of the form to remove the
selection.

The form should look like the one on the following
page.

Note: You can resize the box by selecting it, pointing 
to the black handles, and dragging them as you have 
learned. If you want to re draw the box, se lect it, tap
the DELETE key, and try again.
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5. Before continuing, you are going to take a look at your
redesigned form in Form View.

On the View menu, choose Form View.

Notice the redesigned form. The box helps to offset
the school information from the other fields.

6. You are going to make some more modifications to the 
form design.

On the View menu, choose Design View.

Applying Text 
Format to
Controls

You are going to format the StudentID field so that the data will
appear in boldface. This will help make it stand out on the form.

1. Select the StudentID bound control.

2. On the Formatting toolbar, click the Bold button.

Notice that the contents of the control appear in
boldface text.

Note: In the same man ner, you can use the other
but tons and drop-down list boxes to for mat con trols. 
These but tons work just like they do when
for mat ting datasheets, so you will not use them at
this time. Un like datasheets, how ever, you can
for mat in di vid ual con trols on a form.
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Adding a
Form Header

So far, all of the information that you have placed on the form
design has been in the Detail section. In addition to the Detail
section, however, forms can have up to four other sections. Here is
a summary of these different sections.

! Form Header. Used for information (such as the title of the 
form) that will appear at the top of the form on the
screen.

! Form Footer. Used for information (such as totals of
values) that will appear at the bottom of the form on the
screen.

! Page Header. Used for information (such as the date) that
will appear at the top of every page if the form is ever
printed.

! Page Footer. Used for information (such as the page
number) that will appear at the bottom of each page if
the form is printed.

Since forms are not usually printed, Page Headers/Footers are not
always included in the form design. It is common, however, to
include information in the Form Header section. You are going to
add a form title to the Form Header section.

1. On the View menu, choose Form Header/Footer.

Notice the two new sections on your form design.
(You might need to scroll to see both sections or you
might need to enlarge the window.) Nothing has
changed in the Detail section — the entire section
has simply been shifted down.
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Note: If the Form Header sec tion is al ready
dis played but there is no room be tween it and the
De tail sec tion, point to the line
be tween the two sec tions and
then drag down about 1/2 inch.

2. The title of the form will be an unbound control (more
specifically, a label). Controls are created using the
buttons on the Toolbox toolbar.

On the Toolbox toolbar, click the Label
button.

3. Drag the pointer to the Form Header section. (Do
not click yet.)

The pointer is in the shape of a
cross with a letter A attached. 
This reminds you that you are
going to add a label to the form.

4. Before typing the label, it is a good idea to choose the
font size and style for the text.

On the Formatting toolbar, click the Font Size
drop-down list box and choose 12.

5. On the Formatting toolbar, click the Bold button.

The label will have a size of 12 points and be
formatted in bold.

There are two ways in which to create the label. You
can use the Label tool to drag and create a “box” of a 
specific size to store the label. This technique is often 
used when there is a fixed amount of horizontal
space on the form. If the label is long, the text will
automatically wrap to a new line when it reaches the 
end of the label “box.”

Another technique is to simply click the mouse.
Access will then make the Label box as long as
needed. The text will not wrap, however, until it
reaches the edge of the form. This method is often
used when the label is not very long.

6. You are going to use the second technique.

Point to the upper left corner of the Form Header
section and click.
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Notice the thin Label box containing 
the blinking insertion point. 
You are ready to type the label.

7. Type: Student Information

The Label box adjusts itself as you type.

8. Click outside of the label that you just added.

9. If necessary, move the label that you just added so 
that it is positioned as follows:

10. You are going to look at the redesigned form.

On the Form Design toolbar, click the View button
to switch back to Form View.

Notice the redesigned form with the Form Header
section and the StudentID in boldface.

11. When you modify a form, the window that holds the
form may no longer fit the form very well — there might 
be scroll bars, or an excessive amount of empty space.
Access can adjust this for you.

On the Window menu, choose Size to Fit Form.

The window adjusts to fit the form. Since this is a
small form, scroll bars no longer appear.
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Note: If this com mand is not avail able, your Form
win dow is max i mized. Click the Form win dow’s
Re store but ton and try again.

12. Click the Next Record button a few times.

Notice that the Form Header appears at the top of
each form and that the contents of the StudentID
field are in boldface.

You are going to save the redesigned form with a new name.

1. On the File menu, choose Save As.

The Save As dialog box appears. 

2. Change the contents of the New Name text box to:
NewStudentInfo

3. Click OK.

The redesigned form has been saved as a new
Access object.

4. Close the Form window.

Notes It is important to understand that when you modify the
control objects in any way, you are not changing the fields to
which those control objects are tied. Rather, you are simply
changing the way in which the fields — however they might
be formatted in the Table Design window — are displayed
on the particular form.

If you prefer Datasheet view, you can look at the form in
Datasheet view as well. Simply choose Datasheet on the View
menu.

Review
Exercise

To review the concepts presented in this lesson, you are going to
create a new form based on the Electives table and then modify the
form design in several ways.

1. The Form Design Database window should be open.

2. Use the AutoForm to create a new (columnar) form
based on the Electives table.
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3. The form probably has the same Expedition format
you used at the end of the last lesson. To change
this, switch to Design view, click the Format menu,
and choose AutoFormat. On the AutoFormat dialog
box choose Standard and click OK.

4. Save the form as NewElectivesForm.

5. You are going to redesign the form so that it looks like
the example on the next page.

Open the form in Design View. You might want to
maximize the window to help you work.

6. Referring to the example below, move the
Comments label to the right of the form.

7. Move and re-size the Comments bound control
underneath the Comments label.

8. Re-size the Period bound control so it is smaller.

9. Move the Teacher and Room controls up.

10. Use the Rectangle button to place a box around the 
Teacher and Room controls.

11. In the Form Header section, add the title to the
form. It should be formatted in a bold, 14 point font.

12. Switch to Form view.

Your form should look similar to the following:

13. If the window is maximized, click the Restore
button.

14. Use the Size to Fit Form command to adjust the size.

15. Save the changes to the form before closing it.

End of Lesson 12
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