


Designing a
Form

 So far, you have worked with two Access objects: tables and
queries (filters are not considered objects). Forms are another type
of object. Forms provide you with a way of viewing, entering and
editing information in tables. As you might expect, Access
provides you with a number of different ways in which to create
forms.

First, you are going to manually create a form using Design View.
Later, you will use the Form Wizard to create forms.

1. Open the Forms database.

2. Before creating the form, you are going to look at the
table on which the form will be based.

On the Database window, select the Tables tab.

3. Double-click the Electives table to open it.

Notice the records in the table. Although you can
work with these records in Datasheet View, forms
can present the records in a more organized manner.

4. Close the table.

5. You are going to create a new form based on the table
that you just opened.

On the Database window, select the Forms tab.

6. Click the New button.

The New Form dialog box appears. Notice the
various ways in which you can create a form. 

7. You are going to begin with Design View.

In the list box, verify that Design View is selected.
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8. Forms can be based on a table or a query. You will
design one based on a query later.

At the bottom of the dialog box, click the
drop-down list box.

Notice the different tables and queries available in
the database.

9. Choose Electives and then click OK.

The Form Design window appears. (Yours may look 
slightly different from the following.)

In the Form Design window, notice the grid-like
structure. This is where you will create the form.
Currently, you may see only one part of the form —
the Detail section. This is the section that holds the
various fields from the table or query. You will learn 
more about other sections in the next lesson.

In addition to the Form Design window, there might 
be a floating toolbar on the screen. Any toolbar can
be displayed in this manner by simply dragging it
from its “docked” position.

There may be other items displayed on your screen
as in the previous example. You will learn more
about these later.
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10. If there is a Form dialog box on the screen, as in
the previous example, click its Close button (X).
You will not be needing it.

11. To help you design your form, you are going to verify
that certain items are displayed.

Click the View menu.

12. Verify that Field List is chosen. Its icon should be
highlighted. If it is not, click on Field List to display
the Field List box.

Notice the Field List box 
for the Electives table. You will use
this to place fields on the form.

13. Click the View menu and verify that
Toolbox is selected. If it is not, click
on Toolbox to display the Toolbox toolbar.

Notice the Toolbox toolbar.

Note: If you can not see the Tool box
toolbar, it might be docked on the
side of the screen. If this is the case,
point care fully to its bor der (or any
other blank area of the toolbar) and
drag it to wards the Form De sign
win dow.

14. On the View menu, verify that the
Ruler and Grid items are selected. If
they are not selected (there should be a check
mark next to each one), select them at this time.

The ruler and grid will make it easier to line up the
different fields on the form.

15. If necessary, position the Field List box and the
Toolbox toolbar so that you can see all of the form.

Adding Fields 
to a Form

Although a form can contain many different items — such as a
company logo, instructions, or a warning — its primary purpose is
to display the fields from a table or query. There are various ways
in which you can add fields to your form. One of the easiest ways
is to use the Field List box.

You are ready to design the form. You are going to design the form 
so that it looks similar to the form below.
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1. In the Field List box, select CourseID.

2. In the following steps, do not release the mouse button 
until specified.

Without releasing the mouse, carefully drag the
CourseID field onto the form design window.

Notice that the pointer turns into a small field box,
indicating that a field is being positioned.

3. Position the CourseID field on the form so its left
edge is at 1 1/2 inch on the top ruler and its top
edge is at 1/4 inch on the left ruler.

4. Release the mouse button.

Notice the field. By 
default, Access creates a 
text box for the selected 
field. This is called a control 
object. Control objects come 
in different shapes (e.g., text boxes, list boxes) and
are often used to hold information from a table. 

In addition to the text box, Access places a label with
the corresponding field name. The label is another
type of control object, usually used to identify the
contents of the field. For now, we will simply refer
to these as labels.

5. You are going to add the next field to the form.

In the Field List box, select the Name field.

6. Carefully drag the Name field so that it is
positioned just underneath the CourseID control
object. Be sure to leave a little room.
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As with the CourseID field, Access creates a control
object and a label.

7. In the same way, select the Period field from the
Field List box and then drag it just underneath the
Name field.

8. You can place the fields in any order. You are going to
place the Teacher field next.

Select the Teacher field in the Field List box and
then position it just underneath the Period field.

9. Select the Room field in the Field List box and then
position it just underneath the Teacher field.

10. Finally, you are going to place the Comments field.

Select the Comments field from the Field List box
and place it to the right of the CourseID field, at
approximately 3 3/4 inches on the top ruler.

Your form should look approximately like the one
below.

Notice the control object and the label for the
Comments field. Notice that the control object for the
Comments field is larger than the other control
objects. This is because the Comments field is defined 
as a Memo data type. In the next lesson, you will
learn how to format and resize control objects.

You are going to take a look at your form.

1. On the View menu, choose Form View.

Notice the form that you just designed. By default,
Access displays the first record in the form.
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At the bottom of the form, notice the Record Control 
buttons. These have the same function that they
have with datasheets.

At the left of the form, notice the Record Selection
bar. As with Datasheet view, the black triangle
indicates the active record. (Only one record appears 
on the form at a time.)

Saving a
Form

Before working with a form, it is a good idea to save it. You save a
form just as you would save any other Access object.

1. On the File menu, choose Save.

The Save As dialog box appears.

2. Change the contents of the Form Name text box to
MyElectivesForm and then click OK.

The form has been saved.

3. Close the form.

You will learn more about designing and modifying
forms in the next lesson. For now, you are going to
practice working with your form.

Working
with Forms

Most of the techniques that you have learned with datasheets,
filters, and queries can also be used when working with forms. You 
are going to review some of the most common techniques.

Navigating
the Form

You navigate through the records in a form much in the same way
that you navigate in a datasheet.

1. Double-click the MyElectivesForm form to open it.
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2. Tap the TAB key a few times.

Notice that the insertion point moves from field to
field on the form.

3. Click the Next Record button.

Notice that the second record is displayed.

4. You are going to use the Record Number box to go to
record 7.

Change the contents of the Record Number box to 7
and then tap the ENTER key.

Notice record 7.

5. Click the First Record button.

You are returned to the first record in the
table.

Entering and
Modifying
Information

As mentioned, you can use a form to add, delete, and modify
records. Of course, all of this can be done using a datasheet. Forms
can make this work easier, however. You are going to use your
new form to add, delete, and modify some of the records.

1. Click the Add New Record button.

Access moves to the end of the table. New records
are always added at the end of the table.

Tip: You can also add a new re cord by choos ing New
Re cord on the In sert menu.

2. Enter the following information into the fields. As
you do so, notice the description of each field on
the Status bar.

CourseID: EL015
Name: Basketball
Period: 2
Teacher: Williams
Room: Gym
Comments: Must wear proper clothing

As you enter the information in the Comments field,
notice that Access places a vertical scroll bar in the
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field. Remember, Memo data types can hold up to
64,000 characters.

3. Tap the TAB key to save the record.

The record has been added to the Electives table and
the insertion point moves to a new record. If you
were to open the table in Datasheet view, you would 
see the new record at the end of the table.

You are going to modify one of the records. You can modify
records using the same techniques that you used earlier when you
modified the records in Datasheet View.

1. Use the Record Number box to go to record 14.

2. Change the Period field to: 2

3. Change the Room field to: Auditorium

Tip: Re mem ber, you can al ways use SHIFT/F2 to
open the Zoom win dow. This can make it eas ier to
edit long ex pres sions.

4. Notice that the Record Selection bar displays a pencil,
indicating that the record is being edited.

Use SHIFT/ENTER to save changes to the record
without leaving it.

The pencil is replaced with a triangle. The changes
have been saved.

You are going to delete the record that you added earlier.

1. Click the Last Record button.

Notice the record that you added.

2. Click the Record Selection bar to select the record.

3. Tap the DELETE key.

An alert box appears asking you to verify the action.
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4. Click Yes.

The record is deleted. Since Access was at the end of
the table, it is now prepared to add a new record.

5. Click the First Record button to return to the
beginning of the table.

Tip: You can also de lete a re cord by se lect ing it and
then choos ing Cut on the Edit menu.

Applying
Filters

The filtering techniques that you used when working with table
datasheets can be used on forms. You are going to take a look at
some of these techniques again.

1. The first record is for an elective that meets during the
first period. You are going to display all electives that
meet during this period.

Click an insertion point in the Period field.

2. On the toolbar, click the Filter By 
Selection button.

Notice, by the Record Control buttons,
Access indicates a total of three records and that the
table is filtered.

3. Navigate through the records and notice that only
electives meeting during the first period are
displayed.

4. On the Form View toolbar, click the 
Remove Filter button 
to display all records again.

You are going to use the Filter By Form command to display
electives that meet in the gym or in the art room.

1. On the toolbar, click the Filter By 
Form button.

The form is duplicated so that you can enter
criteria in the appropriate fields. As with table
datasheets, criteria entered on the same filter grid
(or form) are combined using the AND operator.
Criteria on different filter grids (or forms) are
combined using the OR operator. Notice the Look for
and Or sheet tabs at the bottom of the form.
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2. First, you are going to clear the current filter criterion.

On the toolbar, click the Clear Grid button.

3. Click an insertion point in the Room field.

Notice that a drop-down list box button appears.
You can enter the criterion manually or you can
choose one of the existing values from the list box.

4. Type: Gym

5. Click the Or tab.

6. In the Room field, type: Art

7. On the Filter/Sort toolbar, click the Apply
Filter button.

8. Scroll through the records.

Notice that only the records of electives meeting in
the gym or the art room are displayed. Also notice
that the number of filtered records is displayed at
the bottom of the window.

9. Click the Remove Filter button to remove the filter.

10. On the File menu, choose Close to close the form.

Notes You can also filter records using the comparison operators
that you used in the last lesson. 

The Advanced Filter/Sort feature works with forms just as 
it does with table datasheets. In both cases, choosing this
command brings you to the same Advanced Filter/Sort grid
that you used in Lesson 8.
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Remember, all of the searching and sorting techniques that
you used on datasheets can be used on forms as well. If you
feel the need, practice using the Find, Replace, Sort, and Go To
features while working with forms.

Although they are primarily intended for use on the
computer screen, you can print forms just as you printed
table datasheets in an earlier lesson.

The Form
Wizard

The Form Wizard can help you quickly create a simple form. You
are going to use the Form Wizard to create a form to help you edit
the information in the StudentInfo table.

1. With the Forms tab of the Database window
selected, click the New button.

2. On the New Form dialog box, select Form Wizard.

3. At the bottom of the dialog box, click the
drop-down list box and choose StudentInfo.

4. Click OK.

The Form Wizard begins. After a few moments, the
first dialog box appears.

This dialog box works much like the Simple Query
Wizard dialog box. Notice that the Tables/Queries
drop-down list box contains the table you selected
earlier. The Available Fields list box contains the
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fields in the selected table (or query). The Selected
Fields list box contains the fields that will appear on
the form.

5. You are going to put all the fields on the form.

Click the Move All Fields button.

All the fields move to the Selected Fields list
box.

6. Click the Next button.

The next dialog box appears. You are asked to
choose the type of layout for the form. The default
option is Columnar. Notice the sample of how a
columnar form will look — the fields (in lighter
gray) are listed in a column next to the field name
(in darker gray).

7. Select the Tabular option and notice the sample
look of the form.

8. Select the Datasheet option and notice the look.

9. Select the Justified option notice the look.

10. Select Columnar and then click Next.

The next dialog box (shown on the following page)
asks you to select a form style. There are ten preset
styles that are designed to give your form a
consistent look.

11. Select some of the different styles and notice the
samples.
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12. Select Standard and then click Next.

The last dialog box is displayed. You are given the
opportunity to name the form. By default, Access
will name it the same as the selected table.

13. Verify that the form will be named StudentInfo.

14. You are given the opportunity to open the form or to
modify the form design. You will learn more about
modifying the form design in the next lesson.

Verify that Open the form to view or enter information
is selected and then click Finish.

After a few moments, the StudentInfo form opens.
Notice that all of the table’s fields appear on the
form in a columnar layout. To the left of each field is 
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the field label. The Form Wizard has lined up the
different control objects and labels.

15. Navigate through the form and notice the different
records.

16. Practice applying different filters to the form.

17. Close the Form window.

Deleting a
Form

You can delete a form object just as you would delete any other
Access object. You are going to delete the StudentInfo form that you
just created.

1. In the Database window, select the StudentInfo
form object and then tap the DELETE key.

2. When the alert box appears asking you to verify
the action, click Yes to delete the form.

Tip: You can also choose De lete on the Edit menu.

Review
Exercise

To review the concepts presented in this lesson, you are going to
create a new form based on the Electives table and then use the
form to work with the information in the table.

1. The Forms Database window should be open.

2. Use the Form Wizard to start creating a new form
based on the Electives table.

3. The form should include all of the fields in the
table and should have a columnar layout.
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4. When you are asked to choose a style for the form, 
select the Expedition option.

5. Name the form NewElectives and finish the wizard.

Your form should look like the following:

6. Sort the records in alphabetical order by the course 
name.

7. Use one of the filter features to display only the
records of electives that meet during period 2.

8. Remove the filter.

9. Close the form.

End of Lesson 11
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